Introduction

 Bosch Logo

Introduction, goals of Integrus Transmitter Protocol

This specification describes the Bosch Conference Protocol for the DICENTIS Integrus Transmitter. This specification is intended to be used by developers who want to use this interface to develop a client application to control the functionality available.

The Bosch Conference Protocol is created to have an interface which is similar for the following Bosch conference product families:

  • DICENTIS Conference System

  • Integrus

  • DICENTIS wireless (future development)

  • CCS 1000D (future development)

So that solutions can be used across the Bosch conference portfolio.

The Protocol provides the information about which functions are available and how they are used.

Bosch Security Systems

(c) Bosch Security System B.V., 2024


License

Bosch License Statement of use:

This topic contains the following sections:

  • SOFTWARE LICENSE FOR:UNITED STATES OF AMERICA, CANADA, MEXICO, BRAZIL, ARGENTINA, PARAGUAY, URUGUAY, VENEZUELA, COLOMBIA AND ECUADOR
  • Software license for Russia
  • SOFTWARE LICENSE FOR ANY OTHER COUNTRY
  • Software maintenance Agreement
SOFTWARE LICENSE FOR:UNITED STATES OF AMERICA, CANADA, MEXICO, BRAZIL, ARGENTINA, PARAGUAY, URUGUAY, VENEZUELA, COLOMBIA AND ECUADOR

STOP!

PLEASE READ THE FOLLOWING TERMS AND CONDITIONS CAREFULLY

IF YOU DO NOT AGREE WITH THESE TERMS AND CONDITIONS, DO NOT REGISTER THE AUTHORIZATION CODES MENTIONED IN THIS DOCUMENT, INSTEAD, PROMPTLY REMOVE AND DELETE THIS DOCUMENT AND ASK FOR A FULL REFUND AT YOUR SUPPLIER

BOSCH SECURITY SYSTEMS B.V. LICENSE AGREEMENT FOR SOFTWARE

Bosch Security Systems B.V. (hereinafter referred to as “Bosch") licenses this computer program and all associated documentation (the “Software”) for your non-exclusive use subject to the following terms and conditions:

  1. LICENSE - Under the terms of this license:

    • You may use the Software only on a single computer at a time and only for the operation of Bosch products.

    • You may not modify, decompile, disassemble or reverse engineer the Software.

    • You may, not sublicense, lease or otherwise rent the Software without Bosch 's prior written consent.

    • You may make one copy of the Software solely for backup or archival purposes. No other copying of the Software or the accompanying documentation is permitted.

    • This license will terminate automatically if you fail at any time to comply with any of its terms or conditions. Upon termination, you shall immediately destroy the Software or return it to Bosch along with any copies you have made, and to delete any installed copy from your hardware.

  2. TRANSFER OF OWNERSHIP - You may transfer this license to another party only if you:

    • Also transfer this Agreement, the Software and all accompanying documentation and (by sale or lease) ownership of the associated Bosch hardware, if applicable

    • Require the other party to abide by the terms of this license agreement, and

    • Destroy all copies of the Software and any updates that you do not transfer to the other party.

  3. OWNERSHIP AND COPYRIGHT OF THE SOFTWARE - Although the media containing the Software is yours, the Software is owned and copyrighted by Bosch and/or its suppliers. You may not remove, change or delete the copyright notice from the Software. The Software contains confidential and trade secret information of Bosch. You will instruct your employees and others having access to the Software in and ensure their compliance with the terms of this agreement. You will use your best efforts to prevent any unauthorized copying of the Software.

  4. Updated: Bosch will be entitled to update and/or modify the Licensed Software.

  5. SECTION REGARDING FREE OPEN SOURCE SOFTWARE.

    • The software of the offered program possibly includes open source software and third party software under royalty free licenses (“FOSS”).

    • The FOSS in the program is subject to FOSS license agreements (“FOSS-Licenses”). Pursuant to these FOSS-Licenses, Bosch has to pass on to you their terms and conditions and you have to comply with these terms and conditions and fulfill respective obligations when using the FOSS in another way than merely installing and running it internally on your machines, e.g. through further disposal of the product, as by distribution, selling, or otherwise passing it on to a third party. The rights under the FOSS-Licenses are being granted to you, and in the event of you passing on a copy of the product to another party, the terms and conditions of the respective FOSS-Licenses apply to the distribution of any included FOSS (in some cases, the FOSS-License provides a direct license from the author/licensor of the FOSS to the third party). For many FOSS-Licenses, Bosch itself can neither grant nor obtain these rights for you. The applicable FOSS-Licenses are available on the internet address of the provider of the FOSS or will be made available by Bosch upon your request.

    • The FOSS itself does not contribute to the sales price of the program offered by Bosch and the FOSS is thus is provided without royalty or monetary compensation.

    • You have to, either expressly, or implied by amendment or adaptation of the FOSS, accept and take responsibility for your compliance with the applicable FOSS-Licenses. Further, you have to agree that updates or new versions of the software program may contain different or additional FOSS or changes in the FOSS-Licenses.

    • If any terms or restriction of this EULA conflict with the FOSS-Licenses or any other license conditions of Open Source Software included in this product, the terms and conditions of these Open Source Software licenses shall prevail.

  6. Responsibility for Webcasting

    You will be exclusively responsible for any liability arising from unauthorized access or alteration to the Webcast Data or Content. You will also be responsible for any liability arising from any material or data which has been Webcast that includes any threatening, defamatory, obscene, offensive or illegal material or any material which infringes any person's intellectual property rights. Except as expressly otherwise stated in the Agreement, we will not be responsible for any liability arising from the failure to Webcast any material or data.

  7. Purpose of Transmission

    • You will use the Services and Equipment only as may be lawful and for lawful purposes.

    • So far as permitted by law and save as expressly herein set out you will not have and you waive and assign to us all and any rights relating to our Website the Hardware and the Software and/or any code and/or the names or designations thereof.

  8. Consent

    You will obtain the consent of any person to be filmed or Webcast, or, in the case of minor children, obtain the consent of their parent or guardian.

  9. Reproduction of the Content

    You will not copy or reproduce the Content or the Webcast Data on to any other server or location for further reproduction without our prior written consent, which will not be unreasonably withheld. However, you may provide third parties with links to the Webcasts so that they can view them.

  10. TAXES - You must pay all taxes that may now or hereafter be imposed, levied, or assessed with respect to the possession or use of the Software or this license. You shall file all reports required in connection with such taxes.

  11. WARRANTY, LIMITATION OF LIABILITY, REMEDIES - THE SOFTWARE IS PROVIDED “AS IS” WITHOUT WARRANTY OR CONDITION OF ANY KIND INCLUDING WARRANTIES FOR MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. NEITHER BOSCH NOR ITS SUPPLIERS SHALL BE LIABLE FOR ANY LOSS OF PROFITS, LOSS OF USE, INTERRUPTION OF BUSINESS, LOSS OF DATA, NOR FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY KIND WHETHER UNDER THIS AGREEMENT OR OTHERWISE, OR FOR ANY CLAIM BY ANY OTHER PARTY.

    Bosch does not warrant the functions provided by the Software. However, Bosch warrants the media on which the Software is furnished to be free from defects in materials and workmanship under normal use for a period of 90 days from the date of original purchase. Bosch's entire liability to you, and your exclusive remedy, shall be the replacement of the media containing the Software not meeting Bosch's warranty, provided you return the same to Bosch. The replacement will be warranted for the remainder of the term of the original warranty or 30 days, whichever is longer. You assume responsibility for the selection of the Software to achieve your intended results, and for the installation, use and results obtained from the Software.

  12. U.S. GOVERNMENT RESTRICTED RIGHTS - The Software is provided with restricted rights. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at 52.227-7013 or its successor.

  13. EXPORT LAWS, APPLICABLE LAW - The deliveries and services (fulfillment of contract) are under the proviso that their fulfillment is not contrary to the compliance with national or international regulations, especially export control regulations, embargoes or other sanctions. The contract parties commit themselves to supply all necessary information and documents needed for the export / transfer to other EU member states / import. Delays due to export control assessments or export control licensing procedures invalidate terms and dates of delivery. When licenses are not granted respectively the delivery and service is not licensable, this contract becomes void regarding to the affected parts. Claims for damages resulting from the above mentioned reasons and from mentioned delivery delays are excluded.

    The customer commits himself to comply with all relevant export control regulations in case of resale or onward delivery, i.e. all national regulations or EC regulations as well as US regulations). The resale or onward delivery of listed commodities (products, software and technology), the resale to embargoed countries or to blocked persons, organizations or companies or to consignees which use the commodities for a military end-use, for nuclear, biological or chemical weapons or nuclear technology could require an export license. The reseller or the customer who makes the onward delivery has to apply for the necessary licenses.

    The customer should note that the US export control law is also applicable when the commodities are completely or only partly originated in the USA. This can also be the case if the components are of US origin although the contract has no other reference to the USA.

    Infringements of the rules of law are subject to contract annulation.

  14. If any terms or conditions of this Agreement are declared illegal, null or void or for any other reason considered non-applicable, such terms or conditions will be considered eliminated or non-existing in the Agreement and will not affect the validity and applicability of the other terms and conditions.

  15. This Agreement shall exclusively be governed by the laws of The Netherlands.

Software license for Russia

ВНИМАНИЕ!

ВНИМАТЕЛЬНО ПРОЧТИТЕ СЛЕДУЮЩИЕ УСЛОВИЯ

ЕСЛИ ВЫ НЕ СОГЛАСНЫ С ДАННЫМИ УСЛОВИЯМИ, НЕ РЕГИСТРИРУЙТЕ КОДЫ АВТОРИЗАЦИИ, УПОМИНАЕМЫЕ В ДАННОМ ДОКУМЕНТЕ, ВМЕСТО ЭТОГО СВОЕВРЕМЕННО УДАЛИТЕ И УНИЧТОЖЬТЕ ДАННЫЙ ДОКУМЕНТ И ОБРАТИТЕСЬ К ПОСТАВЩИКУ ЗА ПОЛНЫМ ВОЗМЕЩЕНИЕМ УПЛАЧЕННОЙ ЗА НЕГО СУММЫ. Использование данного Программного обеспечения означает, что вы принимаете указанные ниже условия.

BOSCH SECURITY SYSTEMS B.V. ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ НА ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ

Программное обеспечение, устанавливаемое в настоящий момент (именуемое в дальнейшем «Лицензионное программное обеспечение»), разработано Bosch Security Systems B.V. (именуемой в дальнейшем «Bosch»). Bosch предлагает Конечному пользователю лицензию для его использования на указанных ниже условиях. Регистрация кодов авторизации Лицензионного программного обеспечения и (или) использование Лицензионного программного обеспечения означает, что Конечный пользователь принимает условия настоящего лицензионного соглашения с Конечным пользователем (именуемого в дальнейшем «настоящее Соглашение»), в частности, Конечный пользователь принимает следующие условия.

  1. Определения

    Соглашение:

    настоящее лицензионное соглашение на программное обеспечение.

    Bosch:

    Bosch Security Systems B.V.

    Содержимое:

    весь добавляемый и транслируемый материал.

    Конечный пользователь:

    физическое или юридическое лицо, для которого предназначено программное обеспечение или оборудование. Этот термин основан на том, что назначение программного продукта или оборудования может быть полезно для клиента. Конечного пользователя можно противопоставить разработчикам и программистам продукта. Конечные пользователи также находятся в группе, отдельной от установщиков или администраторов продукта. (http://www.techterms.com/definition/enduser).

    Оборудование:

    инструменты и другие элементы, необходимые для выполнения конкретной операции или задачи.

    Лицензионное программное обеспечение:

    программное обеспечение, для работы которого требуется легальный код авторизации.

    Услуги:

    нематериальные продукты, такие как хранение и распространение информации и содержимого.

    Данные веб-трансляции:

    содержимое веб-трансляции.

    Веб-трансляция:

    веб-трансляция представляет собой мультимедийную презентацию, которая распространяется через Интернет с использованием технологии потоковой передачи мультимедийных данных для одновременной трансляции одного исходного содержимого нескольким слушателям или зрителям. Веб-трансляция может распространяться в режиме реального времени или по требованию. Веб-трансляция главным образом передается через Интернет.

  2. Авторские права

    Лицензионное программное обеспечение является интеллектуальной собственностью Bosch, которой принадлежат все соответствующие авторские права. Bosch сохраняет за собой навсегда право собственности Лицензионного программного обеспечения.

  3. Право на использование

    Конечный пользователь получает персональное неисключительное право на использование Лицензионного программного обеспечения только при условии его использования на 1 (одном) компьютере одновременно без размещения каких-либо ссылок в сетях. Bosch также сохраняет за собой все права, не переданные явным образом Конечному пользователю по настоящему Соглашению.

    Конечный пользователь не вправе продавать, передавать в аренду или иное пользование Лицензионное программное обеспечение или иным образом передавать или уступать права на его использование. Конечный пользователь не вправе декомпилировать, разбирать, осуществлять обратную разработку или каким-либо образом изменять программный код без предварительного письменного согласия Bosch. Несанкционированное копирование Лицензионного программного обеспечения запрещено в прямой форме.

  4. Бесплатное программное обеспечение с открытым исходным кодом

    • Программное обеспечение в предложенной программе может включать в себя программное обеспечение с открытым кодом и стороннее программное обеспечение, предоставляемое по бесплатным лицензиям (“FOSS”).

    • FOSS в программе регулируется условиями лицензионного соглашения FOSS («лицензии FOSS»). Согласно лицензиям FOSS, компания Bosch должна передавать вам соответствующие условия использования, и вы должны соблюдать их и выполнять соответствующие обязательства при использовании FOSS, не просто устанавливая и запуская ПО на ваших компьютерах, но, например, осуществляя утилизацию продукта за счет распределения, продажи или иной передачи ПО третьей стороне. Права по лицензиям FOSS предоставляются вам, и в случае передачи копии продукта другой стороне условия использования соответствующих лицензий FOSS применяются к передаче любого входящего в комплект ПО FOSS (в некоторых случаях лицензия FOSS представляет прямую лицензию от автора/лицензиара FOSS третьей стороне). Для многих лицензий FOSS компания Bosch не может ни предоставить, ни получить эти права для вас. Соответствующие лицензии FOSS доступны по интернет-адресу поставщика FOSS или предоставляются компанией Bosch по запросу.

    • Само ПО FOSS не влияет на цену продажи программы, предложенной компанией Bosch, и предоставляется без комиссии или денежной компенсации.

    • Вы должны явно или косвенно посредством поправки или адаптации FOSS принять ответственность за соблюдение соответствующих условий лицензий FOSS. Кроме того, вы должны согласиться с тем, что обновления или новые версии ПО могут содержать другие или дополнительные продукты FOSS или изменения в лицензий FOSS.

    • Если какие-либо условия или ограничения данного лицензионного соглашения конфликтуют с лицензиями FOSS или любыми другими условиями лицензии программного обеспечения с открытым кодом, включенного в этот продукт, приоритет имеют условия и положения этих лицензий на программное обеспечение с открытым кодом.

  5. Гарантия

    Bosch гарантирует, что Лицензионное программное обеспечение будет функционировать в значительной мере в соответствии со всей доступной документацией, поставляемой с этой или с предыдущими версиями Лицензионного программного обеспечения. Bosch не делает никакие дополнительные заявления и не предоставляет никакие дополнительные гарантии (явные или подразумеваемые), в том числе, среди прочего, относительно пригодности Лицензионного программного обеспечения для продажи и соответствия другим конкретным целям, отсутствия ошибок в Лицензионном программном обеспечении, а также, что в результате использования Лицензионного программного обеспечения или любых его копий не нарушаются права на интеллектуальную или промышленную собственность (например, патенты, авторские права или товарные знаки) третьих лиц.

  6. Обновления

    Bosch имеет право обновлять и (или) модифицировать Лицензионное программное обеспечение.

  7. Цель передачи

    Принимая условия настоящего соглашения, вы в явной форме подтверждаете свое согласие и обязуетесь использовать Лицензионное программное обеспечение, Услуги и Оборудование только для целей, для которых они предназначены, в соответствии с применимыми (местными) законами и нормативными актами. Вы не вправе привлекать к ответственности Bosch за убытки или претензии в связи с незаконным и (или) запрещенным использованием Лицензионного программного обеспечения, Услуг и (или) Оборудования и должны оградить компанию Bosch от любых подобных претензий, возникших в результате таких действий (например, от третьих лиц). Если установка или использование Лицензионного программного обеспечения, Услуг или Оборудования ведет к получению вами каких-либо прав, считается, что вы отказались от этих прав и передали их Bosch, если иное не определено в явной форме в настоящем Соглашении.

  8. Ответственность за веб-трансляцию (применяется только в случае веб-трансляции)

    Вы несете полную ответственность по обязательствам, возникающим в результате несанкционированного доступа к данным или содержимому веб-трансляций, а также за их изменение. Вы также несете ответственность по обязательствам, возникающим в результате незаконной веб-трансляции материалов и данных, а также за распространение угрожающих, непристойных, клеветнических, оскорбительных или незаконных материалов или материалов, размещение которых нарушает права на интеллектуальную собственность третьих лиц. Мы не несем ответственность по обязательствам, возникающим в результате сбоев веб-трансляции материалов или данных, если иное не выражено явно в настоящем Соглашении.

  9. Согласие

    Вы должны получить согласие лица на его съемку, в случае съемки несовершеннолетних — получить согласие родителей или опекуна.

  10. Воспроизведение содержимого

    Вы не должны копировать или воспроизводить Содержимое или Данные веб-трансляции на какой-либо другой сервер или в другое место для дальнейшего воспроизведения без получения предварительного письменного согласия, в предоставлении которого может быть отказано только при наличии разумныъх причин. Тем не менее, вы вправе предоставлять третьим лицам ссылки на веб-трансляции для просмотра.

  11. Изменение настоящего Соглашения

    Изменения настоящего Соглашения действительны в случае их письменного одобрения Bosch и Конечным пользователем. Условия в отношении Конечного пользователя применяются вне зависимости от их упоминания в формах заказа или в другом виде, если иное не принято компанией Bosch в письменной форме путем дополнения настоящего Соглашения.

  12. Ограничение ответственности

    Bosch не несет перед Конечным пользователем ответственность за убытки, в том числе за упущенную выгоду, потерю сбережений или любые другие случайные или косвенные убытки Конечного пользователя, возникшие в результате использования или невозможности использования Лицензионного программного обеспечения, даже если Bosch или его представители были уведомлены заранее о возможности таких убытков или претензий от любой другой стороны. Обязательные (императивные) законные требования Конечного пользователя остаются не затронутыми.

  13. Срок действия и расторжение Соглашения

    Настоящее Соглашение вступает в силу с момента открытия Конечным пользователем пакета, содержащего Лицензионное программное обеспечение.

    Конечный пользователь имеет право расторгнуть данное Соглашение в любое время. Для этого он должен предоставить письменное заявление в Bosch в соответствии с положениями, указанными в настоящем Соглашении.

    Bosch имеет право расторгнуть данное Соглашение в любое время путем предоставления письменного уведомления Конечному пользователю, но только в том случае, если Конечный пользователь не соблюдает те или иные обязательства в рамках данного Соглашения. В случае расторжения Соглашения Конечным пользователем или компанией Bosch Конечный пользователь должен незамедлительно прекратить использование Лицензионного программного обеспечения и всех его копий, а также вернуть его Bosch или уничтожить Лицензионное программное обеспечение и все его копии. Кроме этого, Конечный пользователь должен своевременно (но не позднее, чем в течение пяти дней с момента расторжения) предоставить в компанию Bosch письменное подтверждение осуществления возврата или уничтожения Лицензионного программного обеспечения и всех его копий, а также прекращения его использования. В дополнение к этому при расторжении по причине несоблюдения обязательств Конечным пользователем Bosch сохраняет право применить любые средства защиты своих прав, которые доступны в рамках закона и по соглашению, включая право на возмещение убытков.

  14. Экспортный контроль

    В отношении поставки продуктов и предоставления услуг (выполнения соглашения) действует положение о том, что их осуществление не должно противоречить национальным и международным нормам, в частности, нормативным актам по экспортному контролю, эмбарго и другим санкциям. Стороны обязуются предоставлять всю информацию и документы, необходимые для экспорта / передачи другим государствам ЕС / импорта. При возникновении задержек в результате оценки в рамках экспортного контроля или процедуры лицензирования в рамках экспортного контроля сроки и даты поставки аннулируются. Если не предоставляются соответствующие лицензии, и в отношении поставки товаров или предоставления услуг не могут быть предоставлены лицензии , данное соглашение становится недействительным для вовлеченных сторон. Требования по возмещению убытков в результате указанных выше причин и задержек поставки исключаются.

    Клиент обязуется соблюдать все требования, связанные с экспортным контролем, в случае перепродажи или последующей поставки, то есть все национальные нормативные требования или нормативные требования ЕС, а также нормативные требования США. При перепродаже или последующей поставке перечисленных товаров (продуктов, Лицензионного программного обеспечения и технологии), перепродаже в страны, на которые наложено эмбарго, или лицам, организациям и компаниям, чьи активы заморожены, а также адресатам, которые используют товары в военных целях, для создания ядерного, биологического или химического оружия или разработки ядерных технологий, может потребоваться лицензия на экспорт. Реселлер или клиент, осуществляющий последующую поставку, должен обращаться за получением необходимых лицензий.

    Клиент также должен учитывать, что законодательство по экспортному контролю США применяется также тогда, когда товары полностью или частично произведены в США. Данное положение также может применяться, если компоненты произведены в США, но несмотря на это в соглашении отсутствуют прочие упоминания США.

    Нарушение правил, установленных законодательством, является основанием для расторжения данного Соглашения.

  15. Конфиденциальность

    Стороны обязуются обеспечивать конфиденциальность информации или данных, предоставляемых раскрывающей стороной, если получающая сторона знает или должна разумно знать, что эти данные являются секретными и (или) конфиденциальными и (или) что такое разглашение может нанести вред раскрывающей их стороне. Получающая сторона не должна раскрывать эти данные другим сторонам, не участвующим в настоящем Соглашении, кроме случаев наличия предварительного явного письменного разрешения на разглашение соответствующей информации или раскрытие осуществляется согласно требованиям закона или по требованию компетентных органов власти.

  16. Прочие условия

    Если любое положение настоящего Соглашения стало или должно стать недействительным, оно не влияет на действительность остальных положений. В таких случаях недействительное положение должно быть заменено любым другим допустимым положением, похожим по значению и цели на оригинальное положение.

    Если это явно не согласовано сторонами в письменной или иной форме в рамках данного Соглашения, срок для предъявления претензий к Bosch составляет 1 (один) год с момента получения Конечным пользователем персонального неисключительного права на использование Лицензионного программного обеспечения.

  17. Применимое законодательство

    Настоящее Соглашение регулируется правом Нидерландов исключая применение коллизионных норм.

SOFTWARE LICENSE FOR ANY OTHER COUNTRY

STOP!

PLEASE READ THE FOLLOWING TERMS AND CONDITIONS CAREFULLY

IF YOU DO NOT AGREE WITH THESE TERMS AND CONDITIONS, DO NOT REGISTER THE AUTHORIZATION CODES MENTIONED IN THIS DOCUMENT, INSTEAD, PROMPTLY REMOVE AND DISTROY THIS DOCUMENT AND ASK FOR A FULL REFUND AT YOUR SUPPLIER. By using this Software you accept the terms stated below:

BOSCH SECURITY SYSTEMS B.V. LICENSE AGREEMENT FOR SOFTWARE

The software program that is currently being installed (hereinafter referred to as “the Licensed Software") has been developed by Bosch Security Systems B.V. (hereinafter referred to as “Bosch"). Bosch hereby offers End-User a license to use it under the following terms and conditions. By registering the authorization codes of the Licensed Software and/or using the Licensed Software End-User agrees to be bound by the terms and conditions of this End-User license agreement (hereinafter referred to as "this Agreement") and more specifically End-User agrees to the following:

  1. Definitions

    Agreement:

    this license agreement for software;

    Bosch:

    Bosch Security Systems B.V.;

    Content:

    all added and broadcasted material;

    End-User:

    an end-user is the person or organization that a software program or equipment is designed for. The term is based on the idea that the "end goal" of a software or hardware product is to be useful to the consumer. The end-user can be contrasted with the developers or programmers of the product. End-users are also in a separate group from the installers or administrators of the product. (http://www.techterms.com/definition/enduser);

    Equipment

    the tools, or other items needed for a particular activity or purpose;

    Licensed Software:

    software that need a legal authorization code to work;

    Services:

    intangible products such as storage and distribution of information or content;

    Webcast Data:

    content of the webcast;

    Webcast/Webcasting:

    a webcast is a media presentation distributed over the Internet using streaming media technology to distribute a single content source to many simultaneous listeners/viewers. A webcast may either be distributed live or on demand. Essentially, webcasting is “broadcasting” over the internet.

  2. Copyright

    The Licensed Software is a proprietary product of Bosch and Bosch owns all copyrights therein. Bosch retains title and ownership of the Licensed Software at all times.

  3. Right to use

    End-User is hereby granted the personal non-exclusive right to use the Licensed Software only on and in conjunction with one (1) computer at one (1) time and without further linkups in networks and the like. Bosch also reserves all rights not expressly granted to End-User herein.

    End-User may not sell, rent or lease the Licensed Software or otherwise transfer or assign the right to use it. End-User may not decompile, disassemble, reverse engineer or in any way modify program code without the prior written consent of Bosch. Unauthorised copying of the Licensed Software is expressly forbidden.

  4. Free Open Source Software

    • The software of the offered program possibly includes open source software and third party software under royalty free licenses (“FOSS”).

    • The FOSS in the program is subject to FOSS license agreements (“FOSS-Licenses”). Pursuant to these FOSS-Licenses, Bosch has to pass on to you their terms and conditions and you have to comply with these terms and conditions and fulfill respective obligations when using the FOSS in another way than merely installing and running it internally on your machines, e.g. through further disposal of the product, as by distribution, selling, or otherwise passing it on to a third party. The rights under the FOSS-Licenses are being granted to you, and in the event of you passing on a copy of the product to another party, the terms and conditions of the respective FOSS-Licenses apply to the distribution of any included FOSS (in some cases, the FOSS-License provides a direct license from the author/licensor of the FOSS to the third party). For many FOSS-Licenses, Bosch itself can neither grant nor obtain these rights for you. The applicable FOSS-Licenses are available on the internet address of the provider of the FOSS or will be made available by Bosch upon your request.

    • The FOSS itself does not contribute to the sales price of the program offered by Bosch and the FOSS is thus is provided without royalty or monetary compensation.

    • You have to, either expressly, or implied by amendment or adaptation of the FOSS, accept and take responsibility for your compliance with the applicable FOSS-Licenses. Further, you have to agree that updates or new versions of the software program may contain different or additional FOSS or changes in the FOSS-Licenses.

    • If any terms or restriction of this EULA conflict with the FOSS-Licenses or any other license conditions of Open Source Software included in this product, the terms and conditions of these Open Source Software licenses shall prevail.

  5. Warranty

    Bosch warrants that the Licensed Software will perform in substantial compliance with all available documentation supplied either with this or with previous versions of the Licensed Software. Bosch makes no further representations or warranties, expressly or implied, such as, by way of example but not of limitation, regarding merchantability or fitness for any particular purpose, that Licensed Software is error-free, that the use of the Licensed Software or any copies thereof will not infringe any intellectual or industrial property rights like patent, copyright or trademark of any third parties.

  6. Updates

    Bosch is always entitled to update and/or modify the Licensed Software.

  7. Purpose of transmission

    By accepting this agreement you explicitly acknowledge and oblige yourself to only use the Licensed Software, the Services and the Equipment for their intended purposes and according to the applicable (local) laws and regulations. You can never hold Bosch liable for any damage or claims in connection with illegal and/or otherwise prohibited use of the Licensed Software, the Services and/or the Equipment and shall indemnify Bosch from any claims in this respect (e.g. of third parties). If installing and use of the Licensed Software, Services and Equipment would lead to any right for you, you are deemed to waive this rights and assign them to Bosch, unless expressly stated in this Agreement otherwise.

  8. Responsibility for Webcasting (only applicable in case of webcasting)

    You will be exclusively responsible for any liability arising from unauthorized access or alteration to the Webcast Data or Content. You will also be responsible for any liability arising from any material or data which has been webcast unlawfully or that includes e.g. any threatening, defamatory, obscene, offensive or illegal material or any material which infringes any person's intellectual property rights. Except as expressly stated otherwise in this Agreement, we will not be responsible for any liability arising from the failure to webcast any material or data.

  9. Consent>

    You will obtain the consent of any person to be filmed, or, in the case of minor children, obtain the consent of their parent or guardian.

  10. Reproduction of the Content

    You will not copy or reproduce the Content or the Webcast Data on to any other server or location for further reproduction without our prior written consent, which will not be unreasonably withheld. However, you may provide third parties with links to the Webcasts so that they can view them.

  11. Changes to this Agreement

    No changes to this Agreement are valid unless with Bosch's and End-User's written approval. The terms and conditions of End-User are applicable whether or not contained in order forms or otherwise, unless specifically accepted by Bosch in writing by means of an addition to this Agreement.

  12. Limitations of liability

    Bosch shall not be liable to End-User for any damages, including any loss of profit, loss of savings or other End-User's incidental or consequential damages arising out of End-User's use or inability to use the Licensed Software, even if Bosch or its representatives have been advised of the possibility of such damages or for any claim by any other party.

  13. Validity and termination

    This Agreement shall be valid with effect as of the date End-User has opened the package containing the Licensed Software.

    End-User is entitled to terminate this Agreement at any time by simple written notice to Bosch subject to the provisions set out hereinafter.

    Bosch is entitled to terminate this Agreement by simple written notice to End-User but only in the event End-User fails to comply with any of its obligations pursuant to this Agreement. In the event of termination, whether by End-User or by Bosch, End-user shall immediately stop any use of the Licensed Software and of all copies thereof and shall return to Bosch or destroy the Licensed Software and all copies thereof and End-User shall promptly (but at the latest within five days after termination) confirm in writing to Bosch that it has returned or destroyed Licensed Software and all copies thereof and has terminated use. In addition, in the event of termination because of End-User's failure to comply with its obligations, Bosch reserves the right to invoke any and all other remedies available to it in law or contract including the right to claim damages.

  14. Export control

    The deliveries and services (fulfillment of contract) are under the proviso that their fulfillment is not contrary to the compliance with national or international regulations, especially export control regulations, embargoes or other sanctions. The contract parties commit themselves to supply all necessary information and documents needed for the export / transfer to other EU member states / import. Delays due to export control assessments or export control licensing procedures invalidate terms and dates of delivery. When licenses are not granted respectively the delivery and service is not licensable, this contract becomes void regarding to the affected parts. Claims for damages resulting from the above mentioned reasons and from mentioned delivery delays are excluded.

    The customer commits himself to comply with all relevant export control regulations in case of resale or onward delivery, i.e. all national regulations or EC regulations as well as US regulations). The resale or onward delivery of listed commodities (products, Licensed software and technology), the resale to embargoed countries or to blocked persons, organizations or companies or to consignees which use the commodities for a military end-use, for nuclear, biological or chemical weapons or nuclear technology could require an export license. The reseller or the customer who makes the onward delivery has to apply for the necessary licenses.

    The customer should note that the US export control law is also applicable when the commodities are completely or only partly originated in the USA. This can also be the case if the components are of US origin although the contract has no other reference to the USA.

    Infringements of the rules of law are subject to this agreement termination.

  15. Confidentiality

    Parties shall keep confidential any information or data provided by or on behalf of the disclosing party, which the receiving party knows or should reasonably know is secret and / or confidential and / or that disclosure may be harmful to the disclosing party. The receiving party shall not disclose this to others, not involved in the performance of the Agreement, unless the disclosing party has given explicit prior written consent to disclose the relevant information or disclosure occurs because the law or a competent authority obliges the receiving party to do so

  16. Miscellaneous

    If any provision contained in this agreement should be or become invalid, this shall not affect the remaining provisions. In such cases the invalid provision shall be replaced by a valid provision approximating as closely as possible to the sense and purpose of the original provision.

    Unless explicitly agreed otherwise by the parties in writing, or otherwise provided for in this Agreement, any claim against Bosch shall in any case expire after one (1) year from the time that End-User was granted the personal non-exclusive right to use the Licensed Software.

  17. Applicable law

    This Agreement shall exclusively be governed by the laws of The Netherlands.

Software maintenance Agreement

MAINTENANCE SERVICE LEVEL AGREEMENT

Supplement to the Software Maintenance Agreement

Bosch Security Systems B.V. ("Bosch") develops, markets and licenses software for use in Conference, Public Address, Voice Evacuation and Networked Audio systems. The Bosch Software Maintenance Agreement (the “Agreement”) sets out the terms and conditions under which Bosch will provide "Maintenance Services" for the "Software" (as defined in the Agreement).

This Service Level Agreement Supplement (the "Supplement") is a supplement to and a part of the Agreement, and sets forth the extent, detail and dependencies of the Maintenance Services to be provided by Bosch to a system integrator (“Customer”) of the software (the “Software”). The provision of Maintenance Services under the Agreement is subject to and conditioned on the terms of this Supplement.

Bosch only provides Maintenance Services on the Software to a Customer who has obtained a valid user license to the Software pursuant to the Agreement.

Terms defined in the Agreement shall have the same meaning when used in this Supplement unless otherwise expressly stated.

  • Maintenance Services. Maintenance Services include:

  • bug-fixing ("Support Services"); and

  • issuing new Releases of the Software.

  • Support.

  • Support Services are comprised of the analysis and correction of an "Error" (define below) in the Software.

  • An "Error" is a "Reproducible" (defined below) malfunction or issue in the Software that causes the Software to operate in a way that is materially different from what is described in the applicable documentation.

  • "Reproducible" means that the issue that causes the Error must re-occur when the operation and configuration of the Customer implemented version of the Software is repeated in Bosch’s support center, indicating that the issue is caused by a bug or other issue inherent to the software, rather than caused by the specific Customer environment or use.

  • In case of doubt on the Reproducible character of an issue, Bosch will normally provide Services as if the issue was reproducible (i.e. without any additional fee); provided, however, if, at any time during analysis or resolution, an issue appears to be not Reproducible, Bosch's continued resolution efforts will be subject to Customer agreeing to pay Bosch's then current fees and charges for such efforts.

  • If, on initial analysis, an issue appears not be Reproducible, Bosch may still choose to assist the Customer in finding a solution, but Bosch does not have any contractual duty to do so, and Bosch is entitled to charge additional fees, and such continued Bosch assistance will be subject to Customer agreeing to pay Bosch's then current fees and charges for such efforts.

  • If, after final analysis, an issue is found to be Reproducible (even if it appeared as non-Reproducible at initial logging), Bosch will not charge any additional such fees.

  • Different levels of Errors. Errors shall be categorized in accordance to their severity as defined in the following four (4) Severity Levels:

  • Severity Level 1 (Critical). An Error is Severity Level 1, when, in the production environment, the Software is completely down, or a major function of the Software is not working at all or is inaccessible, and there is no workaround available.

  • Severity Level 2 (Serious). An Error is Severity Level 2, when, in the production environment, the Software is significantly impaired (e.g. loss or degradation of a substantial functionality), which causes the Software to perform materially less than as described in the applicable documentation, or, in a test or back-up environment, the Software is completely down, or a major function of the Software is not working at all or is inaccessible, and there is no workaround available.

  • Severity Level 3 (Moderate). An Error is Severity Level 3, when, in the production environment, the Software encounters a technical or functional problem, but a temporary workaround is available, or, in a test or back-up environment, the Software is significantly impaired (e.g. loss or degradation of a substantial functionality), which causes the Software to perform materially less than as described in the applicable documentation.

  • Severity Level 4 (Minor). An Error is Severity Level 4, when there is an issue that relates to improvement of performance or functionality, or there is an issue for which a permanent workaround has been provided.

  • Support Services.

  • Errors have to be logged by Customer through the designed telephone hot-line, or via a dedicated support helpdesk website or email address ("First Line Support"). Bosch will indicate to Customer the exact contact details for First Line Support.

  • Bosch will use its reasonable efforts to provide Customer with a solution to the Error.

  • Solution times. Since Bosch will not know in advance of receipt of Customer's notice of an Error what the cause of an Error is, or how it can be resolved, Bosch cannot commit to solution times. Bosch will use reasonable commercial efforts to resolve the Error as soon as possible, taking into account the Severity Level of the Error.

  • Availability of First Line Support.

  • First Line Support is available during normal business hours of your Bosch sales representative, excluding weekends and holidays.

  • Remote Access and On-Site Support.

  • It is an essential condition of Support Services that Customer provides on-line remote access to the production environment of the Software. If no such remote access is provided, the level of Service may be severely impacted, and the response times will be delayed as a result.

  • The standard Support Services do not include On-Site Support. Upon Customer written request, and subject to Customer's agreement to pay Bosch's then current fees and charges therefor, Bosch may (but is under no obligation to) agree to provide On-Site Support. In such case, all travel and accommodation costs shall be charged in addition to Bosch's then current fees and charges.

  • Conditions to be able to call upon Support Services.

  • In order to be able to call upon Support Services, the Customer must:

  • have a valid user license to the Software, and not be in breach of any of the terms of the Software license;

  • have effectively paid all due and owing license, maintenance, and other fees owed to Bosch;

  • use the Software strictly in accordance with the applicable documentation and the Bosch instructions (including but not limited to the hardware and technological environment and usage instructions as issued by Bosch from time to time);

  • comply with the instructions on installment of the latest Software release as set out in this document or as instructed by Bosch from time to time;

  • ensure that the Software is only used by Customer's personnel that is properly qualified and trained in the use of the Software;

  • Bosch is entitled to request Customer to impose certain minimum training and certification requirements to the staff using the Software, in order to comply with the latest condition above.

  • If at the time Customer contacts First Line Support, it appears that Customer does not comply with one or more of the above conditions, Bosch will be entitled (but is not obligated) to make the provision of Support Services subject to payment of additional fees and charges.

  • If at the time Customer contacts First Line Support, it appears that the issue to be logged has been resolved by a new Release (either a Major or Minor Release, including fixes and hot patches) that has already been made generally available by Bosch, then Customer will first have to implement such Release, prior to Bosch performing any Support Services.

  • The following are not included in Software Support Services (“Out-of-Scope Services”):

  • data retrieval;

  • support of issues that are not Reproducible, or that otherwise fail to be qualified as Errors;

  • support of interfaces;

  • support of Customer-specific development software;

  • support of the technological environment in which the Software is installed;

  • support of hardware (Bosch cameras, or other parts of the Bosch hardware configuration are covered by separate agreements, and are specifically excluded from Software Support Services); and

  • support of third party software.

  • Upon Customer’s request, Bosch may (but has no obligation to) accept to provide Out-of-Scope Services, subject to Customer agreeing to pay Bosch's then current fees and charges therefor for time and materials. Any such Out-of-Scope Services will be provided on a reasonable effort basis, without any commitment as to Response or Solution times.

  • New Releases.

  • Bosch will make available to Customer new Releases of the Software as and when they are made “generally available” by Bosch to similarly situated customers. New Releases are made available to Customers with valid Maintenance Agreements at no additional cost.

  • Implementation (e.g. installation, license activation, and configuration) of new Releases is not included in the Maintenance Services. If Customer wants to receive such implementation services, they need to be ordered separately.

  • ALTHOUGH BOSCH WILL USE COMMERCIALLY REASONABLE EFFORTS TO ENSURE BACKWARDS COMPATIBILITY BETWEEN RELEASES, BOSCH DOES NOT GUARANTEE FULL BACKWARDS COMPATIBILITY, AND THE IMPLEMENTATION OF A NEW RELEASE MAY CAUSE SOME DATA LOSS. CUSTOMER SHOULD MAKE A FULL BACK-UP OF ALL DATA THAT CUSTOMER WISHES TO RETAIN PRIOR TO THE IMPLEMENTATION OF A NEW RELEASE.


Scope

This user manual describes the use of the Bosch Conference Protocol for the Bosch Integrus Transmitter. To understand this manual, knowledge is expected on the following areas:

  • Coding knowledge of languages such as :HTML, Javascript, Typescript and C#. In this documentation, definitions and examples are using code fragments of these languages. If user wants to develop any application in other languages, can also use this conference protocol but is responsible in converting these examples to the appropriate language.

  • The Integrus Transmitter and its installation.

This user manual is intended for users, who want to use the Conference Protocol of the Integrus Transmitter into their application.

The current version of the Conference Protocol provides functionality to:

  • Login: Authentication to Login and logout

  • Transmitter management: Enable testtones to all channels and manage powering state of the device

  • License management: Add and remove licenses on the device

This application works based on client server communication basis. The client is developed using React and TypeScript. The conference protocol is developed using C#.

In this manual, we will find the code fragments of all mentioned technology as examples to clarify the use of the conference protocol controlling the Integrus Transmitter.

See Also

Other Resources

Introduction


History

History of Conference Protocol

Version | Details
DICENTIS 4.2 | Initial version


HowTo Overview

This section includes "How To" documentation for performing common conferencing system tasks.

In This Section

  • How to use the Conference Protocol

  • Conference Protocol basics

  • Authentication

  • Password requirements

  • Permissions

  • User roles

  • Events

  • Error Handling

  • Examples

  • How to diagnose the Integrus Transmitter using its logging

  • How to use the Integrus Transmitter conference protocol demonstrator

  • Handling audio level updates


How To Use Conference Protocol

This page provides a step wise description regarding use of various functionalities available with Integrus Transmitter conference protocol such as login, transmitter management and license management etc.

Opening a protocol channel

The Integrus Transmitter conference protocol runs over a web socket. To open a channel to the protocol, create a websocket to the address :

Copy
wss://<host>/Dicentis/API

using the (sub)protocol

Copy
DICENTIS_1_0

The protocol only supports wss, i.e. secure web sockets. Insecure web sockets are not supported. No http headers, credentials or cookies need to be set. Any specified will be ignored. In JavaScript, one would create the socket using:

By default, the websocket server uses self signed certificates.

JavaScript
Copy
var s = new WebSocket(“wss://IntTxo/Dicentis/API”, “DICENTIS_1_0”);


Conference Protocol Basics

Once the web socket is opened, the client can send request messages. The Integrus Transmitter responds with response messages. All messages are formatted using JSON.

All messages, both request and response have a similar format, as defined by this JSON schema:

Copy
{
"type": "object",
"properties": {
    "messageId": {
        "required": true,
        "type": "integer"
    },
    "operation": {
        "required": true,
        "type": [
            "string",
            "null"
        ]
    },
    "parameters": {
    "required": true,
    "type": [
        "object",
        "null"
    ],
    "properties": {}
    }
  }
}

The messageId is not used by the Integrus Transmitter. It serves only for the client to match requests it sends to responses received from the Integrus Transmitter. When the Integrus Transmitter generates a response, it copies the messageId received in the request message to the response. The client should not use messageId value 0 because that number is used by the Integrus Transmitter for notifying events.

The operation is a string that identifies the operation on the Integrus Transmitter to be executed. It is not case sensitive. Operations are defined later in this document. The Integrus Transmitter copies the operation name from the request to the response, except when an error occurs.

Finally, every request and response message has a parameters field. This field is an object. In requests to the Integrus Transmitter, it that holds all the parameters for the operation to be executed. In responses it holds the results of processing.

Since the parameters field is an object, it itself contains fields.

  1. If a request message contains any fields in the parameters object that the Integrus Transmitter does not understand, the operation will fail, and the Integrus Transmitter will return an error message.
  2. If the client does not specify all the fields that the Integrus Transmitter can handle, the Integrus Transmitter will fill in suitable defaults and the operation will complete normally.


How to Authenticate

In order to be able to use the conference protocol, the clients need to log in using the “LogIn” operation. It is illegal to call “LogIn” again after a successful login.

To log off, client can close the web socket connection, or use the “LogOut” operation.

Without a valid LogIn, all other operations will return an error message.


Password requirements

For standard security purposes, the API sets a few requirements to the password of a user.

A password needs to adhere to the following:

  • It is at least 8 characters long
  • It contains at least 1 lower case letter
  • It contains at least 1 upper case letter
  • It contains at least 1 number
  • It contains at least 1 special character


Permissions

This page explains the various permissions which a user can have.

Name | Description
canViewTransmitterStatus | This permission indicates that the user is allowed to view status information of the Transmitter.
canViewDashboard | This permission indicates that the user is allowed to view the combined overall (Dashboard-)status.
canControlTransmitter | This permission indicates that the user is allowed to control/configure the Transmitter, e.g. enable/disable carriers.
canControlAudio | This permission indicates that the user is allowed to mute and change gain levels for language inputs and the auxiliary input of the transmitter.
canConfigureLicenses | This permission indicates that the user is allowed to add or remove licenses on the Integrus Transmitter.
canSwitchSystemPowerOff | This permissions allows the user to power the Integrus Transmitter on and off.
canChangeOwnPassword | This permission indicates that the user is allowed to change their own password
canManageUsers | This permission indicates that the user is allowed to create, edit (incl. their passwords (incl. their own)) and delete users
canRegisterFirstUse | This permission indicates that the user is allowed to set the password to enable access via the network.


User roles

This page explains the roles that a user can have.

Name

Description

Technician

 The technician has the following permissions:
  • CanViewTransmitterStatus
  • CanViewDashboard
  • CanSwitchSystemPowerOff
  • CanControlTransmitter
  • CanControlAudio
  • CanConfigureLicenses
  • CanManageUsers

Operator

 The operator has the following permissions:
  • CanViewTransmitterStatus
  • CanViewDashboard
  • CanSwitchSystemPowerOff
  • CanChangeOwnPassword


Events

An event message may be sent by the Integrus Transmitter at any time. A client needs to be aware that after sending a request, the Integrus Transmitter may send an event message before the response.

Just like error messages, event messages conform to the basic message format.

messageId is set to 0.
operation is set to the string “event”.
parameters is set the object with the JSON schema:

Copy
{
  "type": "object",
  "properties": {
    "events": {
      "required": true,
      "type": [
        "array",
        "null"
      ],
      "items": {
        "type": [
          "string",
          "null"
        ]
      }
    }
  }
}

Each event is identified by a string value. Events never carry any data. Instead, once the event occurs, the client must use one of the operations to get the data. For example, when the event “PermissionsChanged” fires, the client can use the “GetPermissions” operations to get the set of current permissions.

An event will only fire once. It needs to be reset by the client for it to fire again. There are two ways to reset the event:

  1. The reset is implicit when the corresponding data is retrieved. For example, After PermissionsChanged event has fired, no more PermissionChanged events are fired, even if the permissions change. Only after the client has requested the current permissions using GetPermissions, the PermissionsCanged event will fire again.
  2. An explicit reset by calling “RegisterEvents” for the event again.

The documentation for each event explains which operation resets the event.

Although this might seem complex, normally it works intuitively on the client application side. The advantage of this way of working is that the Integrus Transmitter will never overload a slow network connection with a huge amount of events, nor with data that is already out of date by the time it arrives at the client.

The “RegisterEvents” and “UnregisterEvents” operations allow a client to filter the events it wants to receive. After a new web socket connection is established, no events are generated until “RegisterEvents” is called.


Error Handling

If the Integrus Transmitter detects a protocol error (e.g. bad formatted JSON) in a request, it closes the web socket.

In all other cases, the Integrus Transmitter responds with an error message. An error message conforms to the message format defined in the previous paragraph.

messageId is copied from the request message.
operation is set to the string “error”.
parameters is set the object with the JSON schema:

Copy
 {
  "type": "object",
  "properties": {
    "message": {
      "required": true,
      "type": [
        "string",
        "null"
      ]
    }
  }
}

Note that the message holds information useful to the client application developer, not to the end user. And it is not intended to be parsed. Different implementations of the Integrus Transmitter may have different error messages.


Examples

Message exchange for the RegisterEvents operation

Request:

Copy
{
  "messageId": 1,
  "operation": "RegisterEvents",
  "parameters": {
    "events": [
      "standbyStateChanged",
      "enableTestTonesChanged"
    ]
  }
}

Response:

Copy
{
  "messageId": 1,
  "operation": "RegisterEvents",
  "parameters": {}
}

Message exchange for the GetPermissions operation

Request:

Copy
{
  "messageId": 1,
  "operation": "GetPermissions",
  "parameters": {}
}

Response:

Copy
{
  "messageId": 1,
  "operation": "GetPermissions",
  "parameters": {
    "permissions": [
      "canViewTransmitterStatus",
      "canSwitchSystemPowerOff"
    ]
  }
}

A request for an unknown operation:

Request:

Copy
{
  "messageId": 3,
  "operation": "DummyOperation",
  "parameters": {}
}

Response:

Copy
{
  "messageId": 3,
  "operation": "error",
  "parameters": {
    "message": "DummyOperation is an unknown operation"
  }
}

A malformed request. Here the operation is missing:

Request:

Copy
{
  "messageId": 3,
  "parameters": {}
}

Response:

Copy
{
  "messageId": 3,
  "operation": "error",
  "parameters": {
    "message": "Bad message format"
  }
}

Another request. Here the parameters object contains some unknown fields (GetPermissions does not take any parameters, but here an events parameter is passed):

Request:

Copy
{
  "messageId": 4,
  "operation":"GetPermissions",
  "parameters":{"events":["standbyStateChanged","enableTestTonesChanged"]}
}

Response:

Copy
{
  "messageId": 4,
  "operation": "error",
  "parameters": {
    "message": "Could not find member 'events' on object of type 'GetPermissionsRequest'. Path 'parameters.events', line 1, position 67."
  }
}


How to use the Integrus Transmitter conference protocol demonstrator

The Integrus Transmitter ConferenceProtocol Demonstrator is a webpage which is built using ConferenceProtocol, it helps the users in understanding how to write their own application using ConferenceProtocol

Prerequisites for the Integrus Transmitter conference protocol demonstrator

In order to use the demonstrator, it required to install Visual Studio Code.

After starting Visual Studio Code

  1. Open the folder 'txo-protocol-demonstrator'
  2. Open a terminal and from the commandline enter: npm install

    This will install all required dependencies from GitHub to build the demonstrator.

  3. Open the TypeScript source file AppConfig.ts and set the option 'debug' to true and 'debugHost' to the IP-address of the Zync-processor of the Integrus Transmitter.
  4. From the terminal commandline enter: npm start

    Now a local development server is started to run the application.

How to use Integrus Transmitter conference protocol demonstrator

Next to running the Integrus Transmitter conference protocol demonstrator using a development server, the demonstrator is hosted from the Integrus Transmitter itself.

  1. In a browser (supports only in Firefox, Edge, Safari, Chrome) enter URL “https://<Zync IP-address>”
  2. It opens the Integrus Transmitter conference protocol demonstrator webpage.
  3. Enter valid username and password, on successful login, user can see permissions they have and all granted functionality is enabled.
    Valid User Name Password
Example

1) How to enable and disable testtones to all channels.

Prerequisites
  • The WebClient requires Enabling test tones right.
  • Logged in user requires Enabletest tones right.

Login to the Integrus Transmitter conference protocol demonstrator. And check if you have canEnableTestTones permission to enable/disable testtones to all channels.

Using Integrus Transmitter conference protocol demonstrator navigate to "Transmitter status" tab.

Click on 'Test tone to all' checkbox.

2) How to use power on /off the system.

Prerequisites
  • The WebClient requires Power off right.
  • Logged in user requires Power off.

Login to the Integrus Transmitter conference protocol demonstrator. And check if you have canSwitchSystemPowerOff permission to power on and off the system.

Using Integrus Transmitter conference protocol demonstrator navigate to "Standby" tab.

If system power mode status is "poweredOn" then user will see "Power OFF" as button text to power off the system.

If system power mode status is "poweredOff" then user will see "Power ON" as button text to power on the system.

How to debug
  1. Goto browser’s DEBUG mode by pressing F12 in the browser, in console window all requests, responses, errors are logged.

    For example: When logging in from the in "INT-TXO" tab, you can see the request and response as in the below image


How to handle audio level updates

The possibility exists to register for audio levels (in dB). These values can be used to display on VU-meters. An audiolevel update-message may be sent by the Integrus Transmitter at any time. The update message contains the audio level for the Integrus Transmitter channels.

Just like regular messages, audiolevel update messages conform to the basic message format.

messageId is set to 0.
operation is set to the string “update”.
parameters is set the object with the generic JSON schema and contains an update structure:

Copy
{
  "what": "audioLevels",
  "content":
    {
      "languages": [
        {
          "languageId": <int>,
          "channels": [
            {
              "channelId": <int>,
              "dbLevel": <double>
            }]
        }],
      "auxiliary":
        {
          "dbLevel": <double>
        }
    }
  }

The “RegisterAudioLevels” and “UnregisterAudioLevels” operations allow a client to register for updates which will follow immediately after at a periodic interval of 30 milliseconds. For this is advised only to register for these updates when required. Only an update for a channel will be updated when a change in level occurred compared to the last update.

When no update of audio levels is available for auxiliary input or languages, the corresponding field shall be empty (null).

Audio level updates are based on dBFS (Full Scale) values ranging between -90 dBFS upto 0 dBFS.


How to diagnose the Integrus Transmitter using its logging

The Integrus Transmitter Protocol provides a number of commands to control and retrieve logging.

Logging control

There are two paths to control the log level:

  • Through the conference protocol

  • Through Dicentis system

Through the front-end, the logging level can be set to configure the logging details immediately and persistently. Setting a log level then changes behavior of the system as follows:

  • DEFAULT - supplies info level of logs and higher, allows Dicentis controlled log level

  • TRACE - supplies trace (or debug) level of logs and higher, blocks Dicentis controlled log level

  • INFO - supplies info level of logs and higher, blocks Dicentis controlled log level

  • WARNING - supplies warning level of logs and higher, blocks Dicentis controlled log level

  • ERROR - supplies error level of logs and higher, blocks Dicentis controlled log level

Logging retrieval

The INT-TXO stores the logging persistently. Performing a firmware upgrade or downgrade clears the logs on the INT-TXO. The logs retrieved are transmitted in UTF-8 format and contain unix style end-of-line character.
The following commands retrieve the logs from the INT-TXO:

  • getLogs - retrieve all available logs from INT-TXO, size of the log file may vary

  • getLogsTail(count) - retrieve the last (count) number of logs from INT-TXO. Each log entry equals 1 count

  • getLatestLogs - retrieve the latest logs from the INT-TXO, which were added since the previous call to this command

    First time calling this command should result in no logs sent back the command does not persistently store the calling moment to this method.
    Expect first-time calling behavior when:

    • Calling this method after a reboot

    • After closing the web-client

    • Not calling for long time - depending on the log level and system activity, this could mean after tens of minutes (TRACE) or after a few days (ERROR)

    The INT-TXO supports up to a maximum of 10 parallel sessions.
    We recommend using the command with a polling mechanism running at 1 second interval.


Integrus Transmitter Protocol Reference

This help file describes the Integrus Transmitter protocol.


ConferenceApiHandler.ActivateAuxiliary Method

ActivateAuxiliary Method

Activates the analog auxiliary input
Syntax
Json
Request:

Copy
{
    "active": <bool>
}

Response:

Copy
{
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

auxiliaryActiveStateChanged
systemModeChanged
permissionsChanged


ConferenceApiHandler.ActivateLicenses Method

ActivateLicenses Method

Issues a request to activate license(s)
Syntax
Json
Request:

Copy
{
    "activationIds": [<string>],
    "dictionary":
    {
        "address": <string>,
        "city": <string>,
        "country": <string>,
        "customerName": <string>,
        "locationName": <string>
    }
}

Response:

Copy
{
    "package": <string>
}
Remarks
Requires:
  • canConfigureLicenses permission.
See Also

Reference

licensesChanged


ConferenceApiHandler.AddUser Method

AddUser Method

Adds a user
Syntax
Json
Request:

Copy
{
    "firstName": <string>,
    "lastName": <string>,
    "role": <string>,
    "user": <string>,
    "password": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageUsers permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.BackupConfiguration Method

BackupConfiguration Method

Gets the current Configuration file on device
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "package": <string>
}
Remarks
Requires:
  • canControlTransmitter permission. canManageUsers permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ChangeOwnPassword Method

ChangeOwnPassword Method

Change the password of the logged in user
Syntax
Json
Request:

Copy
{
    "currentPassword": <string>,
    "newPassword": <string>
}

Response:

Copy
{
}
Remarks
Requires one of these permissions:
  • canChangeOwnPassword permission.
  • canManageUsers permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableTestTones Method

EnableTestTones Method

Enables testtones to all channels. Is not possible to enable testtones when 'slave' mode or 'auxiliary' mode is active
Syntax
Json
Request:

Copy
{
    "enable": <bool>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

enableTestTonesChanged
systemModeChanged


ConferenceApiHandler.GetAuxiliaryGainLevel Method

GetAuxiliaryGainLevel Method

Gets the auxiliary gain level.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "level": <double>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryMutedState Method

GetAuxiliaryMutedState Method

Gets the analog auxiliary active state
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "muted": <bool>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

auxiliaryMuteStateChanged
systemModeChanged


ConferenceApiHandler.GetAuxiliaryState Method

GetAuxiliaryState Method

Gets the analog auxiliary active state
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "active": <bool>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

auxiliaryActiveStateChanged
systemModeChanged


ConferenceApiHandler.GetCarriersState Method

GetCarriersState Method

Gets the enabled state of the carriers
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "carriersInfo":
    [
        {
            "carrierId": <int>,
            "enabled": <bool>
        }
    ]
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

carrierStateChanged


ConferenceApiHandler.GetControlModeConfiguration Method

GetControlModeConfiguration Method

Gets the currently configured Standalone or DICENTIS mode of the INT-TXO.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "mode": "dicentis"|"standalone"
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

controlModeConfigurationChanged
systemModeChanged


ConferenceApiHandler.GetDateTime Method

GetDateTime Method

Gets the local date and time as single string in iso-8601 format (yyyy-MM-ddTHH:mm:ss)
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "dateTime": <string>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

dateTimeChanged


ConferenceApiHandler.GetDicentisConnectionState Method

GetDicentisConnectionState Method

Gets the state of the connection with the DICENTIS system
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "connected": <bool>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

dicentisConnectionStateChanged


ConferenceApiHandler.GetEnableTestTones Method

GetEnableTestTones Method

Gets the enabled state of testtones to all channels
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "enable": <bool>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

enableTestTonesChanged
systemModeChanged


ConferenceApiHandler.GetInputContactState Method

GetInputContactState Method

Gets the input contact state of the transmitter
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "engaged": <bool>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

inputContactStateChanged


ConferenceApiHandler.GetLanguageDistributionInfo Method

GetLanguageDistributionInfo Method

Gets Language Distribution Info
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "languageDistributionInfo":
    {
        "numberOfActiveLanguages": <int>,
        "numberOfReceivedLanguages": <int>
    }
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

languageDistributionInfoChanged


ConferenceApiHandler.GetLanguageGainLevels Method

GetLanguageGainLevels Method

Gets the channel gain levels.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "languageGainLevels":
    [
        {
            "languageId": <int>,
            "level": <double>
        }
    ]
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageMutedStates Method

GetLanguageMutedStates Method

Gets the muted state of the languages
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "languageMutedStates":
    [
        {
            "languageId": <int>,
            "muted": <bool>
        }
    ]
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

languageMutedStatesChanged


ConferenceApiHandler.GetLanguagesConfiguration Method

GetLanguagesConfiguration Method

Gets the overall language, channel and carrier configuration for routing audio. Returns the current transmitted language configuration, including to which carrier the channels for the language are allocated. The sourceInput indicates which Dicentis language with languageId matching the sourceInput is being received and transmitted to the receiver. The sourceInput is ignored for Dante languages.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "languageConfigurations":
    [
        {
            "channels":
            [
                {
                    "audioSlot": <int>,
                    "carrierId": <int>,
                    "channelId": <int>
                }
            ],
            "enabled": <bool>,
            "label": <string>,
            "languageId": <int>,
            "mode": "mono"|"stereo",
            "sourceInput": <int>,
            "sourceType": "dicentis"|"dante"
        }
    ]
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

languagesConfigurationChanged
SetLanguageAudioModes
SetLanguageSourceTypes
SetLanguageInputs


ConferenceApiHandler.GetLatestLogs Method

GetLatestLogs Method

This function gets the latest logs from the INT-TXO starting from the moment this function was last called
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "logs": [<string>]
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLicenses Method

GetLicenses Method

Gets the installed licenses on the device
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "licenseInfo":
    {
        "activationInfo":
        {
            "deviceId": <string>,
            "licenses":
            [
                {
                    "activationDate": <string>,
                    "expirationDate": <string>,
                    "featureName": <string>,
                    "quantity": <int>
                }
            ],
            "version": <string>
        },
        "customerInfo":
        {
            "address": <string>,
            "city": <string>,
            "country": <string>,
            "customerName": <string>,
            "locationName": <string>
        }
    }
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLoginStatus Method

GetLoginStatus Method

Gets the login status
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "loggedIn": <bool>
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogLevel Method

GetLogLevel Method

This function gets the loglevel set on the INT-TXO
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "logLevel": "default"|"trace"|"info"|"warning"|"error"
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

logLevelChanged


ConferenceApiHandler.GetLogs Method

GetLogs Method

This function gets all logs available on the INT-TXO
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "logs": [<string>]
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsTail Method

GetLogsTail Method

This function gets last count of logs from the eventlog on the INT-TXO
Syntax
Json
Request:

Copy
{
    "count": <int>
}

Response:

Copy
{
    "logs": [<string>]
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNetworkInfo Method

GetNetworkInfo Method

Gets the network information
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "networkInfo":
    {
        "capIpAddr": <string>,
        "capMacAddr": <string>,
        "deviceName": <string>,
        "gateway": <string>,
        "hostname": <string>,
        "ipAssignmentMode": "dhcp"|"manual",
        "mainIpAddr": <string>,
        "mainMacAddr": <string>,
        "rstp": <bool>,
        "serialNumber": <string>,
        "subnetMask": <string>
    }
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

networkInfoChanged


ConferenceApiHandler.GetNumberOfLanguagesLimit Method

GetNumberOfLanguagesLimit Method

Gets the configured maximum number of languages to transmit
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "limit": <int>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

numberOfLanguagesLimitChanged
languagesConfigurationChanged


ConferenceApiHandler.GetOperationMode Method

GetOperationMode Method

Gets the master/slave operation mode
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "mode": "master"|"slave"
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

operationModeChanged
systemModeChanged


ConferenceApiHandler.GetPermissions Method

GetPermissions Method

Gets the permissions of the logged-in user
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "permissions":
    [
        "canRegisterFirstUse"|"canViewTransmitterStatus"|"canControlTransmitter"|"canControlAudio"|"canConfigureLicenses"|"canSwitchSystemPowerOff"|
    ]
}
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQualityConfiguration Method

GetQualityConfiguration Method

Gets the overall channel quality configuration setting
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "quality": "standard"|"premium"
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

qualityConfigurationChanged


ConferenceApiHandler.GetRadiatorsState Method

GetRadiatorsState Method

Gets the radiators state connected to the INT-TXO
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "radiatorsInfo":
    [
        {
            "hasError": <bool>,
            "isPresent": <bool>,
            "radiatorId": <int>
        }
    ]
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

radiatorStateChanged


ConferenceApiHandler.GetRegisterFirstUseState Method

GetRegisterFirstUseState Method

Gets the state of registering for first use
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "firstUseState": <bool>
}
See Also

Reference

registerFirstUseStateChanged


ConferenceApiHandler.GetStandbyState Method

GetStandbyState Method

Gets the standby state of the transmitter
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "standby": <bool>
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

standbyStateChanged


ConferenceApiHandler.GetSystemMode Method

GetSystemMode Method

Gets the current system mode the INT-TXO is in.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "mode": "dicentis"|"standalone"|"auxiliary"|"test"|"slave"
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

systemModeChanged


ConferenceApiHandler.GetUsers Method

GetUsers Method

Gets the users
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "users":
    [
        {
            "firstName": <string>,
            "lastName": <string>,
            "role": <string>,
            "user": <string>
        }
    ]
}
Remarks
Requires one of the following permissions:
  • canChangeOwnPassword permission.
    Provides only the data of the logged in user.
  • canManageUsers permission.
    Provides data of all users.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVersionInfo Method

GetVersionInfo Method

Gets the version information
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
    "versionInfo":
    {
        "mainVersion": <string>,
        "omneoVersion": <string>,
        "productVersion": <string>
    }
}
Remarks
Requires:
  • canViewTransmitterStatus permission.
See Also

Reference

versionInfoChanged


ConferenceApiHandler.Login Method

Login Method

Logs in the user
Syntax
Json
Request:

Copy
{
    "password": <string>,
    "user": <string>
}

Response:

Copy
{
    "loggedIn": <bool>
}
See Also

Reference

Logout


ConferenceApiHandler.Logout Method

Logout Method

Logs the user out
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

Login


ConferenceApiHandler.ProcessLicensePackage Method

ProcessLicensePackage Method

Issues a request to process a license response package
Syntax
Json
Request:

Copy
{
    "package": <string>
}

Response:

Copy
{
    "package": <string>
}
Remarks
Requires:
  • canConfigureLicenses permission.
See Also

Reference

licensesChanged


ConferenceApiHandler.Reboot Method

Reboot Method

Triggers an unconditional reboot of the transmitter
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterAudioLevels Method

RegisterAudioLevels Method

This functions allows to register for audio level updates for the channels.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks

Upon sending this message it will trigger the INT-TXO to start sending audio level updates whenever an audio level of one or more channels has changed.

Remarks
Requires:
  • canViewDashboard permission.
See Also

Reference

UnregisterAudioLevels


ConferenceApiHandler.RegisterEvents Method

RegisterEvents Method

This function allows to register for events (e.g.: The number of active channels changed or permissions changed) of which the current data needs to be requested, whenever the event is triggered
Syntax
Json
Request:

Copy
{
    "events":
    [
        "loginStateChanged"|"permissionsChanged"|"standbyStateChanged"|"operationModeChanged"|"enableTestTonesChanged"|"licensesChanged"|
        "registerFirstUseStateChanged"|"languageDistributionInfoChanged"|"networkInfoChanged"|"radiatorStateChanged"|"carrierStateChanged"|
        "versionInfoChanged"|"userInfoChanged"|"auxiliaryActiveStateChanged"|"systemModeChanged"|"controlModeConfigurationChanged"|"qualityConfigurationChanged"|
        "languagesConfigurationChanged"|"languageGainLevelsChanged"|"auxiliaryGainLevelChanged"|"dicentisConnectionStateChanged"|"inputContactStateChanged"|
        "languageMutedStatesChanged"|"auxiliaryMutedStateChanged"|"numberOfLanguagesLimitChanged"|"dateTimeChanged"|"logLevelChanged"
    ]
}

Response:

Copy
{
}
Remarks
The loginStateChanged event does not require registration.
See Also

Reference

UnregisterEvents


ConferenceApiHandler.RegisterFirstUse Method

RegisterFirstUse Method

Registers first use
Syntax
Json
Request:

Copy
{
    "password": <string>
}

Response:

Copy
{
}
See Also

Reference

registerFirstUseStateChanged


ConferenceApiHandler.RemoveUser Method

RemoveUser Method

Removes a user
Syntax
Json
Request:

Copy
{
    "user": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canManageUsers permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetToFactoryDefault Method

ResetToFactoryDefault Method

Resets the transmitter to its factory defaults
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RestoreConfiguration Method

RestoreConfiguration Method

Restore configuration data retrieved with 'backupConfiguration'
Syntax
Json
Request:

Copy
{
    "package": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission. canManageUsers permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryGainLevel Method

SetAuxiliaryGainLevel Method

This function allows to set the gain level of the auxiliary input, valid values between -12dB and 12dB in steps of 0.5dB
Syntax
Json
Request:

Copy
{
    "level": <double>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlAudio permission.
See Also

Reference

auxiliaryGainLevelChanged


ConferenceApiHandler.SetAuxiliaryMutedState Method

SetAuxiliaryMutedState Method

This function allows to set the muted state of the auxiliary input
Syntax
Json
Request:

Copy
{
    "muted": <bool>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlAudio permission.
See Also

Reference

auxiliaryMuteStateChanged


ConferenceApiHandler.SetCarriersState Method

SetCarriersState Method

Sets the carriers state connected to the INT-TXO
Syntax
Json
Request:

Copy
{
    "carriersInfo":
    [
        {
            "carrierId": <int>,
            "enabled": <bool>
        }
    ]
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

carrierStateChanged


ConferenceApiHandler.SetControlMode Method

SetControlMode Method

Sets the control mode of the INT-TXO. The control mode configuration setting is stored persistently in the INT-TXO's configuration. The operational state of the control mode will only change when the current state of the INT-TXO allows for it.
Syntax
Json
Request:

Copy
{
    "mode": "dicentis"|"standalone"
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

controlModeConfigurationChanged
systemModeChanged


ConferenceApiHandler.SetDateTime Method

SetDateTime Method

Sets the current local date and time as single string in iso-8601 format (yyyy-MM-ddTHH:mm:ss)
Syntax
Json
Request:

Copy
{
    "dateTime": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

dateTimeChanged


ConferenceApiHandler.SetHostname Method

SetHostname Method

Change the hostname of the INT-TXO
Syntax
Json
Request:

Copy
{
    "hostname": <string>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

networkInfoChanged


ConferenceApiHandler.SetLanguageAudioModes Method

SetLanguageAudioModes Method

This functions sets the audio mode for the given list of languages.
Syntax
Json
Request:

Copy
{
    "languageAudioModes":
    [
        {
            "languageId": <int>,
            "mode": "mono"|"stereo"
        }
    ]
}

Response:

Copy
{
}
See Also

Reference

languagesConfigurationChanged


ConferenceApiHandler.SetLanguageGainLevels Method

SetLanguageGainLevels Method

This function allows to set the gain level of the given set of languages, valid values between -12dB and 12dB in steps of 0.5dB
Syntax
Json
Request:

Copy
{
    "languageGainLevels":
    [
        {
            "languageId": <int>,
            "level": <double>
        }
    ]
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlAudio permission.
See Also

Reference

languageGainLevelsChanged


ConferenceApiHandler.SetLanguageInputs Method

SetLanguageInputs Method

This function sets the source input configuration for the given list languages. For a language definition with 'languageId', sets a Dicentis language languageId as 'sourceInput'. The Dicentis language configured as 'sourceInput' will then be receive and transmitted to the receiver. The default value of a sourceInput equals the languageId.The sourceInput is only valid/used for Dicentis languages.
Syntax
Json
Request:

Copy
{
    "languageInputs":
    [
        {
            "languageId": <int>,
            "sourceInput": <int>
        }
    ]
}

Response:

Copy
{
}
See Also

Reference

languagesConfigurationChanged


ConferenceApiHandler.SetLanguageLabels Method

SetLanguageLabels Method

This function sets thelabels for the given list of languages.
Syntax
Json
Request:

Copy
{
    "languageLabels":
    [
        {
            "label": <string>,
            "languageId": <int>
        }
    ]
}

Response:

Copy
{
}
See Also

Reference

languagesConfigurationChanged


ConferenceApiHandler.SetLanguageMutedStates Method

SetLanguageMutedStates Method

This function sets the muted state for the given list of languages.
Syntax
Json
Request:

Copy
{
    "languageMutedStates":
    [
        {
            "languageId": <int>,
            "muted": <bool>
        }
    ]
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlAudio permission.
See Also

Reference

languageMutedStatesChanged


ConferenceApiHandler.SetLanguageSourceTypes Method

SetLanguageSourceTypes Method

This function sets the source types for the given list of languages.
Syntax
Json
Request:

Copy
{
    "languageSourceTypes":
    [
        {
            "languageId": <int>,
            "sourceType": "dicentis"|"dante"
        }
    ]
}

Response:

Copy
{
}
See Also

Reference

languagesConfigurationChanged


ConferenceApiHandler.SetLogLevel Method

SetLogLevel Method

This function sets the loglevel on the INT-TXO
Syntax
Json
Request:

Copy
{
    "logLevel": "default"|"trace"|"info"|"warning"|"error"
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

logLevelChanged


ConferenceApiHandler.SetManualNetworkIpSettings Method

SetManualNetworkIpSettings Method

This functions allows to set the network settings
Syntax
Json
Request:

Copy
{
    "settings":
    {
        "capIpAddr": <string>,
        "gateway": <string>,
        "mainIpAddr": <string>,
        "subnetMask": <string>
    }
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

networkInfoChanged


ConferenceApiHandler.SetNetworkIpAssignmentMode Method

SetNetworkIpAssignmentMode Method

Indicates whether network address should assigned automatically (DHCP) or manual
Syntax
Json
Request:

Copy
{
    "ipAssignmentMode": "dhcp"|"manual"
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

networkInfoChanged


ConferenceApiHandler.SetNumberOfLanguagesLimit Method

SetNumberOfLanguagesLimit Method

Configures the maximum number of languages to transmit
Syntax
Json
Request:

Copy
{
    "limit": <int>
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

numberOfLanguagesLimitChanged
languagesConfigurationChanged


ConferenceApiHandler.SetQualityConfiguration Method

SetQualityConfiguration Method

Sets the overall channel quality configuration
Syntax
Json
Request:

Copy
{
    "quality": "standard"|"premium"
}

Response:

Copy
{
}
Remarks
Requires:
  • canControlTransmitter permission.
See Also

Reference

qualityConfigurationChanged


ConferenceApiHandler.SetStandbyState Method

SetStandbyState Method

Gets the standby state of the transmitter: 'on' or 'off'
Syntax
Json
Request:

Copy
{
    "standby": <bool>
}

Response:

Copy
{
}
Remarks
Requires:
  • canSwitchSystemPowerOff permission.
See Also

Reference

standbyStateChanged


ConferenceApiHandler.UnregisterAudioLevels Method

UnregisterAudioLevels Method

This functions allows to unregister from audio level updates.
Syntax
Json
Request:

Copy
{
}

Response:

Copy
{
}
See Also

Reference

RegisterAudioLevels


ConferenceApiHandler.UnregisterEvents Method

UnregisterEvents Method

This functions allows to un register for the registered events
Syntax
Json
Request:

Copy
{
    "events":
    [
        "loginStateChanged"|"permissionsChanged"|"standbyStateChanged"|"operationModeChanged"|"enableTestTonesChanged"|"licensesChanged"|
        "registerFirstUseStateChanged"|"languageDistributionInfoChanged"|"networkInfoChanged"|"radiatorStateChanged"|"carrierStateChanged"|
        "versionInfoChanged"|"userInfoChanged"|"auxiliaryActiveStateChanged"|"systemModeChanged"|"controlModeConfigurationChanged"|"qualityConfigurationChanged"|
        "languagesConfigurationChanged"|"languageGainLevelsChanged"|"auxiliaryGainLevelChanged"|"dicentisConnectionStateChanged"|"inputContactStateChanged"|
        "languageMutedStatesChanged"|"auxiliaryMutedStateChanged"|"numberOfLanguagesLimitChanged"|"dateTimeChanged"|"logLevelChanged"
    ]
}

Response:

Copy
{
}
See Also

Reference

RegisterEvents
For the list of available events to register on


ConferenceApiHandler.UpdateUser Method

UpdateUser Method

Updates a user.
Syntax
Json
Request:

Copy
{
    "firstName": <string>,
    "lastName": <string>,
    "role": <string>,
    "user": <string>,
    "password": <string>
}

Response:

Copy
{
}
Remarks
Each field is optional.
Only the changing fields need to be provided.

Changing the role of the logged in user is not possible.
Changing the password of the logged in user is blocked. Use ChangeOwnPassword instead.

Requires:
  • canManageUsers permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RestoreConfigurationRequest Class

ConferenceApiHandlerRestoreConfigurationRequest Class

Restore configuration data that was retrieved by 'backupConfiguration'
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRestoreConfigurationRequest
Syntax
Json
{ JsonClass:RestoreConfigurationRequest		Package:<type>,
 }

The ConferenceApiHandlerRestoreConfigurationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRestoreConfigurationRequest | Initializes a new instance of the ConferenceApiHandlerRestoreConfigurationRequest class
Top
Properties
 | Name | Description
Public property | Package | A binary blob
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyState Constructor

Initializes a new instance of the JsonStandbyState class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCustomerInfo.LocationName Property

LocationName Property

Syntax
Json
{ Property:LocationName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguagesConfigurationResponse Class

ConferenceApiHandlerGetLanguagesConfigurationResponse Class

Response from GetLanguagesConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLanguagesConfigurationResponse
Syntax
Json
{ JsonClass:GetLanguagesConfigurationResponse		LanguageConfigurations:<type>,
 }

The ConferenceApiHandlerGetLanguagesConfigurationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLanguagesConfigurationResponse | Initializes a new instance of the ConferenceApiHandlerGetLanguagesConfigurationResponse class
Top
Properties
 | Name | Description
Public property | LanguageConfigurations | The audio channel configuration set for each channel
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCount.Count Property

Count Property

Syntax
Json
{ Property:Count }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCustomerInfo.Country Property

Country Property

Syntax
Json
{ Property:Country }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetLogLevelResponse Properties

The ConferenceApiHandlerGetLogLevelResponse type exposes the following members.

Properties
 | Name | Description
Public property | LogLevel | The loglevel to be set
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLogLevelRequest Constructor

ConferenceApiHandlerSetLogLevelRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetLogLevelRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryMutedState Constructor

Initializes a new instance of the JsonAuxiliaryMutedState class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSystemMode Constructor

Initializes a new instance of the JsonSystemMode class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetManualNetworkIpSettingsResponse Constructor

ConferenceApiHandlerSetManualNetworkIpSettingsResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetManualNetworkIpSettingsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetQualityConfigurationRequest.Quality Property

Quality Property

Indicates the overall channel quality configuration setting
Syntax
Json
{ Property:Quality }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageDistributionInfo Properties

The JsonLanguageDistributionInfo type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfActiveLanguages |
Public property | NumberOfReceivedLanguages |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoGet Constructor

Initializes a new instance of the JsonUserInfoGet class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfo.Enabled Property

Enabled Property

Syntax
Json
{ Property:Enabled }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageDistributionInfo Properties

The LanguageDistributionInfo type exposes the following members.

Properties
 | Name | Description
Public property | NumberOfActiveLanguages | The number of active channels that visible on the receivers
Public property | NumberOfReceivedLanguages | The number of languages that INT-TXO received
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.QueueWorkItem Method

QueueWorkItem Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfoList.LanguageMutedStates Property

LanguageMutedStates Property

Syntax
Json
{ Property:LanguageMutedStates }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelConfigurationInfoList Properties

The JsonChannelConfigurationInfoList type exposes the following members.

Properties
 | Name | Description
Public property | LanguagesConfiguration |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterAudioLevelsResponse Class

ConferenceApiHandlerRegisterAudioLevelsResponse Class

Response from RegisterAudioLevels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRegisterAudioLevelsResponse
Syntax
Json
{ JsonClass:RegisterAudioLevelsResponse	 }

The ConferenceApiHandlerRegisterAudioLevelsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterAudioLevelsResponse | Initializes a new instance of the ConferenceApiHandlerRegisterAudioLevelsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguagesConfigurationResponse.LanguageConfigurations Property

LanguageConfigurations Property

The audio channel configuration set for each channel
Syntax
Json
{ Property:LanguageConfigurations }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourcesList Properties

The JsonLanguageSourcesList type exposes the following members.

Properties
 | Name | Description
Public property | LanguageInputs |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetRegisterFirstUseStateResponse Properties

The ConferenceApiHandlerGetRegisterFirstUseStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | FirstUseState | Indicates whether first time use registration is active or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CustomerRegistrationInfo.Address Property

Address Property

The address of the customer
Syntax
Json
{ Property:Address }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetStandbyStateResponse Constructor

ConferenceApiHandlerGetStandbyStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetStandbyStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNumberOfLanguagesLimitRequest Class

ConferenceApiHandlerSetNumberOfLanguagesLimitRequest Class

Parameters to SetNumberOfLanguagesLimit
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetNumberOfLanguagesLimitRequest
Syntax
Json
{ JsonClass:SetNumberOfLanguagesLimitRequest		Limit:<type>,
 }

The ConferenceApiHandlerSetNumberOfLanguagesLimitRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetNumberOfLanguagesLimitRequest | Initializes a new instance of the ConferenceApiHandlerSetNumberOfLanguagesLimitRequest class
Top
Properties
 | Name | Description
Public property | Limit | Indicates maximum number of languages to transmit
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.SerialNumber Property

SerialNumber Property

Syntax
Json
{ Property:SerialNumber }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageAudioLevelsList.Languages Property

Languages Property

Syntax
Json
{ Property:Languages }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkIpSetting Constructor

Initializes a new instance of the JsonNetworkIpSetting class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserCredentials.Username Property

Username Property

Syntax
Json
{ Property:Username }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTestTones Properties

The JsonTestTones type exposes the following members.

Properties
 | Name | Description
Public property | Enable |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InstalledLicense Constructor

Initializes a new instance of the InstalledLicense class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RestoreConfigurationRequest Properties

The ConferenceApiHandlerRestoreConfigurationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Package | A binary blob
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserCredentials.Password Property

Password Property

Syntax
Json
{ Property:Password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateLicensesRequest Class

ConferenceApiHandlerActivateLicensesRequest Class

Request for activate licenses
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerActivateLicensesRequest
Syntax
Json
{ JsonClass:ActivateLicensesRequest		ActivationIds:<type>,
    Dictionary:<type>,
 }

The ConferenceApiHandlerActivateLicensesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateLicensesRequest | Initializes a new instance of the ConferenceApiHandlerActivateLicensesRequest class
Top
Properties
 | Name | Description
Public property | ActivationIds | The list of activation ID's requested
Public property | Dictionary | The information of the customer activating the license(s)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfoList.LanguageLabels Property

LanguageLabels Property

Syntax
Json
{ Property:LanguageLabels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicense Constructor

Initializes a new instance of the JsonInstalledLicense class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLogLevelRequest Class

ConferenceApiHandlerSetLogLevelRequest Class

Parameters to SetLogLevel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLogLevelRequest
Syntax
Json
{ JsonClass:SetLogLevelRequest		LogLevel:<type>,
 }

The ConferenceApiHandlerSetLogLevelRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLogLevelRequest | Initializes a new instance of the ConferenceApiHandlerSetLogLevelRequest class
Top
Properties
 | Name | Description
Public property | LogLevel |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryActivation Constructor

Initializes a new instance of the JsonAuxiliaryActivation class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsRequest Constructor

ConferenceApiHandlerUnregisterEventsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerUnregisterEventsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivationInfo Class

Describes activated license on the transmitter
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientActivationInfo
Syntax
Json
{ JsonClass:ActivationInfo		DeviceId:<type>,
    Licenses:<type>,
    Version:<type>,
 }

The ActivationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationInfo | Initializes a new instance of the ActivationInfo class
Top
Properties
 | Name | Description
Public property | DeviceId | The devices identification
Public property | Licenses | The list of installed licenses on the device
Public property | Version | The version string of the license manager on the device
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCustomerInfo.CustomerName Property

CustomerName Property

Syntax
Json
{ Property:CustomerName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryGainLevelRequest Constructor

ConferenceApiHandlerSetAuxiliaryGainLevelRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetAuxiliaryGainLevelRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetLogsTailResponse Properties

The ConferenceApiHandlerGetLogsTailResponse type exposes the following members.

Properties
 | Name | Description
Public property | Logs | The logs returned from the tail
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDateTimeRequest Constructor

ConferenceApiHandlerGetDateTimeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetDateTimeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageMutedStatesRequest.LanguageMutedStates Property

LanguageMutedStates Property

The list of language muted status.
Syntax
Json
{ Property:LanguageMutedStates }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCustomerInfo.Address Property

Address Property

Syntax
Json
{ Property:Address }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNumberOfLanguagesLimitResponse Constructor

ConferenceApiHandlerGetNumberOfLanguagesLimitResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetNumberOfLanguagesLimitResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLoginStatus Constructor

Initializes a new instance of the JsonLoginStatus class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivationInfo.Licenses Property

Licenses Property

The list of installed licenses on the device
Syntax
Json
{ Property:Licenses }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject.Dispose Method

Dispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the DisposableObject
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DisposableObject and optionally releases the managed resources
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetCarriersStateRequest.CarriersInfo Property

CarriersInfo Property

The carriers to set
Syntax
Json
{ Property:CarriersInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQualityConfigurationResponse.Quality Property

Quality Property

Indicates the overall channel quality configuration setting.
Syntax
Json
{ Property:Quality }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChangeOwnPassword Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonChangeOwnPassword
Syntax
Json
{ JsonClass:JsonChangeOwnPassword		CurrentPassword:<type>,
    NewPassword:<type>,
 }

The JsonChangeOwnPassword type exposes the following members.

Constructors
 | Name | Description
Public method | JsonChangeOwnPassword | Initializes a new instance of the JsonChangeOwnPassword class
Top
Properties
 | Name | Description
Public property | CurrentPassword |
Public property | NewPassword |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicense.Quantity Property

Quantity Property

Syntax
Json
{ Property:Quantity }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryAudioLevel Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonAuxiliaryAudioLevel
Syntax
Json
{ JsonClass:JsonAuxiliaryAudioLevel		DbLevel:<type>,
 }

The JsonAuxiliaryAudioLevel type exposes the following members.

Constructors
 | Name | Description
Public method | JsonAuxiliaryAudioLevel | Initializes a new instance of the JsonAuxiliaryAudioLevel class
Top
Properties
 | Name | Description
Public property | DbLevel |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLogs.Logs Property

Logs Property

Syntax
Json
{ Property:Logs }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageMutedStateInfo.LanguageId Property

LanguageId Property

The ID of the language
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItem.AsyncWaitHandle Property

AsyncWaitHandle Property

Syntax
Json
{ Property:AsyncWaitHandle }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginResponse.LoggedIn Property

LoggedIn Property

Loggeg in status
Syntax
Json
{ Property:LoggedIn }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItem Constructor

Initializes a new instance of the WorkItem class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryStateResponse Constructor

ConferenceApiHandlerGetAuxiliaryStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevelsList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageGainLevelsList
Syntax
Json
{ JsonClass:JsonLanguageGainLevelsList		LanguageGainLevels:<type>,
 }

The JsonLanguageGainLevelsList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageGainLevelsList | Initializes a new instance of the JsonLanguageGainLevelsList class
Top
Properties
 | Name | Description
Public property | LanguageGainLevels |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonOperationMode Constructor

Initializes a new instance of the JsonOperationMode class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSourceTypeInfo Class

Defines the label of a channel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguageSourceTypeInfo
Syntax
Json
{ JsonClass:LanguageSourceTypeInfo		LanguageId:<type>,
    SourceType:<type>,
 }

The LanguageSourceTypeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageSourceTypeInfo | Initializes a new instance of the LanguageSourceTypeInfo class
Top
Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | SourceType | The audio source type for the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterAudioLevelsRequest Constructor

ConferenceApiHandlerUnregisterAudioLevelsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerUnregisterAudioLevelsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AudioChannelLevel.DbLevel Property

DbLevel Property

The level of the audio for the channel
Syntax
Json
{ Property:DbLevel }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetControlModeResponse Constructor

ConferenceApiHandlerSetControlModeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetControlModeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageLabelInfo Constructor

Initializes a new instance of the LanguageLabelInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessage Constructor

Initializes a new instance of the JsonMessage class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetControlModeRequest.Mode Property

Mode Property

The operational control mode.
Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddUserResponse Class

ConferenceApiHandlerAddUserResponse Class

Response from addUser
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerAddUserResponse
Syntax
Json
{ JsonClass:AddUserResponse	 }

The ConferenceApiHandlerAddUserResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerAddUserResponse | Initializes a new instance of the ConferenceApiHandlerAddUserResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSource.SourceInput Property

SourceInput Property

Syntax
Json
{ Property:SourceInput }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.BackupConfigurationRequest Class

ConferenceApiHandlerBackupConfigurationRequest Class

Parameters to backupConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerBackupConfigurationRequest
Syntax
Json
{ JsonClass:BackupConfigurationRequest	 }

The ConferenceApiHandlerBackupConfigurationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerBackupConfigurationRequest | Initializes a new instance of the ConferenceApiHandlerBackupConfigurationRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ProcessLicensePackageRequest Properties

The ConferenceApiHandlerProcessLicensePackageRequest type exposes the following members.

Properties
 | Name | Description
Public property | Package | The package to process.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAuxiliaryResponse Constructor

ConferenceApiHandlerActivateAuxiliaryResponse Constructor

Initializes a new instance of the ConferenceApiHandlerActivateAuxiliaryResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread Constructor

Initializes a new instance of the WorkerThread class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypeInfo Constructor

Initializes a new instance of the JsonLanguageSourceTypeInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.EndLoop Property

EndLoop Property

Syntax
Json
{ Property:EndLoop }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevel Constructor

Initializes a new instance of the JsonLanguageGainLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryStateResponse.Active Property

Active Property

Indicates whether the analog auxiliary input is active or not
Syntax
Json
{ Property:Active }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoList Constructor

Initializes a new instance of the JsonUserInfoList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RadiatorInfo.RadiatorId Property

RadiatorId Property

The ID of the radiator
Syntax
Json
{ Property:RadiatorId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetAuxiliaryGainLevelRequest Properties

The ConferenceApiHandlerSetAuxiliaryGainLevelRequest type exposes the following members.

Properties
 | Name | Description
Public property | Level | The gain level of the auxiliary input
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer Constructor

Initializes a new instance of the Synchronizer class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject.Dispose Method

Dispose Method

Releases all resources used by the DisposableObject
Syntax
Json
Request
Response

Implements

IDisposableDispose
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguagesConfigurationInfo
Syntax
Json
{ JsonClass:JsonLanguagesConfigurationInfo		Channels:<type>,
    Label:<type>,
    LanguageId:<type>,
    Mode:<type>,
    SourceInput:<type>,
    SourceType:<type>,
 }

The JsonLanguagesConfigurationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguagesConfigurationInfo | Initializes a new instance of the JsonLanguagesConfigurationInfo class
Top
Properties
 | Name | Description
Public property | Channels |
Public property | Label |
Public property | LanguageId |
Public property | Mode |
Public property | SourceInput |
Public property | SourceType |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRadiatorsStateResponse Class

ConferenceApiHandlerGetRadiatorsStateResponse Class

Response from GetRadiatorsState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetRadiatorsStateResponse
Syntax
Json
{ JsonClass:GetRadiatorsStateResponse		RadiatorsInfo:<type>,
 }

The ConferenceApiHandlerGetRadiatorsStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetRadiatorsStateResponse | Initializes a new instance of the ConferenceApiHandlerGetRadiatorsStateResponse class
Top
Properties
 | Name | Description
Public property | RadiatorsInfo | The radiators and their status
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfoList.RadiatorsInfo Property

RadiatorsInfo Property

Syntax
Json
{ Property:RadiatorsInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioLevel Properties

The LanguageAudioLevel type exposes the following members.

Properties
 | Name | Description
Public property | Channels | The list of allocated channels and the corresponding audio level in decibels.
Public property | LanguageId | The language for which the audio levels are applicable.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSourceTypeInfo Constructor

Initializes a new instance of the LanguageSourceTypeInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.Gateway Property

Gateway Property

Syntax
Json
{ Property:Gateway }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoPut Properties

The JsonUserInfoPut type exposes the following members.

Properties
 | Name | Description
Public property | FirstName | (Inherited from JsonUserInfoGet.)
Public property | LastName | (Inherited from JsonUserInfoGet.)
Public property | Password |
Public property | Role | (Inherited from JsonUserInfoGet.)
Public property | User | (Inherited from JsonUserInfoGet.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageMutedStatesResponse Constructor

ConferenceApiHandlerGetLanguageMutedStatesResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetLanguageMutedStatesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageMutedStatesResponse.LanguageMutedStates Property

LanguageMutedStates Property

The mute state for list of languages
Syntax
Json
{ Property:LanguageMutedStates }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LicenseInfo Constructor

Initializes a new instance of the LicenseInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetOperationModeResponse Constructor

ConferenceApiHandlerGetOperationModeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetOperationModeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VersionInfo.ProductVersion Property

ProductVersion Property

The DICENTIS software version
Syntax
Json
{ Property:ProductVersion }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.ManagedThreadId Property

ManagedThreadId Property

Syntax
Json
{ Property:ManagedThreadId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetCarriersStateResponse Properties

The ConferenceApiHandlerGetCarriersStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | CarriersInfo | The information for all carriers
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioModesList Properties

The JsonLanguageAudioModesList type exposes the following members.

Properties
 | Name | Description
Public property | LanguageAudioModes |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetStandbyStateRequest Constructor

ConferenceApiHandlerSetStandbyStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetStandbyStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InstalledLicense.ExpirationDate Property

ExpirationDate Property

The expiratiom date of the license
Syntax
Json
{ Property:ExpirationDate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelConfigurationInfoList.LanguagesConfiguration Property

LanguagesConfiguration Property

Syntax
Json
{ Property:LanguagesConfiguration }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAudioChannelLevel.ChannelId Property

ChannelId Property

Syntax
Json
{ Property:ChannelId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuxiliaryAudioLevel.DbLevel Property

DbLevel Property

The level of the audio for the zuxiliary input
Syntax
Json
{ Property:DbLevel }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterFirstUseRequest.Password Property

Password Property

New password for Admin user upon first-time registration.
Syntax
Json
{ Property:Password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfo.CarrierId Property

CarrierId Property

Syntax
Json
{ Property:CarrierId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAuxiliaryRequest Constructor

ConferenceApiHandlerActivateAuxiliaryRequest Constructor

Initializes a new instance of the ConferenceApiHandlerActivateAuxiliaryRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetManualNetworkIpSettingsRequest Properties

The ConferenceApiHandlerSetManualNetworkIpSettingsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Settings | The network settings to be changed to
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetQualityConfigurationResponse Class

ConferenceApiHandlerSetQualityConfigurationResponse Class

Response from GetQualityConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetQualityConfigurationResponse
Syntax
Json
{ JsonClass:SetQualityConfigurationResponse	 }

The ConferenceApiHandlerSetQualityConfigurationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetQualityConfigurationResponse | Initializes a new instance of the ConferenceApiHandlerSetQualityConfigurationResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemModeResponse.Mode Property

Mode Property

The system mode.
Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsRequest Class

ConferenceApiHandlerGetLogsRequest Class

Parameters to GetLogs
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLogsRequest
Syntax
Json
{ JsonClass:GetLogsRequest	 }

The ConferenceApiHandlerGetLogsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLogsRequest | Initializes a new instance of the ConferenceApiHandlerGetLogsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivationInfo.DeviceId Property

DeviceId Property

Syntax
Json
{ Property:DeviceId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicenseInfo Properties

The JsonInstalledLicenseInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivationInfo |
Public property | CustomerInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivationInfo Properties

The ActivationInfo type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId | The devices identification
Public property | Licenses | The list of installed licenses on the device
Public property | Version | The version string of the license manager on the device
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSystemMode.Mode Property

Mode Property

Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetDateTimeResponse Constructor

ConferenceApiHandlerSetDateTimeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetDateTimeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetControlModeConfigurationRequest Constructor

ConferenceApiHandlerGetControlModeConfigurationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetControlModeConfigurationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageMutedStatesRequest Constructor

ConferenceApiHandlerGetLanguageMutedStatesRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetLanguageMutedStatesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler Events

The ConferenceApiHandler type exposes the following members.

Events
 | Name | Description
Public event | ApiAudioLevelsUpdateReceived |
Public event | ApiEventReceived |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRadiatorsStateRequest Constructor

ConferenceApiHandlerGetRadiatorsStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetRadiatorsStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivationInfo.Licenses Property

Licenses Property

Syntax
Json
{ Property:Licenses }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageLabelInfo Class

Defines the label of a channel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguageLabelInfo
Syntax
Json
{ JsonClass:LanguageLabelInfo		Label:<type>,
    LanguageId:<type>,
 }

The LanguageLabelInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageLabelInfo | Initializes a new instance of the LanguageLabelInfo class
Top
Properties
 | Name | Description
Public property | Label | The label of the language
Public property | LanguageId | The ID of the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSetHostname Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonSetHostname
Syntax
Json
{ JsonClass:JsonSetHostname		Hostname:<type>,
 }

The JsonSetHostname type exposes the following members.

Constructors
 | Name | Description
Public method | JsonSetHostname | Initializes a new instance of the JsonSetHostname class
Top
Properties
 | Name | Description
Public property | Hostname |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNetworkInfoRequest Class

ConferenceApiHandlerGetNetworkInfoRequest Class

Parameters to GetNetworkInfo
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetNetworkInfoRequest
Syntax
Json
{ JsonClass:GetNetworkInfoRequest	 }

The ConferenceApiHandlerGetNetworkInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetNetworkInfoRequest | Initializes a new instance of the ConferenceApiHandlerGetNetworkInfoRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo.Enabled Property

Enabled Property

Indicates if the channel is enabled or not
Syntax
Json
{ Property:Enabled }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsResponse Class

ConferenceApiHandlerGetPermissionsResponse Class

Response from GetPermissions
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetPermissionsResponse
Syntax
Json
{ JsonClass:GetPermissionsResponse		Permissions:<type>,
 }

The ConferenceApiHandlerGetPermissionsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPermissionsResponse | Initializes a new instance of the ConferenceApiHandlerGetPermissionsResponse class
Top
Properties
 | Name | Description
Public property | Permissions | Permissions list
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonDateTime.DateTime Property

DateTime Property

Syntax
Json
{ Property:DateTime }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonDateTime Properties

The JsonDateTime type exposes the following members.

Properties
 | Name | Description
Public property | DateTime |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ApiEventReceived Event

ApiEventReceived Event

Syntax
Json
{ Event:ApiEventReceived }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet Constructor (UserInfoGet)

Copy constructor
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLicensesRequest Class

ConferenceApiHandlerGetLicensesRequest Class

Request for getting licenses
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLicensesRequest
Syntax
Json
{ JsonClass:GetLicensesRequest	 }

The ConferenceApiHandlerGetLicensesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLicensesRequest | Initializes a new instance of the ConferenceApiHandlerGetLicensesRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRadiatorsStateResponse.RadiatorsInfo Property

RadiatorsInfo Property

The radiators and their status
Syntax
Json
{ Property:RadiatorsInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetQualityConfigurationRequest Properties

The ConferenceApiHandlerSetQualityConfigurationRequest type exposes the following members.

Properties
 | Name | Description
Public property | Quality | Indicates the overall channel quality configuration setting
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivateLicenseInfo Properties

The JsonActivateLicenseInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivationIds |
Public property | Dictionary |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVersionInfoResponse Constructor

ConferenceApiHandlerGetVersionInfoResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetVersionInfoResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivationInfo.DeviceId Property

DeviceId Property

The devices identification
Syntax
Json
{ Property:DeviceId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryMutedStateResponse Constructor

ConferenceApiHandlerSetAuxiliaryMutedStateResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetAuxiliaryMutedStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCustomerInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonCustomerInfo
Syntax
Json
{ JsonClass:JsonCustomerInfo		Address:<type>,
    City:<type>,
    Country:<type>,
    CustomerName:<type>,
    LocationName:<type>,
 }

The JsonCustomerInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonCustomerInfo | Initializes a new instance of the JsonCustomerInfo class
Top
Properties
 | Name | Description
Public property | Address |
Public property | City |
Public property | Country |
Public property | CustomerName |
Public property | LocationName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TcpIpProperties Constructor

Initializes a new instance of the TcpIpProperties class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AudioChannelLevel Properties

The AudioChannelLevel type exposes the following members.

Properties
 | Name | Description
Public property | ChannelId | The audio channel for which the audio level is applicable.
Public property | DbLevel | The level of the audio for the channel
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageUpdate Constructor

Initializes a new instance of the JsonMessageUpdate class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetControlModeConfigurationResponse Constructor

ConferenceApiHandlerGetControlModeConfigurationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetControlModeConfigurationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbySchedule Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonStandbySchedule
Syntax
Json
{ JsonClass:JsonStandbySchedule		Schedule:<type>,
 }

The JsonStandbySchedule type exposes the following members.

Constructors
 | Name | Description
Public method | JsonStandbySchedule | Initializes a new instance of the JsonStandbySchedule class
Top
Properties
 | Name | Description
Public property | Schedule |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioMode.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSource.LanguageId Property

LanguageId Property

The ID of the language
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogLevelRequest Class

ConferenceApiHandlerGetLogLevelRequest Class

Parameters to GetLogLevel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLogLevelRequest
Syntax
Json
{ JsonClass:GetLogLevelRequest	 }

The ConferenceApiHandlerGetLogLevelRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLogLevelRequest | Initializes a new instance of the ConferenceApiHandlerGetLogLevelRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageDistributionInfo Constructor

Initializes a new instance of the JsonLanguageDistributionInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryGainLevel Constructor

Initializes a new instance of the JsonAuxiliaryGainLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkIpSetting.IpAssignmentMode Property

IpAssignmentMode Property

Syntax
Json
{ Property:IpAssignmentMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonControlMode.Mode Property

Mode Property

Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetDateTimeRequest Constructor

ConferenceApiHandlerSetDateTimeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetDateTimeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivateLicenseInfo.Dictionary Property

Dictionary Property

Syntax
Json
{ Property:Dictionary }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioLevel Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageAudioLevel
Syntax
Json
{ JsonClass:JsonLanguageAudioLevel		Channels:<type>,
    LanguageId:<type>,
 }

The JsonLanguageAudioLevel type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageAudioLevel | Initializes a new instance of the JsonLanguageAudioLevel class
Top
Properties
 | Name | Description
Public property | Channels |
Public property | LanguageId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer Constructor

Overload List
 | Name | Description
Public method | Synchronizer | Initializes a new instance of the Synchronizer class
Public method | Synchronizer(String) | Initializes a new instance of the Synchronizer class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TxoConferenceApi.Operational Namespace

Classes
 | Class | Description
Public class | Synchronizer |
Protected class | WorkerThread |
Protected class | WorkerThreadWorkItemQueue |
Protected class | WorkItem |


JsonNumberOfLanguagesLimit Constructor

Initializes a new instance of the JsonNumberOfLanguagesLimit class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TcpIpProperties.SubnetMask Property

SubnetMask Property

The Subnet mask
Syntax
Json
{ Property:SubnetMask }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsTailResponse Constructor

ConferenceApiHandlerGetLogsTailResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetLogsTailResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChangeOwnPassword.CurrentPassword Property

CurrentPassword Property

Syntax
Json
{ Property:CurrentPassword }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetAuxiliaryMutedStateRequest Properties

The ConferenceApiHandlerSetAuxiliaryMutedStateRequest type exposes the following members.

Properties
 | Name | Description
Public property | Muted | The muted state of the auxiliary input
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoGet.User Property

User Property

Syntax
Json
{ Property:User }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevelsList.LanguageGainLevels Property

LanguageGainLevels Property

Syntax
Json
{ Property:LanguageGainLevels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject.Disposed Property

Disposed Property

Syntax
Json
{ Property:Disposed }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypeInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageSourceTypeInfo
Syntax
Json
{ JsonClass:JsonLanguageSourceTypeInfo		LanguageId:<type>,
    SourceType:<type>,
 }

The JsonLanguageSourceTypeInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageSourceTypeInfo | Initializes a new instance of the JsonLanguageSourceTypeInfo class
Top
Properties
 | Name | Description
Public property | LanguageId |
Public property | SourceType |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageGainLevel Constructor

Initializes a new instance of the LanguageGainLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateUserResponse Class

ConferenceApiHandlerUpdateUserResponse Class

Response from updateUser
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerUpdateUserResponse
Syntax
Json
{ JsonClass:UpdateUserResponse	 }

The ConferenceApiHandlerUpdateUserResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUpdateUserResponse | Initializes a new instance of the ConferenceApiHandlerUpdateUserResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyScheduleInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonStandbyScheduleInfo
Syntax
Json
{ JsonClass:JsonStandbyScheduleInfo		DateTime:<type>,
    Enabled:<type>,
    TimeZone:<type>,
 }

The JsonStandbyScheduleInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonStandbyScheduleInfo | Initializes a new instance of the JsonStandbyScheduleInfo class
Top
Properties
 | Name | Description
Public property | DateTime |
Public property | Enabled |
Public property | TimeZone |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetHostnameResponse Class

ConferenceApiHandlerSetHostnameResponse Class

Response from SetHostname
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetHostnameResponse
Syntax
Json
{ JsonClass:SetHostnameResponse	 }

The ConferenceApiHandlerSetHostnameResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetHostnameResponse | Initializes a new instance of the ConferenceApiHandlerSetHostnameResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetHostnameRequest Class

ConferenceApiHandlerSetHostnameRequest Class

Parameters to SetHostname
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetHostnameRequest
Syntax
Json
{ JsonClass:SetHostnameRequest		Hostname:<type>,
 }

The ConferenceApiHandlerSetHostnameRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetHostnameRequest | Initializes a new instance of the ConferenceApiHandlerSetHostnameRequest class
Top
Properties
 | Name | Description
Public property | Hostname | New hostname to set
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AudioSourceType Enumeration

The type of audio source
Syntax
Json
AudioSourceType:{
Dicentis
Dante}
Members
Member name | Value | Description
Dicentis | 0 | Dicentis
Dante | 1 | Dante
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetHostnameRequest Properties

The ConferenceApiHandlerSetHostnameRequest type exposes the following members.

Properties
 | Name | Description
Public property | Hostname | New hostname to set
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguagesConfigurationResponse Constructor

ConferenceApiHandlerGetLanguagesConfigurationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetLanguagesConfigurationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VersionInfo Properties

The VersionInfo type exposes the following members.

Properties
 | Name | Description
Public property | MainVersion | The main software version of the INT-TXO
Public property | OmneoVersion | The OMNEO software version
Public property | ProductVersion | The DICENTIS software version
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQualityConfigurationRequest Class

ConferenceApiHandlerGetQualityConfigurationRequest Class

Parameters to GetQualityConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetQualityConfigurationRequest
Syntax
Json
{ JsonClass:GetQualityConfigurationRequest	 }

The ConferenceApiHandlerGetQualityConfigurationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetQualityConfigurationRequest | Initializes a new instance of the ConferenceApiHandlerGetQualityConfigurationRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNumberOfLanguagesLimitRequest.Limit Property

Limit Property

Indicates maximum number of languages to transmit
Syntax
Json
{ Property:Limit }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.Hostname Property

Hostname Property

Syntax
Json
{ Property:Hostname }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryMutedStateResponse Constructor

ConferenceApiHandlerGetAuxiliaryMutedStateResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryMutedStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSystemMode Properties

The JsonSystemMode type exposes the following members.

Properties
 | Name | Description
Public property | Mode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDicentisConnectionStateResponse Constructor

ConferenceApiHandlerGetDicentisConnectionStateResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetDicentisConnectionStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLicenseInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLicenseInfo
Syntax
Json
{ JsonClass:JsonLicenseInfo		LicenseInfo:<type>,
 }

The JsonLicenseInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLicenseInfo | Initializes a new instance of the JsonLicenseInfo class
Top
Properties
 | Name | Description
Public property | LicenseInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonControlMode Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonControlMode
Syntax
Json
{ JsonClass:JsonControlMode		Mode:<type>,
 }

The JsonControlMode type exposes the following members.

Constructors
 | Name | Description
Public method | JsonControlMode | Initializes a new instance of the JsonControlMode class
Top
Properties
 | Name | Description
Public property | Mode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioLevel.Channels Property

Channels Property

Syntax
Json
{ Property:Channels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonEmpty Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonEmpty
Syntax
Json
{ JsonClass:JsonEmpty	 }

The JsonEmpty type exposes the following members.

Constructors
 | Name | Description
Public method | JsonEmpty | Initializes a new instance of the JsonEmpty class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableTestTonesResponse.Enable Property

Enable Property

Indicates whether all testtones to all channels is enabled
Syntax
Json
{ Property:Enable }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterAudioLevelsResponse Constructor

ConferenceApiHandlerUnregisterAudioLevelsResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerUnregisterAudioLevelsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.Gateway Property

Gateway Property

The default gateway of the INT-TXO
Syntax
Json
{ Property:Gateway }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageGainLevelsResponse.LanguageGainLevels Property

LanguageGainLevels Property

The gain levels for all audio available channels on the INT-TXO
Syntax
Json
{ Property:LanguageGainLevels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InstalledLicense.ActivationDate Property

ActivationDate Property

The activation date of the license
Syntax
Json
{ Property:ActivationDate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo.SourceInput Property

SourceInput Property

The source input for the language, applicable when SourceType is Dicentis
Syntax
Json
{ Property:SourceInput }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TxoConferenceApi.Client Namespace

Classes
 | Class | Description
Public class | ActivateLicenseInfo | Describes the license(s) to be activated
Public class | ActivationInfo | Describes activated license on the transmitter
Public class | AudioChannelLevel | Contains the audio level of the identified channel
Public class | AuxiliaryAudioLevel | Contains the audio level of the auxiliary input
Public class | CarrierInfo | Describes the status of a carrier
Public class | ChannelInfo | Describes the info for a channel
Public class | ConferenceApiHandler |
Public class | ConferenceApiHandlerActivateAuxiliaryRequest | Parameters to ActivateAuxiliary
Public class | ConferenceApiHandlerActivateAuxiliaryResponse | Response from ActivateAuxiliary
Public class | ConferenceApiHandlerActivateLicensesRequest | Request for activate licenses
Public class | ConferenceApiHandlerActivateLicensesResponse | Response for activating licenses
Public class | ConferenceApiHandlerAddUserRequest | Parameters to addUser. Obtains fields directly from UserInfoPut.
Public class | ConferenceApiHandlerAddUserResponse | Response from addUser
Public class | ConferenceApiHandlerBackupConfigurationRequest | Parameters to backupConfiguration
Public class | ConferenceApiHandlerBackupConfigurationResponse | Response from backupConfiguration
Public class | ConferenceApiHandlerChangeOwnPasswordRequest | Parameters to changeOwnPassword.
Public class | ConferenceApiHandlerChangeOwnPasswordResponse | Response from changeOwnPassword
Public class | ConferenceApiHandlerEnableTestTonesRequest | Parameters to EnableTestTones
Public class | ConferenceApiHandlerEnableTestTonesResponse | Response from EnableTestTones
Private class | ConferenceApiHandlerEventResponse | Events response
Public class | ConferenceApiHandlerGetAuxiliaryGainLevelRequest | Request for getting the auxiliary gain levels
Public class | ConferenceApiHandlerGetAuxiliaryGainLevelResponse | Response from getting auxiliary gain level
Public class | ConferenceApiHandlerGetAuxiliaryMutedStateRequest | Parameters to GetAuxiliaryMutedState
Public class | ConferenceApiHandlerGetAuxiliaryMutedStateResponse | Response from GetAuxiliaryMutedState
Public class | ConferenceApiHandlerGetAuxiliaryStateRequest | Parameters to GetAuxiliaryState
Public class | ConferenceApiHandlerGetAuxiliaryStateResponse | Response from GetAuxiliaryState
Public class | ConferenceApiHandlerGetCarriersStateRequest | Parameters to GetCarriersState
Public class | ConferenceApiHandlerGetCarriersStateResponse | Response from GetCarriersState
Public class | ConferenceApiHandlerGetControlModeConfigurationRequest | Parameters to GetControlModeConfiguration
Public class | ConferenceApiHandlerGetControlModeConfigurationResponse | Response from GetControlModeConfiguration
Public class | ConferenceApiHandlerGetDateTimeRequest | Parameters to GetDateTime
Public class | ConferenceApiHandlerGetDateTimeResponse | Response from GetDateTime
Public class | ConferenceApiHandlerGetDicentisConnectionStateRequest | Parameters to GetDicentisConnectionState
Public class | ConferenceApiHandlerGetDicentisConnectionStateResponse | Response from GetDicentisConnectionState
Public class | ConferenceApiHandlerGetEnableTestTonesRequest | Parameters to GetEnableTestTones
Public class | ConferenceApiHandlerGetEnableTestTonesResponse | Response from GetEnableTestTones
Public class | ConferenceApiHandlerGetInputContactStateRequest | Parameters to GetInputContactState
Public class | ConferenceApiHandlerGetInputContactStateResponse | Response from GetInputContactState
Public class | ConferenceApiHandlerGetLanguageDistributionInfoRequest | Parameters to GetLanguageDistributionInfo
Public class | ConferenceApiHandlerGetLanguageDistributionInfoResponse | Response from GetLanguageDistributionInfo
Public class | ConferenceApiHandlerGetLanguageGainLevelsRequest | Request for getting channel gain levels
Public class | ConferenceApiHandlerGetLanguageGainLevelsResponse | Response from getting channel gain levels
Public class | ConferenceApiHandlerGetLanguageMutedStatesRequest | Parameters to GetLanguageMuteStates
Public class | ConferenceApiHandlerGetLanguageMutedStatesResponse | Response from GetLanguageMuteStates
Public class | ConferenceApiHandlerGetLanguagesConfigurationRequest | Parameters to GetLanguagesConfiguration
Public class | ConferenceApiHandlerGetLanguagesConfigurationResponse | Response from GetLanguagesConfiguration
Public class | ConferenceApiHandlerGetLatestLogsRequest | Parameters to GetLatestLogs
Public class | ConferenceApiHandlerGetLatestLogsResponse | Response from GetLatestLogs
Public class | ConferenceApiHandlerGetLicensesRequest | Request for getting licenses
Public class | ConferenceApiHandlerGetLicensesResponse | Response for getting licenses
Public class | ConferenceApiHandlerGetLoginStatusRequest | Parameters to GetLoginStatus
Public class | ConferenceApiHandlerGetLogLevelRequest | Parameters to GetLogLevel
Public class | ConferenceApiHandlerGetLogLevelResponse | Response from SetLogLevel
Public class | ConferenceApiHandlerGetLogsRequest | Parameters to GetLogs
Public class | ConferenceApiHandlerGetLogsResponse | Response from SetLogs
Public class | ConferenceApiHandlerGetLogsTailRequest | Parameters to GetLogsTail
Public class | ConferenceApiHandlerGetLogsTailResponse | Response from SetLogsTail
Public class | ConferenceApiHandlerGetNetworkInfoRequest | Parameters to GetNetworkInfo
Public class | ConferenceApiHandlerGetNetworkInfoResponse | Response from GetNetworkInfo
Public class | ConferenceApiHandlerGetNumberOfLanguagesLimitRequest | Parameters to getNumberOfLanguagesLimit
Public class | ConferenceApiHandlerGetNumberOfLanguagesLimitResponse | Response from getNumberOfLanguagesLimit
Public class | ConferenceApiHandlerGetOperationModeRequest | Parameters to GetOperationMode
Public class | ConferenceApiHandlerGetOperationModeResponse | Response from GetOperationMode
Public class | ConferenceApiHandlerGetPermissionsRequest | Parameters to GetPermissions
Public class | ConferenceApiHandlerGetPermissionsResponse | Response from GetPermissions
Public class | ConferenceApiHandlerGetQualityConfigurationRequest | Parameters to GetQualityConfiguration
Public class | ConferenceApiHandlerGetQualityConfigurationResponse | Response from GetQualityConfiguration
Public class | ConferenceApiHandlerGetRadiatorsStateRequest | Parameters to GetRadiatorsState
Public class | ConferenceApiHandlerGetRadiatorsStateResponse | Response from GetRadiatorsState
Public class | ConferenceApiHandlerGetRegisterFirstUseStateRequest | Parameters to GetRegisterFirstUseState
Public class | ConferenceApiHandlerGetRegisterFirstUseStateResponse | Response from GetRegisterFirstUseState
Public class | ConferenceApiHandlerGetStandbyStateRequest | Parameters to GetStandbyState
Public class | ConferenceApiHandlerGetStandbyStateResponse | Response from GetStandbyState
Public class | ConferenceApiHandlerGetSystemModeRequest | Parameters to GetSystemMode
Public class | ConferenceApiHandlerGetSystemModeResponse | Response from GetSystemMode
Public class | ConferenceApiHandlerGetUsersRequest | Request for getting Users
Public class | ConferenceApiHandlerGetUsersResponse | Response from getting Users
Public class | ConferenceApiHandlerGetVersionInfoRequest | Parameters to GetVersionInfo
Public class | ConferenceApiHandlerGetVersionInfoResponse | Response from GetVersionInfo
Public class | ConferenceApiHandlerLoginRequest | Parameters to Login
Public class | ConferenceApiHandlerLoginResponse | Response from Login
Public class | ConferenceApiHandlerLogoutRequest | Logout request
Public class | ConferenceApiHandlerLogoutResponse | Logout response
Public class | ConferenceApiHandlerProcessLicensePackageRequest | Request for processing the license package
Public class | ConferenceApiHandlerProcessLicensePackageResponse | Response for processing response license package
Public class | ConferenceApiHandlerRebootRequest | Parameters to Reboot
Public class | ConferenceApiHandlerRebootResponse | Response from Reboot
Public class | ConferenceApiHandlerRegisterAudioLevelsRequest | Parameters to RegisterAudioLevels
Public class | ConferenceApiHandlerRegisterAudioLevelsResponse | Response from RegisterAudioLevels
Public class | ConferenceApiHandlerRegisterEventsRequest | Parameters to RegisterEvents
Public class | ConferenceApiHandlerRegisterEventsResponse | Response from RegisterEvents
Public class | ConferenceApiHandlerRegisterFirstUseRequest | Parameters to RegisterFirstUse
Public class | ConferenceApiHandlerRegisterFirstUseResponse | Response from RegisterFirstUse
Public class | ConferenceApiHandlerRemoveUserRequest | Parameters to RemoveUser
Public class | ConferenceApiHandlerRemoveUserResponse | Response from RemoveUser
Public class | ConferenceApiHandlerResetToFactoryDefaultRequest | Parameters to ResetToFactoryDefault
Public class | ConferenceApiHandlerResetToFactoryDefaultResponse | Response from ResetToFactoryDefault
Public class | ConferenceApiHandlerRestoreConfigurationRequest | Restore configuration data that was retrieved by 'backupConfiguration'
Public class | ConferenceApiHandlerRestoreConfigurationResponse | Response from RestoreConfiguration
Public class | ConferenceApiHandlerSetAuxiliaryGainLevelRequest | Parameters to SetAuxiliaryGainLevel
Public class | ConferenceApiHandlerSetAuxiliaryGainLevelResponse | Response from SetAuxiliaryGainLevel
Public class | ConferenceApiHandlerSetAuxiliaryMutedStateRequest | Parameters to SetAuxiliaryMutedState
Public class | ConferenceApiHandlerSetAuxiliaryMutedStateResponse | Response from SetAuxiliaryMutedState
Public class | ConferenceApiHandlerSetCarriersStateRequest | Parameters to SetCarriersState
Public class | ConferenceApiHandlerSetCarriersStateResponse | Response from SetCarriersState
Public class | ConferenceApiHandlerSetControlModeRequest | Parameters to SetControlMode
Public class | ConferenceApiHandlerSetControlModeResponse | Response from SetControlMode
Public class | ConferenceApiHandlerSetDateTimeRequest | Parameters to SetDateTime
Public class | ConferenceApiHandlerSetDateTimeResponse | Response from SetDateTime
Public class | ConferenceApiHandlerSetHostnameRequest | Parameters to SetHostname
Public class | ConferenceApiHandlerSetHostnameResponse | Response from SetHostname
Public class | ConferenceApiHandlerSetLanguageAudioModesRequest | Parameters to SetLanguageAudioModes
Public class | ConferenceApiHandlerSetLanguageAudioModesResponse | Response from SetLanguageAudioModes
Public class | ConferenceApiHandlerSetLanguageGainLevelsRequest | Parameters to SetChannelGainLevels
Public class | ConferenceApiHandlerSetLanguageGainLevelsResponse | Response from SetChannelGainLevels
Public class | ConferenceApiHandlerSetLanguageInputsRequest | Parameters to SetLanguageInputs
Public class | ConferenceApiHandlerSetLanguageInputsResponse | Response from SetLanguageInputs
Public class | ConferenceApiHandlerSetLanguageLabelsRequest | Parameters to SetLanguageLabels
Public class | ConferenceApiHandlerSetLanguageLabelsResponse | Response from SetLanguageLabels
Public class | ConferenceApiHandlerSetLanguageMutedStatesRequest | Parameters to SetLanguagesMutedState
Public class | ConferenceApiHandlerSetLanguageMutedStatesResponse | Response from SetLanguagesMutedState
Public class | ConferenceApiHandlerSetLanguageSourceTypesRequest | Parameters to SetLanguageSourceTypes
Public class | ConferenceApiHandlerSetLanguageSourceTypesResponse | Response from SetLanguageSourceTypes
Public class | ConferenceApiHandlerSetLogLevelRequest | Parameters to SetLogLevel
Public class | ConferenceApiHandlerSetLogLevelResponse | Response from SetLogLevel
Public class | ConferenceApiHandlerSetManualNetworkIpSettingsRequest | Parameters to SetNetworkIpProperties
Public class | ConferenceApiHandlerSetManualNetworkIpSettingsResponse | Response from SetNetworkIpProperties
Public class | ConferenceApiHandlerSetNetworkIpAssignmentModeRequest | Parameters to SetNetworkIpAssignmentMode
Public class | ConferenceApiHandlerSetNetworkIpAssignmentModeResponse | Response from SetNetworkIpAssignmentMode
Public class | ConferenceApiHandlerSetNumberOfLanguagesLimitRequest | Parameters to SetNumberOfLanguagesLimit
Public class | ConferenceApiHandlerSetNumberOfLanguagesLimitResponse | Response from SetNumberOfLanguagesLimit
Public class | ConferenceApiHandlerSetQualityConfigurationRequest | Parameters to SetQualityConfiguration
Public class | ConferenceApiHandlerSetQualityConfigurationResponse | Response from GetQualityConfiguration
Public class | ConferenceApiHandlerSetStandbyStateRequest | Parameters to SetStandbyState
Public class | ConferenceApiHandlerSetStandbyStateResponse | Response from SetStandbyState
Public class | ConferenceApiHandlerUnregisterAudioLevelsRequest | Parameters to UnregisterAudioLevels
Public class | ConferenceApiHandlerUnregisterAudioLevelsResponse | Response from UnregisterAudioLevels
Public class | ConferenceApiHandlerUnregisterEventsRequest | Parameters to UnRegisterEvents
Public class | ConferenceApiHandlerUnregisterEventsResponse | Response from UnRegisterEvents
Public class | ConferenceApiHandlerUpdateUserRequest | Parameters to updateUser. Obtains fields directly from UserInfoPut.
Public class | ConferenceApiHandlerUpdateUserResponse | Response from updateUser
Public class | CustomerRegistrationInfo | Descibes the information of the customer requesting a license
Public class | InstalledLicense | Describes the license
Public class | LanguageAudioLevel | Contains the audio levels of the channels allocated to the language
Public class | LanguageAudioMode | Defines the enabled state and audio mode of a language
Public class | LanguageDistributionInfo | Describes the language distribution info
Public class | LanguageGainLevel | Describes the settings of the channel gain level
Public class | LanguageLabelInfo | Defines the label of a channel
Public class | LanguageMutedStateInfo | Defines muted state of a language
Public class | LanguagesConfigurationInfo | Describes the configuration of a language, including allocated channels and carrier.
Public class | LanguageSource | Defines the audio source input of a language
Public class | LanguageSourceTypeInfo | Defines the label of a channel
Public class | LicenseInfo | Describes the license information
Public class | MessageAudioLevelsList | Defines a message containing all audio levels from the INT-TXO
Public class | NetworkInfo | Describes the information of the network
Public class | RadiatorInfo | Describes the status of a radiator
Public class | TcpIpProperties | Defines the IP-settings of a network
Public class | UserInfoGet | Describes the user information that can be received from the TXO
Public class | UserInfoPut | Describes the user information that can be sent to the TXO
Public class | VersionInfo | Describes the software versions


LanguageSource Constructor

Initializes a new instance of the LanguageSource class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ProcessLicensePackageResponse.Package Property

Package Property

The Base64 encoded binary string containing the possible return file information.
Syntax
Json
{ Property:Package }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkIpSetting Properties

The JsonNetworkIpSetting type exposes the following members.

Properties
 | Name | Description
Public property | IpAssignmentMode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonVersionInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonVersionInfo
Syntax
Json
{ JsonClass:JsonVersionInfo	 }

The JsonVersionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonVersionInfo | Initializes a new instance of the JsonVersionInfo class
Top
Fields
 | Name | Description
Public field | VersionInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLoginStatusRequest Constructor

ConferenceApiHandlerGetLoginStatusRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetLoginStatusRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryAudioLevel Constructor

Initializes a new instance of the JsonAuxiliaryAudioLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLogLevel.LogLevel Property

LogLevel Property

Syntax
Json
{ Property:LogLevel }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetStandbyStateRequest Constructor

ConferenceApiHandlerGetStandbyStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetStandbyStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoPut Properties

The UserInfoPut type exposes the following members.

Properties
 | Name | Description
Public property | FirstName | The first name of the user (Inherited from UserInfoGet.)
Public property | LastName | The last name of the user (Inherited from UserInfoGet.)
Public property | Password | The password of the user
Public property | Role | The role of the user, which determines their permissions (Inherited from UserInfoGet.)
Public property | User | The ID of the user (i.e. their user name) (Inherited from UserInfoGet.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicenseInfo.ActivationInfo Property

ActivationInfo Property

Syntax
Json
{ Property:ActivationInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonDicentisConnectionState Constructor

Initializes a new instance of the JsonDicentisConnectionState class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelConfigurationInfoList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonChannelConfigurationInfoList
Syntax
Json
{ JsonClass:JsonChannelConfigurationInfoList		LanguagesConfiguration:<type>,
 }

The JsonChannelConfigurationInfoList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonChannelConfigurationInfoList | Initializes a new instance of the JsonChannelConfigurationInfoList class
Top
Properties
 | Name | Description
Public property | LanguagesConfiguration |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer Constructor

Initializes the static fields of the Synchronizer class
Syntax
Json
{ Constructor:.cctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLogLevelResponse Constructor

ConferenceApiHandlerSetLogLevelResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetLogLevelResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageLabelsRequest Class

ConferenceApiHandlerSetLanguageLabelsRequest Class

Parameters to SetLanguageLabels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageLabelsRequest
Syntax
Json
{ JsonClass:SetLanguageLabelsRequest		LanguageLabels:<type>,
 }

The ConferenceApiHandlerSetLanguageLabelsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageLabelsRequest | Initializes a new instance of the ConferenceApiHandlerSetLanguageLabelsRequest class
Top
Properties
 | Name | Description
Public property | LanguageLabels | The list of language labels.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicenseInfo.CustomerInfo Property

CustomerInfo Property

Syntax
Json
{ Property:CustomerInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterFirstUseResponse Constructor

ConferenceApiHandlerRegisterFirstUseResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterFirstUseResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ChangeOwnPasswordResponse Constructor

ConferenceApiHandlerChangeOwnPasswordResponse Constructor

Initializes a new instance of the ConferenceApiHandlerChangeOwnPasswordResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonDicentisConnectionState Properties

The JsonDicentisConnectionState type exposes the following members.

Properties
 | Name | Description
Public property | Connected |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageMutedStateInfo Properties

The LanguageMutedStateInfo type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | Muted | The muted state for the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonVersionInfo.VersionInfo Field

VersionInfo Field

Syntax
Json
{ Field:VersionInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CarrierInfo Constructor

Initializes a new instance of the CarrierInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RebootRequest Constructor

ConferenceApiHandlerRebootRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRebootRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


OperationMode Enumeration

Defines the master or slave operation mode
Syntax
Json
OperationMode:{
Master
Slave}
Members
Member name | Value | Description
Master | 0 | Master mode
Slave | 1 | Slave mode
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ChangeOwnPasswordRequest Constructor

ConferenceApiHandlerChangeOwnPasswordRequest Constructor

Initializes a new instance of the ConferenceApiHandlerChangeOwnPasswordRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MessageAudioLevelsList Properties

The MessageAudioLevelsList type exposes the following members.

Properties
 | Name | Description
Public property | Auxiliary | The audio level of the auxiliary input
Public property | Languages | For all languages, the audio levels per channel
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegistrationEvents Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonRegistrationEvents
Syntax
Json
{ JsonClass:JsonRegistrationEvents		Events:<type>,
 }

The JsonRegistrationEvents type exposes the following members.

Constructors
 | Name | Description
Public method | JsonRegistrationEvents | Initializes a new instance of the JsonRegistrationEvents class
Top
Properties
 | Name | Description
Public property | Events |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo.Label Property

Label Property

The label of the language
Syntax
Json
{ Property:Label }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo Constructor

Initializes a new instance of the LanguagesConfigurationInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ControlMode Enumeration

Defines the operational control mode
Syntax
Json
ControlMode:{
Dicentis
Standalone}
Members
Member name | Value | Description
Dicentis | 0 | Connected to Dicentis system
Standalone | 1 | Operating in standalone mode
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageAudioLevelsList.Auxiliary Property

Auxiliary Property

Syntax
Json
{ Property:Auxiliary }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfo Properties

The JsonCarrierInfo type exposes the following members.

Properties
 | Name | Description
Public property | CarrierId |
Public property | Enabled |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject.ValidateStateNotDisposed Method

ValidateStateNotDisposed Method

Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRemoveUser Properties

The JsonRemoveUser type exposes the following members.

Properties
 | Name | Description
Public property | User |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryGainLevel.Level Property

Level Property

Syntax
Json
{ Property:Level }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageLabelInfo.LanguageId Property

LanguageId Property

The ID of the language
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevel Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageGainLevel
Syntax
Json
{ JsonClass:JsonLanguageGainLevel		LanguageId:<type>,
    Level:<type>,
 }

The JsonLanguageGainLevel type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageGainLevel | Initializes a new instance of the JsonLanguageGainLevel class
Top
Properties
 | Name | Description
Public property | LanguageId |
Public property | Level |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTcpIpSettings Constructor

Initializes a new instance of the JsonTcpIpSettings class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryGainLevel Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonAuxiliaryGainLevel
Syntax
Json
{ JsonClass:JsonAuxiliaryGainLevel		Level:<type>,
 }

The JsonAuxiliaryGainLevel type exposes the following members.

Constructors
 | Name | Description
Public method | JsonAuxiliaryGainLevel | Initializes a new instance of the JsonAuxiliaryGainLevel class
Top
Properties
 | Name | Description
Public property | Level |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetUsersResponse Properties

The ConferenceApiHandlerGetUsersResponse type exposes the following members.

Properties
 | Name | Description
Public property | Users | The information for all users registered on the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetCarriersStateResponse.CarriersInfo Property

CarriersInfo Property

The information for all carriers
Syntax
Json
{ Property:CarriersInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CustomerRegistrationInfo Constructor

Initializes a new instance of the CustomerRegistrationInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegisterFirstUseState Properties

The JsonRegisterFirstUseState type exposes the following members.

Properties
 | Name | Description
Public property | FirstUseState |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.SerialNumber Property

SerialNumber Property

The serial number of the INT-TXO
Syntax
Json
{ Property:SerialNumber }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageSourceTypesRequest.LanguageSourceTypes Property

LanguageSourceTypes Property

The list of language source types
Syntax
Json
{ Property:LanguageSourceTypes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetPermissionsResponse Properties

The ConferenceApiHandlerGetPermissionsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Permissions | Permissions list
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLatestLogsRequest Constructor

ConferenceApiHandlerGetLatestLogsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetLatestLogsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkIpSettings Constructor

Initializes a new instance of the JsonNetworkIpSettings class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoPut Constructor

Copy constructor
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetCarriersStateRequest Class

ConferenceApiHandlerSetCarriersStateRequest Class

Parameters to SetCarriersState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetCarriersStateRequest
Syntax
Json
{ JsonClass:SetCarriersStateRequest		CarriersInfo:<type>,
 }

The ConferenceApiHandlerSetCarriersStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetCarriersStateRequest | Initializes a new instance of the ConferenceApiHandlerSetCarriersStateRequest class
Top
Properties
 | Name | Description
Public property | CarriersInfo | The carriers to set
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageGainLevelsRequest Constructor

ConferenceApiHandlerGetLanguageGainLevelsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetLanguageGainLevelsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetManualNetworkIpSettingsResponse Class

ConferenceApiHandlerSetManualNetworkIpSettingsResponse Class

Response from SetNetworkIpProperties
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetManualNetworkIpSettingsResponse
Syntax
Json
{ JsonClass:SetManualNetworkIpSettingsResponse	 }

The ConferenceApiHandlerSetManualNetworkIpSettingsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetManualNetworkIpSettingsResponse | Initializes a new instance of the ConferenceApiHandlerSetManualNetworkIpSettingsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AudioChannelLevel Constructor

Initializes a new instance of the AudioChannelLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogLevelResponse Class

ConferenceApiHandlerGetLogLevelResponse Class

Response from SetLogLevel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLogLevelResponse
Syntax
Json
{ JsonClass:GetLogLevelResponse		LogLevel:<type>,
 }

The ConferenceApiHandlerGetLogLevelResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLogLevelResponse | Initializes a new instance of the ConferenceApiHandlerGetLogLevelResponse class
Top
Properties
 | Name | Description
Public property | LogLevel | The loglevel to be set
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegisterFirstUse.Password Property

Password Property

Syntax
Json
{ Property:Password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogLevelResponse.LogLevel Property

LogLevel Property

The loglevel to be set
Syntax
Json
{ Property:LogLevel }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableTestTonesResponse Constructor

ConferenceApiHandlerEnableTestTonesResponse Constructor

Initializes a new instance of the ConferenceApiHandlerEnableTestTonesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyState Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonStandbyState
Syntax
Json
{ JsonClass:JsonStandbyState		Standby:<type>,
 }

The JsonStandbyState type exposes the following members.

Constructors
 | Name | Description
Public method | JsonStandbyState | Initializes a new instance of the JsonStandbyState class
Top
Properties
 | Name | Description
Public property | Standby |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItem Properties

The WorkItem type exposes the following members.

Properties
 | Name | Description
Public property | AsyncWaitHandle |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonCarrierInfo
Syntax
Json
{ JsonClass:JsonCarrierInfo		CarrierId:<type>,
    Enabled:<type>,
 }

The JsonCarrierInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonCarrierInfo | Initializes a new instance of the JsonCarrierInfo class
Top
Properties
 | Name | Description
Public property | CarrierId |
Public property | Enabled |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypeInfo Properties

The JsonLanguageSourceTypeInfo type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId |
Public property | SourceType |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTcpIpSettings.Gateway Property

Gateway Property

Syntax
Json
{ Property:Gateway }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginResponse Constructor

ConferenceApiHandlerLoginResponse Constructor

Initializes a new instance of the ConferenceApiHandlerLoginResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSource Properties

The LanguageSource type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | SourceInput | The input source allocated to the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageLabelsResponse Constructor

ConferenceApiHandlerSetLanguageLabelsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetLanguageLabelsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguagesConfigurationRequest Constructor

ConferenceApiHandlerGetLanguagesConfigurationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetLanguagesConfigurationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ProcessLicensePackageRequest Constructor

ConferenceApiHandlerProcessLicensePackageRequest Constructor

Initializes a new instance of the ConferenceApiHandlerProcessLicensePackageRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguagesConfigurationRequest Class

ConferenceApiHandlerGetLanguagesConfigurationRequest Class

Parameters to GetLanguagesConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLanguagesConfigurationRequest
Syntax
Json
{ JsonClass:GetLanguagesConfigurationRequest	 }

The ConferenceApiHandlerGetLanguagesConfigurationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLanguagesConfigurationRequest | Initializes a new instance of the ConferenceApiHandlerGetLanguagesConfigurationRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkIpSettings Properties

The JsonNetworkIpSettings type exposes the following members.

Properties
 | Name | Description
Public property | Settings |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTcpIpSettings.MainIpAddr Property

MainIpAddr Property

Syntax
Json
{ Property:MainIpAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioLevel Properties

The JsonLanguageAudioLevel type exposes the following members.

Properties
 | Name | Description
Public property | Channels |
Public property | LanguageId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.WorkItemQueue.Dequeue Method

Dequeue Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


JsonLogLevel Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLogLevel
Syntax
Json
{ JsonClass:JsonLogLevel		LogLevel:<type>,
 }

The JsonLogLevel type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLogLevel | Initializes a new instance of the JsonLogLevel class
Top
Properties
 | Name | Description
Public property | LogLevel |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioLevel Constructor

Initializes a new instance of the JsonLanguageAudioLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegistrationEvents Properties

The JsonRegistrationEvents type exposes the following members.

Properties
 | Name | Description
Public property | Events |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.WorkItemQueue.HasItems Property

HasItems Property

Syntax
Json
{ Property:HasItems }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetDateTimeRequest Properties

The ConferenceApiHandlerSetDateTimeRequest type exposes the following members.

Properties
 | Name | Description
Public property | DateTime | Indicates what local date and time to set in iso-8601 format
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetNumberOfLanguagesLimitRequest Properties

The ConferenceApiHandlerSetNumberOfLanguagesLimitRequest type exposes the following members.

Properties
 | Name | Description
Public property | Limit | Indicates maximum number of languages to transmit
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.IpAssignmentMode Property

IpAssignmentMode Property

The network address assignent setting of a network
Syntax
Json
{ Property:IpAssignmentMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RadiatorInfo.HasError Property

HasError Property

Indicates whether the radiator is in error state
Syntax
Json
{ Property:HasError }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.IpAssignmentMode Property

IpAssignmentMode Property

Syntax
Json
{ Property:IpAssignmentMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet.FirstName Property

FirstName Property

The first name of the user
Syntax
Json
{ Property:FirstName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryState.Active Property

Active Property

Syntax
Json
{ Property:Active }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLicensesResponse.LicenseInfo Property

LicenseInfo Property

The license information available at the transmitter
Syntax
Json
{ Property:LicenseInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetCarriersStateRequest Properties

The ConferenceApiHandlerSetCarriersStateRequest type exposes the following members.

Properties
 | Name | Description
Public property | CarriersInfo | The carriers to set
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSoftwareInfo Constructor

Initializes a new instance of the JsonSoftwareInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemModeResponse Constructor

ConferenceApiHandlerGetSystemModeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetSystemModeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


EventResponse Properties

The ConferenceApiHandlerEventResponse type exposes the following members.

Properties
 | Name | Description
Public property | Events | List of events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.WorkItemQueue Constructor

WorkerThreadWorkItemQueue Constructor

Initializes a new instance of the WorkerThreadWorkItemQueue class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInputContactState Constructor

Initializes a new instance of the JsonInputContactState class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInputContactStateRequest Class

ConferenceApiHandlerGetInputContactStateRequest Class

Parameters to GetInputContactState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetInputContactStateRequest
Syntax
Json
{ JsonClass:GetInputContactStateRequest	 }

The ConferenceApiHandlerGetInputContactStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInputContactStateRequest | Initializes a new instance of the ConferenceApiHandlerGetInputContactStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonEmpty Constructor

Initializes a new instance of the JsonEmpty class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLogs Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLogs
Syntax
Json
{ JsonClass:JsonLogs		Logs:<type>,
 }

The JsonLogs type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLogs | Initializes a new instance of the JsonLogs class
Top
Properties
 | Name | Description
Public property | Logs |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryMutedStateResponse.Muted Property

Muted Property

Indicates whether the analog auxiliary input is muted or not
Syntax
Json
{ Property:Muted }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageEvents Constructor

Initializes a new instance of the JsonMessageEvents class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetControlModeRequest Class

ConferenceApiHandlerSetControlModeRequest Class

Parameters to SetControlMode
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetControlModeRequest
Syntax
Json
{ JsonClass:SetControlModeRequest		Mode:<type>,
 }

The ConferenceApiHandlerSetControlModeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetControlModeRequest | Initializes a new instance of the ConferenceApiHandlerSetControlModeRequest class
Top
Properties
 | Name | Description
Public property | Mode | The operational control mode.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypeInfo.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryGainLevelRequest.Level Property

Level Property

The gain level of the auxiliary input
Syntax
Json
{ Property:Level }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject.Dispose Method (Boolean)

Dispose Method (Boolean)

 Bosch Logo
Releases the unmanaged resources used by the DisposableObject and optionally releases the managed resources
Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableTestTonesRequest.Enable Property

Enable Property

Indicates whether the test tones to all channels are enabled
Syntax
Json
{ Property:Enable }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageGainLevelsRequest Class

ConferenceApiHandlerSetLanguageGainLevelsRequest Class

Parameters to SetChannelGainLevels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageGainLevelsRequest
Syntax
Json
{ JsonClass:SetLanguageGainLevelsRequest		LanguageGainLevels:<type>,
 }

The ConferenceApiHandlerSetLanguageGainLevelsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageGainLevelsRequest | Initializes a new instance of the ConferenceApiHandlerSetLanguageGainLevelsRequest class
Top
Properties
 | Name | Description
Public property | LanguageGainLevels | The list of channels and the channel gain levels needs to be set to
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler Constructor

Initializes a new instance of the ConferenceApiHandler class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNumberOfLanguagesLimitResponse Constructor

ConferenceApiHandlerSetNumberOfLanguagesLimitResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetNumberOfLanguagesLimitResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageSourceTypesRequest Class

ConferenceApiHandlerSetLanguageSourceTypesRequest Class

Parameters to SetLanguageSourceTypes
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageSourceTypesRequest
Syntax
Json
{ JsonClass:SetLanguageSourceTypesRequest		LanguageSourceTypes:<type>,
 }

The ConferenceApiHandlerSetLanguageSourceTypesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageSourceTypesRequest | Initializes a new instance of the ConferenceApiHandlerSetLanguageSourceTypesRequest class
Top
Properties
 | Name | Description
Public property | LanguageSourceTypes | The list of language source types
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevel.Level Property

Level Property

Syntax
Json
{ Property:Level }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonRadiatorInfo
Syntax
Json
{ JsonClass:JsonRadiatorInfo		HasError:<type>,
    IsPresent:<type>,
    RadiatorId:<type>,
 }

The JsonRadiatorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonRadiatorInfo | Initializes a new instance of the JsonRadiatorInfo class
Top
Properties
 | Name | Description
Public property | HasError |
Public property | IsPresent |
Public property | RadiatorId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyScheduleInfo Properties

The JsonStandbyScheduleInfo type exposes the following members.

Properties
 | Name | Description
Public property | DateTime |
Public property | Enabled |
Public property | TimeZone |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsRequest.Events Property

Events Property

List of unregistered events
Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableTestTonesResponse Class

ConferenceApiHandlerGetEnableTestTonesResponse Class

Response from GetEnableTestTones
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetEnableTestTonesResponse
Syntax
Json
{ JsonClass:GetEnableTestTonesResponse		Enable:<type>,
 }

The ConferenceApiHandlerGetEnableTestTonesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetEnableTestTonesResponse | Initializes a new instance of the ConferenceApiHandlerGetEnableTestTonesResponse class
Top
Properties
 | Name | Description
Public property | Enable | Indicates whether all testtones to all channels is enabled
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLatestLogsRequest Class

ConferenceApiHandlerGetLatestLogsRequest Class

Parameters to GetLatestLogs
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLatestLogsRequest
Syntax
Json
{ JsonClass:GetLatestLogsRequest	 }

The ConferenceApiHandlerGetLatestLogsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLatestLogsRequest | Initializes a new instance of the ConferenceApiHandlerGetLatestLogsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonNetworkInfo
Syntax
Json
{ JsonClass:JsonNetworkInfo		NetworkInfo:<type>,
 }

The JsonNetworkInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonNetworkInfo | Initializes a new instance of the JsonNetworkInfo class
Top
Properties
 | Name | Description
Public property | NetworkInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfoList Constructor

Initializes a new instance of the JsonLanguageLabelInfoList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.Dispose Method

Dispose Method

Releases all resources used by the WorkerThread
Syntax
Json
Request
Response

Implements

IDisposableDispose
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo.Label Property

Label Property

Syntax
Json
{ Property:Label }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypeInfo.SourceType Property

SourceType Property

Syntax
Json
{ Property:SourceType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageDistributionInfoRequest Class

ConferenceApiHandlerGetLanguageDistributionInfoRequest Class

Parameters to GetLanguageDistributionInfo
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLanguageDistributionInfoRequest
Syntax
Json
{ JsonClass:GetLanguageDistributionInfoRequest	 }

The ConferenceApiHandlerGetLanguageDistributionInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLanguageDistributionInfoRequest | Initializes a new instance of the ConferenceApiHandlerGetLanguageDistributionInfoRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLicensesResponse Class

ConferenceApiHandlerGetLicensesResponse Class

Response for getting licenses
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLicensesResponse
Syntax
Json
{ JsonClass:GetLicensesResponse		LicenseInfo:<type>,
 }

The ConferenceApiHandlerGetLicensesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLicensesResponse | Initializes a new instance of the ConferenceApiHandlerGetLicensesResponse class
Top
Properties
 | Name | Description
Public property | LicenseInfo | The license information available at the transmitter
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo Constructor

Initializes a new instance of the JsonLanguagesConfigurationInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageDistributionInfoResponse.LanguageDistributionInfo Property

LanguageDistributionInfo Property

The language distribution info
Syntax
Json
{ Property:LanguageDistributionInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetOperationModeResponse Class

ConferenceApiHandlerGetOperationModeResponse Class

Response from GetOperationMode
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetOperationModeResponse
Syntax
Json
{ JsonClass:GetOperationModeResponse		Mode:<type>,
 }

The ConferenceApiHandlerGetOperationModeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetOperationModeResponse | Initializes a new instance of the ConferenceApiHandlerGetOperationModeResponse class
Top
Properties
 | Name | Description
Public property | Mode | The operation mode.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CustomerRegistrationInfo.City Property

City Property

The city of the customer
Syntax
Json
{ Property:City }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetToFactoryDefaultResponse Constructor

ConferenceApiHandlerResetToFactoryDefaultResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerResetToFactoryDefaultResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryStateRequest Class

ConferenceApiHandlerGetAuxiliaryStateRequest Class

Parameters to GetAuxiliaryState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetAuxiliaryStateRequest
Syntax
Json
{ JsonClass:GetAuxiliaryStateRequest	 }

The ConferenceApiHandlerGetAuxiliaryStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetAuxiliaryStateRequest | Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbySchedule Constructor

Initializes a new instance of the JsonStandbySchedule class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAuxiliaryResponse Class

ConferenceApiHandlerActivateAuxiliaryResponse Class

Response from ActivateAuxiliary
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerActivateAuxiliaryResponse
Syntax
Json
{ JsonClass:ActivateAuxiliaryResponse	 }

The ConferenceApiHandlerActivateAuxiliaryResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateAuxiliaryResponse | Initializes a new instance of the ConferenceApiHandlerActivateAuxiliaryResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkIpSetting Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonNetworkIpSetting
Syntax
Json
{ JsonClass:JsonNetworkIpSetting		IpAssignmentMode:<type>,
 }

The JsonNetworkIpSetting type exposes the following members.

Constructors
 | Name | Description
Public method | JsonNetworkIpSetting | Initializes a new instance of the JsonNetworkIpSetting class
Top
Properties
 | Name | Description
Public property | IpAssignmentMode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.Run Method

Run Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


JsonInstalledLicenseInfo Constructor

Initializes a new instance of the JsonInstalledLicenseInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AudioChannelLevel.ChannelId Property

ChannelId Property

The audio channel for which the audio level is applicable.
Syntax
Json
{ Property:ChannelId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterAudioLevelsResponse Class

ConferenceApiHandlerUnregisterAudioLevelsResponse Class

Response from UnregisterAudioLevels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerUnregisterAudioLevelsResponse
Syntax
Json
{ JsonClass:UnregisterAudioLevelsResponse	 }

The ConferenceApiHandlerUnregisterAudioLevelsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnregisterAudioLevelsResponse | Initializes a new instance of the ConferenceApiHandlerUnregisterAudioLevelsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegisterFirstUse Constructor

Initializes a new instance of the JsonRegisterFirstUse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CarrierInfo.Enabled Property

Enabled Property

Indicates whether the carrier is enabled or disabled
Syntax
Json
{ Property:Enabled }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSystemMode Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonSystemMode
Syntax
Json
{ JsonClass:JsonSystemMode		Mode:<type>,
 }

The JsonSystemMode type exposes the following members.

Constructors
 | Name | Description
Public method | JsonSystemMode | Initializes a new instance of the JsonSystemMode class
Top
Properties
 | Name | Description
Public property | Mode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryState Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonAuxiliaryState
Syntax
Json
{ JsonClass:JsonAuxiliaryState		Active:<type>,
 }

The JsonAuxiliaryState type exposes the following members.

Constructors
 | Name | Description
Public method | JsonAuxiliaryState | Initializes a new instance of the JsonAuxiliaryState class
Top
Properties
 | Name | Description
Public property | Active |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypesInfoList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageSourceTypesInfoList
Syntax
Json
{ JsonClass:JsonLanguageSourceTypesInfoList		LanguageSourceTypes:<type>,
 }

The JsonLanguageSourceTypesInfoList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageSourceTypesInfoList | Initializes a new instance of the JsonLanguageSourceTypesInfoList class
Top
Properties
 | Name | Description
Public property | LanguageSourceTypes |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.BackupConfigurationResponse Class

ConferenceApiHandlerBackupConfigurationResponse Class

Response from backupConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerBackupConfigurationResponse
Syntax
Json
{ JsonClass:BackupConfigurationResponse		Package:<type>,
 }

The ConferenceApiHandlerBackupConfigurationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerBackupConfigurationResponse | Initializes a new instance of the ConferenceApiHandlerBackupConfigurationResponse class
Top
Properties
 | Name | Description
Public property | Package | A binary blob
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsResponse Constructor

ConferenceApiHandlerGetPermissionsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetPermissionsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRegisterFirstUseStateResponse Constructor

ConferenceApiHandlerGetRegisterFirstUseStateResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetRegisterFirstUseStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageMutedStateInfo.Muted Property

Muted Property

The muted state for the language
Syntax
Json
{ Property:Muted }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCount Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonCount
Syntax
Json
{ JsonClass:JsonCount		Count:<type>,
 }

The JsonCount type exposes the following members.

Constructors
 | Name | Description
Public method | JsonCount | Initializes a new instance of the JsonCount class
Top
Properties
 | Name | Description
Public property | Count |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ChannelInfo.CarrierId Property

CarrierId Property

The carrier the channel is allocated to.
Syntax
Json
{ Property:CarrierId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RestoreConfigurationResponse Constructor

ConferenceApiHandlerRestoreConfigurationResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRestoreConfigurationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioLevel.LanguageId Property

LanguageId Property

The language for which the audio levels are applicable.
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterAudioLevelsRequest Class

ConferenceApiHandlerUnregisterAudioLevelsRequest Class

Parameters to UnregisterAudioLevels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerUnregisterAudioLevelsRequest
Syntax
Json
{ JsonClass:UnregisterAudioLevelsRequest	 }

The ConferenceApiHandlerUnregisterAudioLevelsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnregisterAudioLevelsRequest | Initializes a new instance of the ConferenceApiHandlerUnregisterAudioLevelsRequest class
Top
Remarks
Requires:
  • canViewDashboard permission.
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonOperationMode.Mode Property

Mode Property

Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChangeOwnPassword Constructor

Initializes a new instance of the JsonChangeOwnPassword class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoPut.Password Property

Password Property

The password of the user
Syntax
Json
{ Property:Password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageInputsRequest Class

ConferenceApiHandlerSetLanguageInputsRequest Class

Parameters to SetLanguageInputs
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageInputsRequest
Syntax
Json
{ JsonClass:SetLanguageInputsRequest		LanguageInputs:<type>,
 }

The ConferenceApiHandlerSetLanguageInputsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageInputsRequest | Initializes a new instance of the ConferenceApiHandlerSetLanguageInputsRequest class
Top
Properties
 | Name | Description
Public property | LanguageInputs | The list of languages with their input configuration
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryActivation Properties

The JsonAuxiliaryActivation type exposes the following members.

Properties
 | Name | Description
Public property | Active |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCount Properties

The JsonCount type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetAuxiliaryStateResponse Properties

The ConferenceApiHandlerGetAuxiliaryStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | Active | Indicates whether the analog auxiliary input is active or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CarrierInfo Class

Describes the status of a carrier
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientCarrierInfo
Syntax
Json
{ JsonClass:CarrierInfo		CarrierId:<type>,
    Enabled:<type>,
 }

The CarrierInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CarrierInfo | Initializes a new instance of the CarrierInfo class
Top
Properties
 | Name | Description
Public property | CarrierId | The ID of the carrier
Public property | Enabled | Indicates whether the carrier is enabled or disabled
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MessageAudioLevelsList.Languages Property

Languages Property

For all languages, the audio levels per channel
Syntax
Json
{ Property:Languages }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetLanguagesConfigurationResponse Properties

The ConferenceApiHandlerGetLanguagesConfigurationResponse type exposes the following members.

Properties
 | Name | Description
Public property | LanguageConfigurations | The audio channel configuration set for each channel
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetControlModeRequest Properties

The ConferenceApiHandlerSetControlModeRequest type exposes the following members.

Properties
 | Name | Description
Public property | Mode | The operational control mode.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivationInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonActivationInfo
Syntax
Json
{ JsonClass:JsonActivationInfo		DeviceId:<type>,
    Licenses:<type>,
    Version:<type>,
 }

The JsonActivationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonActivationInfo | Initializes a new instance of the JsonActivationInfo class
Top
Properties
 | Name | Description
Public property | DeviceId |
Public property | Licenses |
Public property | Version |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RadiatorInfo.IsPresent Property

IsPresent Property

Indicates whether the radiator is connected to the transmitter
Syntax
Json
{ Property:IsPresent }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemModeResponse Class

ConferenceApiHandlerGetSystemModeResponse Class

Response from GetSystemMode
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetSystemModeResponse
Syntax
Json
{ JsonClass:GetSystemModeResponse		Mode:<type>,
 }

The ConferenceApiHandlerGetSystemModeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSystemModeResponse | Initializes a new instance of the ConferenceApiHandlerGetSystemModeResponse class
Top
Properties
 | Name | Description
Public property | Mode | The system mode.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicense Properties

The JsonInstalledLicense type exposes the following members.

Properties
 | Name | Description
Public property | ActivationDate |
Public property | ExpirationDate |
Public property | FeatureName |
Public property | Quantity |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkInfo Properties

The JsonNetworkInfo type exposes the following members.

Properties
 | Name | Description
Public property | NetworkInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo.Mode Property

Mode Property

Indicates the audio mode for the language
Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetQualityConfigurationRequest Class

ConferenceApiHandlerSetQualityConfigurationRequest Class

Parameters to SetQualityConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetQualityConfigurationRequest
Syntax
Json
{ JsonClass:SetQualityConfigurationRequest		Quality:<type>,
 }

The ConferenceApiHandlerSetQualityConfigurationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetQualityConfigurationRequest | Initializes a new instance of the ConferenceApiHandlerSetQualityConfigurationRequest class
Top
Properties
 | Name | Description
Public property | Quality | Indicates the overall channel quality configuration setting
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageUpdate.What Property

What Property

Syntax
Json
{ Property:What }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsResponse Class

ConferenceApiHandlerGetLogsResponse Class

Response from SetLogs
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLogsResponse
Syntax
Json
{ JsonClass:GetLogsResponse		Logs:<type>,
 }

The ConferenceApiHandlerGetLogsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLogsResponse | Initializes a new instance of the ConferenceApiHandlerGetLogsResponse class
Top
Properties
 | Name | Description
Public property | Logs | The returned list of logs
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetStandbyStateResponse Constructor

ConferenceApiHandlerSetStandbyStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetStandbyStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateUserRequest Constructor

ConferenceApiHandlerUpdateUserRequest Constructor

Construct an instance of UpdateUserRequest from an instance of UserInfoPut
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetCarriersStateResponse Constructor

ConferenceApiHandlerGetCarriersStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetCarriersStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioMode Properties

The LanguageAudioMode type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | Mode | Indicates the audio mode for the channel
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetDateTimeRequest.DateTime Property

DateTime Property

Indicates what local date and time to set in iso-8601 format
Syntax
Json
{ Property:DateTime }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ChangeOwnPasswordRequest Class

ConferenceApiHandlerChangeOwnPasswordRequest Class

Parameters to changeOwnPassword.
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerChangeOwnPasswordRequest
Syntax
Json
{ JsonClass:ChangeOwnPasswordRequest		CurrentPassword:<type>,
    NewPassword:<type>,
 }

The ConferenceApiHandlerChangeOwnPasswordRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerChangeOwnPasswordRequest | Initializes a new instance of the ConferenceApiHandlerChangeOwnPasswordRequest class
Top
Properties
 | Name | Description
Public property | CurrentPassword | The current password of the logged in user
Public property | NewPassword | The new password for the logged in user
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryMutedStateRequest Class

ConferenceApiHandlerGetAuxiliaryMutedStateRequest Class

Parameters to GetAuxiliaryMutedState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetAuxiliaryMutedStateRequest
Syntax
Json
{ JsonClass:GetAuxiliaryMutedStateRequest	 }

The ConferenceApiHandlerGetAuxiliaryMutedStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetAuxiliaryMutedStateRequest | Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryMutedStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetControlModeConfigurationRequest Class

ConferenceApiHandlerGetControlModeConfigurationRequest Class

Parameters to GetControlModeConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetControlModeConfigurationRequest
Syntax
Json
{ JsonClass:GetControlModeConfigurationRequest	 }

The ConferenceApiHandlerGetControlModeConfigurationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetControlModeConfigurationRequest | Initializes a new instance of the ConferenceApiHandlerGetControlModeConfigurationRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLicenseInfo Properties

The JsonLicenseInfo type exposes the following members.

Properties
 | Name | Description
Public property | LicenseInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItemQueue Methods

The WorkerThreadWorkItemQueue type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all objects from the QueueT. (Inherited from QueueWorkItem .)
Public method | Contains | Determines whether an element is in the QueueT. (Inherited from QueueWorkItem .)
Public method | CopyTo | Copies the QueueT elements to an existing one-dimensional Array, starting at the specified array index. (Inherited from QueueWorkItem .)
Public method | Dequeue |
Public method | Enqueue |
Public method | GetEnumerator | Returns an enumerator that iterates through the QueueT. (Inherited from QueueWorkItem .)
Public method | Peek | Returns the object at the beginning of the QueueT without removing it. (Inherited from QueueWorkItem .)
Public method | ToArray | Copies the QueueT elements to a new array. (Inherited from QueueWorkItem .)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the QueueT, if that number is less than 90 percent of current capacity. (Inherited from QueueWorkItem .)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsResponse Class

ConferenceApiHandlerUnregisterEventsResponse Class

Response from UnRegisterEvents
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerUnregisterEventsResponse
Syntax
Json
{ JsonClass:UnregisterEventsResponse	 }

The ConferenceApiHandlerUnregisterEventsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnregisterEventsResponse | Initializes a new instance of the ConferenceApiHandlerUnregisterEventsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsRequest Class

ConferenceApiHandlerGetPermissionsRequest Class

Parameters to GetPermissions
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetPermissionsRequest
Syntax
Json
{ JsonClass:GetPermissionsRequest	 }

The ConferenceApiHandlerGetPermissionsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetPermissionsRequest | Initializes a new instance of the ConferenceApiHandlerGetPermissionsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevelsList Constructor

Initializes a new instance of the JsonLanguageGainLevelsList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivationInfo Properties

The JsonActivationInfo type exposes the following members.

Properties
 | Name | Description
Public property | DeviceId |
Public property | Licenses |
Public property | Version |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetCarriersStateResponse Class

ConferenceApiHandlerGetCarriersStateResponse Class

Response from GetCarriersState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetCarriersStateResponse
Syntax
Json
{ JsonClass:GetCarriersStateResponse		CarriersInfo:<type>,
 }

The ConferenceApiHandlerGetCarriersStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetCarriersStateResponse | Initializes a new instance of the ConferenceApiHandlerGetCarriersStateResponse class
Top
Properties
 | Name | Description
Public property | CarriersInfo | The information for all carriers
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicenseInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonInstalledLicenseInfo
Syntax
Json
{ JsonClass:JsonInstalledLicenseInfo		ActivationInfo:<type>,
    CustomerInfo:<type>,
 }

The JsonInstalledLicenseInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonInstalledLicenseInfo | Initializes a new instance of the JsonInstalledLicenseInfo class
Top
Properties
 | Name | Description
Public property | ActivationInfo |
Public property | CustomerInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageMutedStatesResponse Constructor

ConferenceApiHandlerSetLanguageMutedStatesResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetLanguageMutedStatesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CarrierInfo Properties

The CarrierInfo type exposes the following members.

Properties
 | Name | Description
Public property | CarrierId | The ID of the carrier
Public property | Enabled | Indicates whether the carrier is enabled or disabled
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageSourceTypesRequest Constructor

ConferenceApiHandlerSetLanguageSourceTypesRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetLanguageSourceTypesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryState Properties

The JsonAuxiliaryState type exposes the following members.

Properties
 | Name | Description
Public property | Active |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSetHostname Constructor

Initializes a new instance of the JsonSetHostname class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetLanguageInputsRequest Properties

The ConferenceApiHandlerSetLanguageInputsRequest type exposes the following members.

Properties
 | Name | Description
Public property | LanguageInputs | The list of languages with their input configuration
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageDistributionInfo.NumberOfActiveLanguages Property

NumberOfActiveLanguages Property

The number of active channels that visible on the receivers
Syntax
Json
{ Property:NumberOfActiveLanguages }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDateTimeRequest Class

ConferenceApiHandlerGetDateTimeRequest Class

Parameters to GetDateTime
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetDateTimeRequest
Syntax
Json
{ JsonClass:GetDateTimeRequest	 }

The ConferenceApiHandlerGetDateTimeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetDateTimeRequest | Initializes a new instance of the ConferenceApiHandlerGetDateTimeRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAuxiliaryRequest Class

ConferenceApiHandlerActivateAuxiliaryRequest Class

Parameters to ActivateAuxiliary
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerActivateAuxiliaryRequest
Syntax
Json
{ JsonClass:ActivateAuxiliaryRequest		Active:<type>,
 }

The ConferenceApiHandlerActivateAuxiliaryRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateAuxiliaryRequest | Initializes a new instance of the ConferenceApiHandlerActivateAuxiliaryRequest class
Top
Properties
 | Name | Description
Public property | Active | Indicates whether the auxiliary needs to be activated
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.MainMacAddr Property

MainMacAddr Property

Syntax
Json
{ Property:MainMacAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageUpdate Properties

The JsonMessageUpdate type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | What |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioLevel Constructor

Initializes a new instance of the LanguageAudioLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQualityConfigurationRequest Constructor

ConferenceApiHandlerGetQualityConfigurationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetQualityConfigurationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet Constructor

Overload List
 | Name | Description
Public method | UserInfoGet | Default constructor
Public method | UserInfoGet(UserInfoGet) | Copy constructor
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsRequest Constructor

ConferenceApiHandlerGetLogsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetLogsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableTestTonesRequest Constructor

ConferenceApiHandlerGetEnableTestTonesRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetEnableTestTonesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.OperationalWorkerThread
Syntax
Json
{ JsonClass:WorkerThread		EndLoop:<type>,
    ManagedThreadId:<type>,
 }

The WorkerThread type exposes the following members.

Constructors
 | Name | Description
Protected method | WorkerThread | Initializes a new instance of the WorkerThread class
Top
Properties
 | Name | Description
Private property | EndLoop |
Public property | ManagedThreadId |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorkerThread
Protected method | QueueWorkItem |
Private method | Run |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ChannelInfo Constructor

Initializes a new instance of the ChannelInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSource Constructor

Initializes a new instance of the JsonLanguageSource class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItem.DoWork Method

DoWork Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


Roles Enumeration

Defines user roles
Syntax
Json
Roles:{
Technician
Operator}
Members
Member name | Value | Description
Technician | 0 | The technician has the following permissions: CanViewTransmitterStatus, CanViewDashboard, CanControlTransmitter, CanConfigureLicenses, CanSwitchSystemPowerOff, CanManageUsers
Operator | 1 | The operator has the following permissions: CanViewTransmitterStatus, CanViewDashboard, CanSwitchSystemPowerOff, CanChangeOwnPassword
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.SubnetMask Property

SubnetMask Property

The Subnet Mask of the INT-TXO
Syntax
Json
{ Property:SubnetMask }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageGainLevelsResponse Constructor

ConferenceApiHandlerSetLanguageGainLevelsResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetLanguageGainLevelsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkInfo Constructor

Initializes a new instance of the JsonNetworkInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfo Constructor

Initializes a new instance of the JsonLanguageLabelInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo.Channels Property

Channels Property

Syntax
Json
{ Property:Channels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoGet.Role Property

Role Property

Syntax
Json
{ Property:Role }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateLicensesResponse Properties

The ConferenceApiHandlerActivateLicensesResponse type exposes the following members.

Properties
 | Name | Description
Public property | Package | The Base64 encoded binary string containing the activation request file information.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfoList Properties

The JsonLanguageLabelInfoList type exposes the following members.

Properties
 | Name | Description
Public property | LanguageLabels |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetControlModeResponse Class

ConferenceApiHandlerSetControlModeResponse Class

Response from SetControlMode
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetControlModeResponse
Syntax
Json
{ JsonClass:SetControlModeResponse	 }

The ConferenceApiHandlerSetControlModeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetControlModeResponse | Initializes a new instance of the ConferenceApiHandlerSetControlModeResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoPut.Password Property

Password Property

Syntax
Json
{ Property:Password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSetHostname.Hostname Property

Hostname Property

Syntax
Json
{ Property:Hostname }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetInputContactStateResponse Properties

The ConferenceApiHandlerGetInputContactStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | Engaged | Indicates whether input contact on the INT-TXO is engaged or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageAudioModesRequest.LanguageAudioModes Property

LanguageAudioModes Property

The list of languages with their audio modes configuration
Syntax
Json
{ Property:LanguageAudioModes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetToFactoryDefaultResponse Class

ConferenceApiHandlerResetToFactoryDefaultResponse Class

Response from ResetToFactoryDefault
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerResetToFactoryDefaultResponse
Syntax
Json
{ JsonClass:ResetToFactoryDefaultResponse	 }

The ConferenceApiHandlerResetToFactoryDefaultResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerResetToFactoryDefaultResponse | Initializes a new instance of the ConferenceApiHandlerResetToFactoryDefaultResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypesInfoList.LanguageSourceTypes Property

LanguageSourceTypes Property

Syntax
Json
{ Property:LanguageSourceTypes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer.Dispose Method (Boolean)

Dispose Method (Boolean)

 Bosch Logo
Releases the unmanaged resources used by the Synchronizer and optionally releases the managed resources
Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLoginStatus Properties

The JsonLoginStatus type exposes the following members.

Properties
 | Name | Description
Public property | LoggedIn |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageDistributionInfoResponse Class

ConferenceApiHandlerGetLanguageDistributionInfoResponse Class

 Bosch Logo
Response from GetLanguageDistributionInfo
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLanguageDistributionInfoResponse
Syntax
Json
{ JsonClass:GetLanguageDistributionInfoResponse		LanguageDistributionInfo:<type>,
 }

The ConferenceApiHandlerGetLanguageDistributionInfoResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLanguageDistributionInfoResponse | Initializes a new instance of the ConferenceApiHandlerGetLanguageDistributionInfoResponse class
Top
Properties
 | Name | Description
Public property | LanguageDistributionInfo | The language distribution info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageMutedStatesRequest Class

ConferenceApiHandlerSetLanguageMutedStatesRequest Class

Parameters to SetLanguagesMutedState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageMutedStatesRequest
Syntax
Json
{ JsonClass:SetLanguageMutedStatesRequest		LanguageMutedStates:<type>,
 }

The ConferenceApiHandlerSetLanguageMutedStatesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageMutedStatesRequest | Initializes a new instance of the ConferenceApiHandlerSetLanguageMutedStatesRequest class
Top
Properties
 | Name | Description
Public property | LanguageMutedStates | The list of language muted status.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbySchedule.Schedule Property

Schedule Property

Syntax
Json
{ Property:Schedule }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveUserResponse Constructor

ConferenceApiHandlerRemoveUserResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRemoveUserResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.DeviceName Property

DeviceName Property

The device name of the INT-TXO
Syntax
Json
{ Property:DeviceName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EventResponse Class

ConferenceApiHandlerEventResponse Class

Events response
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerEventResponse
Syntax
Json
{ JsonClass:EventResponse		Events:<type>,
 }

The ConferenceApiHandlerEventResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerEventResponse | Initializes a new instance of the ConferenceApiHandlerEventResponse class
Top
Properties
 | Name | Description
Public property | Events | List of events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsResponse.Logs Property

Logs Property

The returned list of logs
Syntax
Json
{ Property:Logs }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo Properties

The NetworkInfo type exposes the following members.

Properties
 | Name | Description
Public property | CapIpAddr | The IP-address of the CAP processor of the INT-TXO
Public property | CapMacAddr | The MAC-address of the CAP processor of the INT-TXO
Public property | DeviceName | The device name of the INT-TXO
Public property | Gateway | The default gateway of the INT-TXO
Public property | Hostname | The hostname of the INT-TXO
Public property | IpAssignmentMode | The network address assignent setting of a network
Public property | MainIpAddr | The IP-address of the main processor of the INT-TXO
Public property | MainMacAddr | The MAC-address of the main processor of the INT-TXO
Public property | Rstp | Indicates whether the RSTP protocol is enabled/disabled on the INT-TXO
Public property | SerialNumber | The serial number of the INT-TXO
Public property | SubnetMask | The Subnet Mask of the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RebootRequest Class

ConferenceApiHandlerRebootRequest Class

Parameters to Reboot
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRebootRequest
Syntax
Json
{ JsonClass:RebootRequest	 }

The ConferenceApiHandlerRebootRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRebootRequest | Initializes a new instance of the ConferenceApiHandlerRebootRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.WorkItemQueue Class

WorkerThreadWorkItemQueue Class

Inheritance Hierarchy
SystemObject
System.Collections.GenericQueueWorkItem
TxoConferenceApi.OperationalWorkerThreadWorkItemQueue
Syntax
Json
{ JsonClass:WorkItemQueue		Count:<type>,
    HasItems:<type>,
 }

The WorkerThreadWorkItemQueue type exposes the following members.

Constructors
 | Name | Description
Public method | WorkerThreadWorkItemQueue | Initializes a new instance of the WorkerThreadWorkItemQueue class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the QueueT. (Inherited from QueueWorkItem .)
Public property | HasItems |
Top
Methods
 | Name | Description
Public method | Clear | Removes all objects from the QueueT. (Inherited from QueueWorkItem .)
Public method | Contains | Determines whether an element is in the QueueT. (Inherited from QueueWorkItem .)
Public method | CopyTo | Copies the QueueT elements to an existing one-dimensional Array, starting at the specified array index. (Inherited from QueueWorkItem .)
Public method | Dequeue |
Public method | Enqueue |
Public method | GetEnumerator | Returns an enumerator that iterates through the QueueT. (Inherited from QueueWorkItem .)
Public method | Peek | Returns the object at the beginning of the QueueT without removing it. (Inherited from QueueWorkItem .)
Public method | ToArray | Copies the QueueT elements to a new array. (Inherited from QueueWorkItem .)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the QueueT, if that number is less than 90 percent of current capacity. (Inherited from QueueWorkItem .)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfo Constructor

Initializes a new instance of the JsonRadiatorInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetStandbyStateRequest Class

ConferenceApiHandlerSetStandbyStateRequest Class

Parameters to SetStandbyState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetStandbyStateRequest
Syntax
Json
{ JsonClass:SetStandbyStateRequest		Standby:<type>,
 }

The ConferenceApiHandlerSetStandbyStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetStandbyStateRequest | Initializes a new instance of the ConferenceApiHandlerSetStandbyStateRequest class
Top
Properties
 | Name | Description
Public property | Standby | Whether INT-TXO is in standby or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonDateTime Constructor

Initializes a new instance of the JsonDateTime class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RebootResponse Class

ConferenceApiHandlerRebootResponse Class

Response from Reboot
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRebootResponse
Syntax
Json
{ JsonClass:RebootResponse	 }

The ConferenceApiHandlerRebootResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRebootResponse | Initializes a new instance of the ConferenceApiHandlerRebootResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageLabelsResponse Class

ConferenceApiHandlerSetLanguageLabelsResponse Class

Response from SetLanguageLabels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageLabelsResponse
Syntax
Json
{ JsonClass:SetLanguageLabelsResponse	 }

The ConferenceApiHandlerSetLanguageLabelsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageLabelsResponse | Initializes a new instance of the ConferenceApiHandlerSetLanguageLabelsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateLicensesResponse.Package Property

Package Property

The Base64 encoded binary string containing the activation request file information.
Syntax
Json
{ Property:Package }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterFirstUseResponse Class

ConferenceApiHandlerRegisterFirstUseResponse Class

Response from RegisterFirstUse
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRegisterFirstUseResponse
Syntax
Json
{ JsonClass:RegisterFirstUseResponse	 }

The ConferenceApiHandlerRegisterFirstUseResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterFirstUseResponse | Initializes a new instance of the ConferenceApiHandlerRegisterFirstUseResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuxiliaryAudioLevel Properties

The AuxiliaryAudioLevel type exposes the following members.

Properties
 | Name | Description
Public property | DbLevel | The level of the audio for the zuxiliary input
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageGainLevelsRequest.LanguageGainLevels Property

LanguageGainLevels Property

The list of channels and the channel gain levels needs to be set to
Syntax
Json
{ Property:LanguageGainLevels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.MainIpAddr Property

MainIpAddr Property

The IP-address of the main processor of the INT-TXO
Syntax
Json
{ Property:MainIpAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonDateTime Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonDateTime
Syntax
Json
{ JsonClass:JsonDateTime		DateTime:<type>,
 }

The JsonDateTime type exposes the following members.

Constructors
 | Name | Description
Public method | JsonDateTime | Initializes a new instance of the JsonDateTime class
Top
Properties
 | Name | Description
Public property | DateTime |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateLicensesRequest.Dictionary Property

Dictionary Property

The information of the customer activating the license(s)
Syntax
Json
{ Property:Dictionary }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EventResponse Constructor

ConferenceApiHandlerEventResponse Constructor

Initializes a new instance of the ConferenceApiHandlerEventResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfo.IsPresent Property

IsPresent Property

Syntax
Json
{ Property:IsPresent }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLicenseInfo Constructor

Initializes a new instance of the JsonLicenseInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageSourceTypesResponse Class

ConferenceApiHandlerSetLanguageSourceTypesResponse Class

Response from SetLanguageSourceTypes
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageSourceTypesResponse
Syntax
Json
{ JsonClass:SetLanguageSourceTypesResponse	 }

The ConferenceApiHandlerSetLanguageSourceTypesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageSourceTypesResponse | Initializes a new instance of the ConferenceApiHandlerSetLanguageSourceTypesResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VersionInfo.MainVersion Property

MainVersion Property

The main software version of the INT-TXO
Syntax
Json
{ Property:MainVersion }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetOperationModeResponse Properties

The ConferenceApiHandlerGetOperationModeResponse type exposes the following members.

Properties
 | Name | Description
Public property | Mode | The operation mode.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonControlMode Constructor

Initializes a new instance of the JsonControlMode class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDicentisConnectionStateResponse.Connected Property

Connected Property

The state of the connection with the DICENTIS system
Syntax
Json
{ Property:Connected }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInputContactStateRequest Constructor

ConferenceApiHandlerGetInputContactStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetInputContactStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNumberOfLanguagesLimit Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonNumberOfLanguagesLimit
Syntax
Json
{ JsonClass:JsonNumberOfLanguagesLimit		Limit:<type>,
 }

The JsonNumberOfLanguagesLimit type exposes the following members.

Constructors
 | Name | Description
Public method | JsonNumberOfLanguagesLimit | Initializes a new instance of the JsonNumberOfLanguagesLimit class
Top
Properties
 | Name | Description
Public property | Limit |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNetworkInfoResponse Class

ConferenceApiHandlerGetNetworkInfoResponse Class

Response from GetNetworkInfo
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetNetworkInfoResponse
Syntax
Json
{ JsonClass:GetNetworkInfoResponse		NetworkInfo:<type>,
 }

The ConferenceApiHandlerGetNetworkInfoResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetNetworkInfoResponse | Initializes a new instance of the ConferenceApiHandlerGetNetworkInfoResponse class
Top
Properties
 | Name | Description
Public property | NetworkInfo | The network info of the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer Methods

The Synchronizer type exposes the following members.

Methods
 | Name | Description
Public method | CreateCopy | (Overrides SynchronizationContextCreateCopy.)
Public method | Dispose |
Protected method | Dispose(Boolean) |
Public method | IsWaitNotificationRequired | Determines if wait notification is required. (Inherited from SynchronizationContext.)
Public method | OperationCompleted | When overridden in a derived class, responds to the notification that an operation has completed. (Inherited from SynchronizationContext.)
Public method | OperationStarted | When overridden in a derived class, responds to the notification that an operation has started. (Inherited from SynchronizationContext.)
Public method | Post | (Overrides SynchronizationContextPost(SendOrPostCallback, Object).)
Public method | Send | (Overrides SynchronizationContextSend(SendOrPostCallback, Object).)
Protected method | SetWaitNotificationRequired | Sets notification that wait notification is required and prepares the callback method so it can be called more reliably when a wait occurs. (Inherited from SynchronizationContext.)
Public method | Wait | Waits for any or all the elements in the specified array to receive a signal. (Inherited from SynchronizationContext.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TcpIpSetting Enumeration

The network address assignent setting of a network
Syntax
Json
TcpIpSetting:{
Dhcp
Manual}
Members
Member name | Value | Description
Dhcp | 0 | Automatic (DHCP)
Manual | 1 | Manual
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSourceTypeInfo Properties

The LanguageSourceTypeInfo type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | SourceType | The audio source type for the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetCarriersStateRequest Constructor

ConferenceApiHandlerGetCarriersStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetCarriersStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsTailResponse.Logs Property

Logs Property

The logs returned from the tail
Syntax
Json
{ Property:Logs }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ProcessLicensePackageResponse Constructor

ConferenceApiHandlerProcessLicensePackageResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerProcessLicensePackageResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageDistributionInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageDistributionInfo
Syntax
Json
{ JsonClass:JsonLanguageDistributionInfo		NumberOfActiveLanguages:<type>,
    NumberOfReceivedLanguages:<type>,
 }

The JsonLanguageDistributionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageDistributionInfo | Initializes a new instance of the JsonLanguageDistributionInfo class
Top
Properties
 | Name | Description
Public property | NumberOfActiveLanguages |
Public property | NumberOfReceivedLanguages |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetAuxiliaryMutedStateResponse Properties

The ConferenceApiHandlerGetAuxiliaryMutedStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | Muted | Indicates whether the analog auxiliary input is muted or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageDistributionInfoResponse Constructor

ConferenceApiHandlerGetLanguageDistributionInfoResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetLanguageDistributionInfoResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageEvents Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonMessageEvents
Syntax
Json
{ JsonClass:JsonMessageEvents		Events:<type>,
 }

The JsonMessageEvents type exposes the following members.

Constructors
 | Name | Description
Public method | JsonMessageEvents | Initializes a new instance of the JsonMessageEvents class
Top
Properties
 | Name | Description
Public property | Events |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo Constructor

Initializes a new instance of the JsonPhysicalNetworkInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageAudioLevelsList Constructor

Initializes a new instance of the JsonMessageAudioLevelsList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAudioChannelLevel Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonAudioChannelLevel
Syntax
Json
{ JsonClass:JsonAudioChannelLevel		ChannelId:<type>,
    DbLevel:<type>,
 }

The JsonAudioChannelLevel type exposes the following members.

Constructors
 | Name | Description
Public method | JsonAudioChannelLevel | Initializes a new instance of the JsonAudioChannelLevel class
Top
Properties
 | Name | Description
Public property | ChannelId |
Public property | DbLevel |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TcpIpProperties.CapIpAddr Property

CapIpAddr Property

The IP-address of the CAP processor
Syntax
Json
{ Property:CapIpAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterFirstUseRequest Class

ConferenceApiHandlerRegisterFirstUseRequest Class

Parameters to RegisterFirstUse
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRegisterFirstUseRequest
Syntax
Json
{ JsonClass:RegisterFirstUseRequest		Password:<type>,
 }

The ConferenceApiHandlerRegisterFirstUseRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterFirstUseRequest | Initializes a new instance of the ConferenceApiHandlerRegisterFirstUseRequest class
Top
Properties
 | Name | Description
Public property | Password | New password for Admin user upon first-time registration.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfo Constructor

Initializes a new instance of the JsonCarrierInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivationInfo.Version Property

Version Property

The version string of the license manager on the device
Syntax
Json
{ Property:Version }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRadiatorsStateRequest Class

ConferenceApiHandlerGetRadiatorsStateRequest Class

Parameters to GetRadiatorsState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetRadiatorsStateRequest
Syntax
Json
{ JsonClass:GetRadiatorsStateRequest	 }

The ConferenceApiHandlerGetRadiatorsStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetRadiatorsStateRequest | Initializes a new instance of the ConferenceApiHandlerGetRadiatorsStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsRequest Constructor

ConferenceApiHandlerGetPermissionsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetPermissionsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonDicentisConnectionState.Connected Property

Connected Property

Syntax
Json
{ Property:Connected }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CarrierInfo.CarrierId Property

CarrierId Property

The ID of the carrier
Syntax
Json
{ Property:CarrierId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetOperationModeRequest Constructor

ConferenceApiHandlerGetOperationModeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetOperationModeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.CommonDisposableObject
TxoConferenceApi.ClientConferenceApiHandler
Syntax
Json
{ JsonClass:DisposableObject		Disposed:<type>,
 }

The DisposableObject type exposes the following members.

Constructors
 | Name | Description
Protected method | DisposableObject | Initializes a new instance of the DisposableObject class
Top
Properties
 | Name | Description
Protected property | Disposed |
Top
Methods
 | Name | Description
Protected method | CleanupUnmanagedResources |
Public method | Dispose | Releases all resources used by the DisposableObject
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DisposableObject and optionally releases the managed resources
Protected method | Finalize | (Overrides ObjectFinalize.)
Protected method | ValidateStateNotDisposed |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetHostnameRequest Constructor

ConferenceApiHandlerSetHostnameRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetHostnameRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbySchedule Properties

The JsonStandbySchedule type exposes the following members.

Properties
 | Name | Description
Public property | Schedule |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetLogsTailRequest Properties

The ConferenceApiHandlerGetLogsTailRequest type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of logs to retrieve from the tail
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableTestTonesRequest Class

ConferenceApiHandlerEnableTestTonesRequest Class

Parameters to EnableTestTones
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerEnableTestTonesRequest
Syntax
Json
{ JsonClass:EnableTestTonesRequest		Enable:<type>,
 }

The ConferenceApiHandlerEnableTestTonesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerEnableTestTonesRequest | Initializes a new instance of the ConferenceApiHandlerEnableTestTonesRequest class
Top
Properties
 | Name | Description
Public property | Enable | Indicates whether the test tones to all channels are enabled
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetToFactoryDefaultRequest Constructor

ConferenceApiHandlerResetToFactoryDefaultRequest Constructor

Initializes a new instance of the ConferenceApiHandlerResetToFactoryDefaultRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessage Properties

The JsonMessage type exposes the following members.

Properties
 | Name | Description
Public property | MessageId |
Public property | Operation |
Public property | Parameters |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetLanguageMutedStatesRequest Properties

The ConferenceApiHandlerSetLanguageMutedStatesRequest type exposes the following members.

Properties
 | Name | Description
Public property | LanguageMutedStates | The list of language muted status.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageMutedStatesRequest Class

ConferenceApiHandlerGetLanguageMutedStatesRequest Class

Parameters to GetLanguageMuteStates
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLanguageMutedStatesRequest
Syntax
Json
{ JsonClass:GetLanguageMutedStatesRequest	 }

The ConferenceApiHandlerGetLanguageMutedStatesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLanguageMutedStatesRequest | Initializes a new instance of the ConferenceApiHandlerGetLanguageMutedStatesRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageInputsResponse Constructor

ConferenceApiHandlerSetLanguageInputsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetLanguageInputsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread Methods

The WorkerThread type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | QueueWorkItem |
Private method | Run |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableTestTonesResponse Constructor

ConferenceApiHandlerGetEnableTestTonesResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetEnableTestTonesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateAuxiliaryRequest Properties

The ConferenceApiHandlerActivateAuxiliaryRequest type exposes the following members.

Properties
 | Name | Description
Public property | Active | Indicates whether the auxiliary needs to be activated
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LicenseInfo Class

Describes the license information
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLicenseInfo
Syntax
Json
{ JsonClass:LicenseInfo		ActivationInfo:<type>,
    CustomerInfo:<type>,
 }

The LicenseInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LicenseInfo | Initializes a new instance of the LicenseInfo class
Top
Properties
 | Name | Description
Public property | ActivationInfo | The information on the licenses installed on the transmitter.
Public property | CustomerInfo | The customer registration information.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegistrationEvents.Events Property

Events Property

Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSource Properties

The JsonLanguageSource type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId |
Public property | SourceInput |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableTestTonesResponse Class

ConferenceApiHandlerEnableTestTonesResponse Class

Response from EnableTestTones
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerEnableTestTonesResponse
Syntax
Json
{ JsonClass:EnableTestTonesResponse	 }

The ConferenceApiHandlerEnableTestTonesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerEnableTestTonesResponse | Initializes a new instance of the ConferenceApiHandlerEnableTestTonesResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.CommonDisposableObject
TxoConferenceApi.ClientConferenceApiHandler
Syntax
Json
{ JsonClass:ConferenceApiHandler		Disposed:<type>,
 }

The ConferenceApiHandler type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandler | Initializes a new instance of the ConferenceApiHandler class
Top
Properties
 | Name | Description
Protected property | Disposed | (Inherited from DisposableObject.)
Top
Methods
 | Name | Description
Public method | ActivateAuxiliary | Activates the analog auxiliary input
Public method | ActivateLicenses | Issues a request to activate license(s)
Public method | AddUser | Adds a user
Public method | BackupConfiguration | Gets the current Configuration file on device
Public method | ChangeOwnPassword | Change the password of the logged in user
Protected method | CleanupUnmanagedResources | (Inherited from DisposableObject.)
Public method | Dispose | (Inherited from DisposableObject.)
Public method | EnableTestTones | Enables testtones to all channels. Is not possible to enable testtones when 'slave' mode or 'auxiliary' mode is active
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetAuxiliaryGainLevel | Gets the auxiliary gain level.
Public method | GetAuxiliaryMutedState | Gets the analog auxiliary active state
Public method | GetAuxiliaryState | Gets the analog auxiliary active state
Public method | GetCarriersState | Gets the enabled state of the carriers
Public method | GetControlModeConfiguration | Gets the currently configured Standalone or DICENTIS mode of the INT-TXO.
Public method | GetDateTime | Gets the local date and time as single string in iso-8601 format (yyyy-MM-ddTHH:mm:ss)
Public method | GetDicentisConnectionState | Gets the state of the connection with the DICENTIS system
Public method | GetEnableTestTones | Gets the enabled state of testtones to all channels
Public method | GetInputContactState | Gets the input contact state of the transmitter
Public method | GetLanguageDistributionInfo | Gets Language Distribution Info
Public method | GetLanguageGainLevels | Gets the channel gain levels.
Public method | GetLanguageMutedStates | Gets the muted state of the languages
Public method | GetLanguagesConfiguration | Gets the overall language, channel and carrier configuration for routing audio. Returns the current transmitted language configuration, including to which carrier the channels for the language are allocated. The sourceInput indicates which Dicentis language with languageId matching the sourceInput is being received and transmitted to the receiver. The sourceInput is ignored for Dante languages.
Public method | GetLatestLogs | This function gets the latest logs from the INT-TXO starting from the moment this function was last called
Public method | GetLicenses | Gets the installed licenses on the device
Public method | GetLoginStatus | Gets the login status
Public method | GetLogLevel | This function gets the loglevel set on the INT-TXO
Public method | GetLogs | This function gets all logs available on the INT-TXO
Public method | GetLogsTail | This function gets last count of logs from the eventlog on the INT-TXO
Public method | GetNetworkInfo | Gets the network information
Public method | GetNumberOfLanguagesLimit | Gets the configured maximum number of languages to transmit
Public method | GetOperationMode | Gets the master/slave operation mode
Public method | GetPermissions | Gets the permissions of the logged-in user
Public method | GetQualityConfiguration | Gets the overall channel quality configuration setting
Public method | GetRadiatorsState | Gets the radiators state connected to the INT-TXO
Public method | GetRegisterFirstUseState | Gets the state of registering for first use
Public method | GetStandbyState | Gets the standby state of the transmitter
Public method | GetSystemMode | Gets the current system mode the INT-TXO is in.
Public method | GetUsers | Gets the users
Public method | GetVersionInfo | Gets the version information
Public method | Login | Logs in the user
Public method | Logout | Logs the user out
Public method | ProcessLicensePackage | Issues a request to process a license response package
Public method | Reboot | Triggers an unconditional reboot of the transmitter
Public method | RegisterAudioLevels | This functions allows to register for audio level updates for the channels.
Public method | RegisterEvents | This function allows to register for events (e.g.: The number of active channels changed or permissions changed) of which the current data needs to be requested, whenever the event is triggered
Public method | RegisterFirstUse | Registers first use
Public method | RemoveUser | Removes a user
Public method | ResetToFactoryDefault | Resets the transmitter to its factory defaults
Public method | RestoreConfiguration | Restore configuration data retrieved with 'backupConfiguration'
Public method | SetAuxiliaryGainLevel | This function allows to set the gain level of the auxiliary input, valid values between -12dB and 12dB in steps of 0.5dB
Public method | SetAuxiliaryMutedState | This function allows to set the muted state of the auxiliary input
Public method | SetCarriersState | Sets the carriers state connected to the INT-TXO
Public method | SetControlMode | Sets the control mode of the INT-TXO. The control mode configuration setting is stored persistently in the INT-TXO's configuration. The operational state of the control mode will only change when the current state of the INT-TXO allows for it.
Public method | SetDateTime | Sets the current local date and time as single string in iso-8601 format (yyyy-MM-ddTHH:mm:ss)
Public method | SetHostname | Change the hostname of the INT-TXO
Public method | SetLanguageAudioModes | This functions sets the audio mode for the given list of languages.
Public method | SetLanguageGainLevels | This function allows to set the gain level of the given set of languages, valid values between -12dB and 12dB in steps of 0.5dB
Public method | SetLanguageInputs | This function sets the source input configuration for the given list languages. For a language definition with 'languageId', sets a Dicentis language languageId as 'sourceInput'. The Dicentis language configured as 'sourceInput' will then be receive and transmitted to the receiver. The default value of a sourceInput equals the languageId.The sourceInput is only valid/used for Dicentis languages.
Public method | SetLanguageLabels | This function sets thelabels for the given list of languages.
Public method | SetLanguageMutedStates | This function sets the muted state for the given list of languages.
Public method | SetLanguageSourceTypes | This function sets the source types for the given list of languages.
Public method | SetLogLevel | This function sets the loglevel on the INT-TXO
Public method | SetManualNetworkIpSettings | This functions allows to set the network settings
Public method | SetNetworkIpAssignmentMode | Indicates whether network address should assigned automatically (DHCP) or manual
Public method | SetNumberOfLanguagesLimit | Configures the maximum number of languages to transmit
Public method | SetQualityConfiguration | Sets the overall channel quality configuration
Public method | SetStandbyState | Gets the standby state of the transmitter: 'on' or 'off'
Public method | UnregisterAudioLevels | This functions allows to unregister from audio level updates.
Public method | UnregisterEvents | This functions allows to un register for the registered events
Public method | UpdateUser | Updates a user.
Protected method | ValidateStateNotDisposed | (Inherited from DisposableObject.)
Top
Events
 | Name | Description
Public event | ApiAudioLevelsUpdateReceived |
Public event | ApiEventReceived |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageMutedStatesResponse Class

ConferenceApiHandlerGetLanguageMutedStatesResponse Class

Response from GetLanguageMuteStates
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLanguageMutedStatesResponse
Syntax
Json
{ JsonClass:GetLanguageMutedStatesResponse		LanguageMutedStates:<type>,
 }

The ConferenceApiHandlerGetLanguageMutedStatesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLanguageMutedStatesResponse | Initializes a new instance of the ConferenceApiHandlerGetLanguageMutedStatesResponse class
Top
Properties
 | Name | Description
Public property | LanguageMutedStates | The mute state for list of languages
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.Rstp Property

Rstp Property

Indicates whether the RSTP protocol is enabled/disabled on the INT-TXO
Syntax
Json
{ Property:Rstp }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryMutedState Properties

The JsonAuxiliaryMutedState type exposes the following members.

Properties
 | Name | Description
Public property | Muted |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfoList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageMutedStateInfoList
Syntax
Json
{ JsonClass:JsonLanguageMutedStateInfoList		LanguageMutedStates:<type>,
 }

The JsonLanguageMutedStateInfoList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageMutedStateInfoList | Initializes a new instance of the JsonLanguageMutedStateInfoList class
Top
Properties
 | Name | Description
Public property | LanguageMutedStates |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInputContactStateResponse Constructor

ConferenceApiHandlerGetInputContactStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetInputContactStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyScheduleInfo.DateTime Property

DateTime Property

Syntax
Json
{ Property:DateTime }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicense.FeatureName Property

FeatureName Property

Syntax
Json
{ Property:FeatureName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfoList Properties

The JsonLanguageMutedStateInfoList type exposes the following members.

Properties
 | Name | Description
Public property | LanguageMutedStates |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNumberOfLanguagesLimitRequest Constructor

ConferenceApiHandlerSetNumberOfLanguagesLimitRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetNumberOfLanguagesLimitRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPackageInfo.Package Property

Package Property

Syntax
Json
{ Property:Package }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ProcessLicensePackageResponse Class

ConferenceApiHandlerProcessLicensePackageResponse Class

Response for processing response license package
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerProcessLicensePackageResponse
Syntax
Json
{ JsonClass:ProcessLicensePackageResponse		Package:<type>,
 }

The ConferenceApiHandlerProcessLicensePackageResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerProcessLicensePackageResponse | Initializes a new instance of the ConferenceApiHandlerProcessLicensePackageResponse class
Top
Properties
 | Name | Description
Public property | Package | The Base64 encoded binary string containing the possible return file information.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryMutedStateRequest.Muted Property

Muted Property

The muted state of the auxiliary input
Syntax
Json
{ Property:Muted }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginResponse Class

ConferenceApiHandlerLoginResponse Class

Response from Login
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerLoginResponse
Syntax
Json
{ JsonClass:LoginResponse		LoggedIn:<type>,
 }

The ConferenceApiHandlerLoginResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLoginResponse | Initializes a new instance of the ConferenceApiHandlerLoginResponse class
Top
Properties
 | Name | Description
Public property | LoggedIn | Loggeg in status
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsTailRequest.Count Property

Count Property

The number of logs to retrieve from the tail
Syntax
Json
{ Property:Count }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyState Properties

The JsonStandbyState type exposes the following members.

Properties
 | Name | Description
Public property | Standby |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLicensesRequest Constructor

ConferenceApiHandlerGetLicensesRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetLicensesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNetworkIpAssignmentModeRequest Class

ConferenceApiHandlerSetNetworkIpAssignmentModeRequest Class

Parameters to SetNetworkIpAssignmentMode
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetNetworkIpAssignmentModeRequest
Syntax
Json
{ JsonClass:SetNetworkIpAssignmentModeRequest		IpAssignmentMode:<type>,
 }

The ConferenceApiHandlerSetNetworkIpAssignmentModeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetNetworkIpAssignmentModeRequest | Initializes a new instance of the ConferenceApiHandlerSetNetworkIpAssignmentModeRequest class
Top
Properties
 | Name | Description
Public property | IpAssignmentMode | Indicates whether IP-addresses are assigned automatically (DHCP) or manual
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoList Properties

The JsonUserInfoList type exposes the following members.

Properties
 | Name | Description
Public property | Users |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetLatestLogsResponse Properties

The ConferenceApiHandlerGetLatestLogsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Logs | The list of logs returned
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageEvents.Events Property

Events Property

Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet Properties

The UserInfoGet type exposes the following members.

Properties
 | Name | Description
Public property | FirstName | The first name of the user
Public property | LastName | The last name of the user
Public property | Role | The role of the user, which determines their permissions
Public property | User | The ID of the user (i.e. their user name)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageAudioModesResponse Constructor

ConferenceApiHandlerSetLanguageAudioModesResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetLanguageAudioModesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet.User Property

User Property

The ID of the user (i.e. their user name)
Syntax
Json
{ Property:User }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRemoveUser Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonRemoveUser
Syntax
Json
{ JsonClass:JsonRemoveUser		User:<type>,
 }

The JsonRemoveUser type exposes the following members.

Constructors
 | Name | Description
Public method | JsonRemoveUser | Initializes a new instance of the JsonRemoveUser class
Top
Properties
 | Name | Description
Public property | User |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfo.RadiatorId Property

RadiatorId Property

Syntax
Json
{ Property:RadiatorId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LogoutResponse Constructor

ConferenceApiHandlerLogoutResponse Constructor

Initializes a new instance of the ConferenceApiHandlerLogoutResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetRadiatorsStateResponse Properties

The ConferenceApiHandlerGetRadiatorsStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | RadiatorsInfo | The radiators and their status
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsRequest Class

ConferenceApiHandlerUnregisterEventsRequest Class

Parameters to UnRegisterEvents
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerUnregisterEventsRequest
Syntax
Json
{ JsonClass:UnregisterEventsRequest		Events:<type>,
 }

The ConferenceApiHandlerUnregisterEventsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUnregisterEventsRequest | Initializes a new instance of the ConferenceApiHandlerUnregisterEventsRequest class
Top
Properties
 | Name | Description
Public property | Events | List of unregistered events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.Rstp Property

Rstp Property

Syntax
Json
{ Property:Rstp }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryAudioLevel Properties

The JsonAuxiliaryAudioLevel type exposes the following members.

Properties
 | Name | Description
Public property | DbLevel |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelInfo Constructor

Initializes a new instance of the JsonChannelInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet Class

Describes the user information that can be received from the TXO
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientUserInfoGet
TxoConferenceApi.ClientUserInfoPut
Syntax
Json
{ JsonClass:UserInfoGet		FirstName:<type>,
    LastName:<type>,
    Role:<type>,
    User:<type>,
 }

The UserInfoGet type exposes the following members.

Constructors
 | Name | Description
Public method | UserInfoGet | Default constructor
Public method | UserInfoGet(UserInfoGet) | Copy constructor
Top
Properties
 | Name | Description
Public property | FirstName | The first name of the user
Public property | LastName | The last name of the user
Public property | Role | The role of the user, which determines their permissions
Public property | User | The ID of the user (i.e. their user name)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAudioChannelLevel Constructor

Initializes a new instance of the JsonAudioChannelLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetCarriersStateResponse Constructor

ConferenceApiHandlerSetCarriersStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetCarriersStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicense Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonInstalledLicense
Syntax
Json
{ JsonClass:JsonInstalledLicense		ActivationDate:<type>,
    ExpirationDate:<type>,
    FeatureName:<type>,
    Quantity:<type>,
 }

The JsonInstalledLicense type exposes the following members.

Constructors
 | Name | Description
Public method | JsonInstalledLicense | Initializes a new instance of the JsonInstalledLicense class
Top
Properties
 | Name | Description
Public property | ActivationDate |
Public property | ExpirationDate |
Public property | FeatureName |
Public property | Quantity |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTcpIpSettings Properties

The JsonTcpIpSettings type exposes the following members.

Properties
 | Name | Description
Public property | CapIpAddr |
Public property | Gateway |
Public property | MainIpAddr |
Public property | SubnetMask |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EventResponse.Events Property

Events Property

List of events
Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VersionInfo.OmneoVersion Property

OmneoVersion Property

The OMNEO software version
Syntax
Json
{ Property:OmneoVersion }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer.Send Method

Send Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo.SourceInput Property

SourceInput Property

Syntax
Json
{ Property:SourceInput }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDateTimeResponse Class

ConferenceApiHandlerGetDateTimeResponse Class

Response from GetDateTime
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetDateTimeResponse
Syntax
Json
{ JsonClass:GetDateTimeResponse		DateTime:<type>,
 }

The ConferenceApiHandlerGetDateTimeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetDateTimeResponse | Initializes a new instance of the ConferenceApiHandlerGetDateTimeResponse class
Top
Properties
 | Name | Description
Public property | DateTime | Contains the current date and time in iso-8601 format
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetUsersResponse Class

ConferenceApiHandlerGetUsersResponse Class

Response from getting Users
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetUsersResponse
Syntax
Json
{ JsonClass:GetUsersResponse		Users:<type>,
 }

The ConferenceApiHandlerGetUsersResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetUsersResponse | Initializes a new instance of the ConferenceApiHandlerGetUsersResponse class
Top
Properties
 | Name | Description
Public property | Users | The information for all users registered on the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddUserRequest Constructor

ConferenceApiHandlerAddUserRequest Constructor

Construct an instance of AddUserRequest from an instance of UserInfoPut
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoGet.FirstName Property

FirstName Property

Syntax
Json
{ Property:FirstName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonUserInfoList
Syntax
Json
{ JsonClass:JsonUserInfoList		Users:<type>,
 }

The JsonUserInfoList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonUserInfoList | Initializes a new instance of the JsonUserInfoList class
Top
Properties
 | Name | Description
Public property | Users |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetDateTimeResponse Properties

The ConferenceApiHandlerGetDateTimeResponse type exposes the following members.

Properties
 | Name | Description
Public property | DateTime | Contains the current date and time in iso-8601 format
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageDistributionInfoRequest Constructor

ConferenceApiHandlerGetLanguageDistributionInfoRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetLanguageDistributionInfoRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegisterFirstUseState.FirstUseState Property

FirstUseState Property

Syntax
Json
{ Property:FirstUseState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.MainIpAddr Property

MainIpAddr Property

Syntax
Json
{ Property:MainIpAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer.CreateCopy Method

CreateCopy Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQualityConfigurationResponse Class

ConferenceApiHandlerGetQualityConfigurationResponse Class

Response from GetQualityConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetQualityConfigurationResponse
Syntax
Json
{ JsonClass:GetQualityConfigurationResponse		Quality:<type>,
 }

The ConferenceApiHandlerGetQualityConfigurationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetQualityConfigurationResponse | Initializes a new instance of the ConferenceApiHandlerGetQualityConfigurationResponse class
Top
Properties
 | Name | Description
Public property | Quality | Indicates the overall channel quality configuration setting.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNetworkIpAssignmentModeRequest.IpAssignmentMode Property

IpAssignmentMode Property

Indicates whether IP-addresses are assigned automatically (DHCP) or manual
Syntax
Json
{ Property:IpAssignmentMode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject.CleanupUnmanagedResources Method

CleanupUnmanagedResources Method

Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourcesList Constructor

Initializes a new instance of the JsonLanguageSourcesList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer.Dispose Method

Dispose Method

Releases all resources used by the Synchronizer
Syntax
Json
Request
Response

Implements

IDisposableDispose
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetUsersRequest Class

ConferenceApiHandlerGetUsersRequest Class

Request for getting Users
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetUsersRequest
Syntax
Json
{ JsonClass:GetUsersRequest	 }

The ConferenceApiHandlerGetUsersRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetUsersRequest | Initializes a new instance of the ConferenceApiHandlerGetUsersRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRegisterFirstUseStateRequest Constructor

ConferenceApiHandlerGetRegisterFirstUseStateRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetRegisterFirstUseStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AddUserRequest Properties

The ConferenceApiHandlerAddUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | FirstName | The first name of the user (Inherited from UserInfoGet.)
Public property | LastName | The last name of the user (Inherited from UserInfoGet.)
Public property | Password | The password of the user (Inherited from UserInfoPut.)
Public property | Role | The role of the user, which determines their permissions (Inherited from UserInfoGet.)
Public property | User | The ID of the user (i.e. their user name) (Inherited from UserInfoGet.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfoList Properties

The JsonRadiatorInfoList type exposes the following members.

Properties
 | Name | Description
Public property | RadiatorsInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AudioMode Enumeration

The audio mode for all supported audio channels
Syntax
Json
AudioMode:{
Mono
Stereo}
Members
Member name | Value | Description
Mono | 0 | Mono audio
Stereo | 1 | Stereo audio
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetLogLevelRequest Properties

The ConferenceApiHandlerSetLogLevelRequest type exposes the following members.

Properties
 | Name | Description
Public property | LogLevel |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageLabelsRequest.LanguageLabels Property

LanguageLabels Property

The list of language labels.
Syntax
Json
{ Property:LanguageLabels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAudioChannelLevel Properties

The JsonAudioChannelLevel type exposes the following members.

Properties
 | Name | Description
Public property | ChannelId |
Public property | DbLevel |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivationInfo.Version Property

Version Property

Syntax
Json
{ Property:Version }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest Constructor

ConferenceApiHandlerLoginRequest Constructor

Initializes a new instance of the ConferenceApiHandlerLoginRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageUpdate.Content Property

Content Property

Syntax
Json
{ Property:Content }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetManualNetworkIpSettingsRequest Class

ConferenceApiHandlerSetManualNetworkIpSettingsRequest Class

Parameters to SetNetworkIpProperties
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetManualNetworkIpSettingsRequest
Syntax
Json
{ JsonClass:SetManualNetworkIpSettingsRequest		Settings:<type>,
 }

The ConferenceApiHandlerSetManualNetworkIpSettingsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetManualNetworkIpSettingsRequest | Initializes a new instance of the ConferenceApiHandlerSetManualNetworkIpSettingsRequest class
Top
Properties
 | Name | Description
Public property | Settings | The network settings to be changed to
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetNumberOfLanguagesLimitResponse Properties

The ConferenceApiHandlerGetNumberOfLanguagesLimitResponse type exposes the following members.

Properties
 | Name | Description
Public property | Limit | Indicates maximum number of languages to transmit
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNetworkInfoResponse Constructor

ConferenceApiHandlerGetNetworkInfoResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetNetworkInfoResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLogs Properties

The JsonLogs type exposes the following members.

Properties
 | Name | Description
Public property | Logs |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetLanguageAudioModesRequest Properties

The ConferenceApiHandlerSetLanguageAudioModesRequest type exposes the following members.

Properties
 | Name | Description
Public property | LanguageAudioModes | The list of languages with their audio modes configuration
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicense.ExpirationDate Property

ExpirationDate Property

Syntax
Json
{ Property:ExpirationDate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsResponse Constructor

ConferenceApiHandlerRegisterEventsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterEventsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetCarriersStateRequest Constructor

ConferenceApiHandlerSetCarriersStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetCarriersStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessage.Operation Property

Operation Property

Syntax
Json
{ Property:Operation }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetStandbyStateRequest Properties

The ConferenceApiHandlerSetStandbyStateRequest type exposes the following members.

Properties
 | Name | Description
Public property | Standby | Whether INT-TXO is in standby or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo.SourceType Property

SourceType Property

Syntax
Json
{ Property:SourceType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegisterFirstUseState Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonRegisterFirstUseState
Syntax
Json
{ JsonClass:JsonRegisterFirstUseState		FirstUseState:<type>,
 }

The JsonRegisterFirstUseState type exposes the following members.

Constructors
 | Name | Description
Public method | JsonRegisterFirstUseState | Initializes a new instance of the JsonRegisterFirstUseState class
Top
Properties
 | Name | Description
Public property | FirstUseState |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject Methods

The DisposableObject type exposes the following members.

Methods
 | Name | Description
Protected method | CleanupUnmanagedResources |
Public method | Dispose |
Protected method | Dispose(Boolean) |
Protected method | Finalize | (Overrides ObjectFinalize.)
Protected method | ValidateStateNotDisposed |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivationInfo Constructor

Initializes a new instance of the JsonActivationInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetUsersRequest Constructor

ConferenceApiHandlerGetUsersRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetUsersRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AudioQuality Enumeration

The audio qualities for all supported audio channels
Syntax
Json
AudioQuality:{
Standard
Premium}
Members
Member name | Value | Description
Standard | 0 | Standard quality
Premium | 1 | Premium quality
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPackageInfo Properties

The JsonPackageInfo type exposes the following members.

Properties
 | Name | Description
Public property | Package |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCustomerInfo Constructor

Initializes a new instance of the JsonCustomerInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryMutedStateResponse Class

ConferenceApiHandlerSetAuxiliaryMutedStateResponse Class

Response from SetAuxiliaryMutedState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetAuxiliaryMutedStateResponse
Syntax
Json
{ JsonClass:SetAuxiliaryMutedStateResponse	 }

The ConferenceApiHandlerSetAuxiliaryMutedStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetAuxiliaryMutedStateResponse | Initializes a new instance of the ConferenceApiHandlerSetAuxiliaryMutedStateResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.CapMacAddr Property

CapMacAddr Property

Syntax
Json
{ Property:CapMacAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDateTimeResponse Constructor

ConferenceApiHandlerGetDateTimeResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetDateTimeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.SubnetMask Property

SubnetMask Property

Syntax
Json
{ Property:SubnetMask }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RadiatorInfo Properties

The RadiatorInfo type exposes the following members.

Properties
 | Name | Description
Public property | HasError | Indicates whether the radiator is in error state
Public property | IsPresent | Indicates whether the radiator is connected to the transmitter
Public property | RadiatorId | The ID of the radiator
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateAuxiliaryRequest.Active Property

Active Property

Indicates whether the auxiliary needs to be activated
Syntax
Json
{ Property:Active }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.BackupConfigurationResponse.Package Property

Package Property

A binary blob
Syntax
Json
{ Property:Package }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Permission Enumeration

Defines user permissions
Syntax
Json
Permission:{
CanRegisterFirstUse
CanViewTransmitterStatus
CanControlTransmitter
CanControlAudio
CanConfigureLicenses
CanSwitchSystemPowerOff
CanChangeOwnPassword
CanManageUsers
CanViewDashboard}
Members
Member name | Value | Description
CanRegisterFirstUse | 0 | Permission to register for first use
CanViewTransmitterStatus | 1 | Permission to view transmitter related status
CanControlTransmitter | 2 | Permission to control the transmitter
CanControlAudio | 3 | Permission to control audio of the transmitter
CanConfigureLicenses | 4 | Permission to configure licenses
CanSwitchSystemPowerOff | 5 | Permission to power off the system
CanChangeOwnPassword | 6 | Permission to change your own password
CanManageUsers | 7 | Permission to add, update or remove information of a user (incl. own password)
CanViewDashboard | 8 | Permission to view the combined dashboard-status of the system
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryActivation Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonAuxiliaryActivation
Syntax
Json
{ JsonClass:JsonAuxiliaryActivation		Active:<type>,
 }

The JsonAuxiliaryActivation type exposes the following members.

Constructors
 | Name | Description
Public method | JsonAuxiliaryActivation | Initializes a new instance of the JsonAuxiliaryActivation class
Top
Properties
 | Name | Description
Public property | Active |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLatestLogsResponse Class

ConferenceApiHandlerGetLatestLogsResponse Class

Response from GetLatestLogs
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLatestLogsResponse
Syntax
Json
{ JsonClass:GetLatestLogsResponse		Logs:<type>,
 }

The ConferenceApiHandlerGetLatestLogsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLatestLogsResponse | Initializes a new instance of the ConferenceApiHandlerGetLatestLogsResponse class
Top
Properties
 | Name | Description
Public property | Logs | The list of logs returned
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetLicensesResponse Properties

The ConferenceApiHandlerGetLicensesResponse type exposes the following members.

Properties
 | Name | Description
Public property | LicenseInfo | The license information available at the transmitter
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LicenseInfo.CustomerInfo Property

CustomerInfo Property

The customer registration information.
Syntax
Json
{ Property:CustomerInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypesInfoList Properties

The JsonLanguageSourceTypesInfoList type exposes the following members.

Properties
 | Name | Description
Public property | LanguageSourceTypes |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveUserResponse Class

ConferenceApiHandlerRemoveUserResponse Class

Response from RemoveUser
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRemoveUserResponse
Syntax
Json
{ JsonClass:RemoveUserResponse	 }

The ConferenceApiHandlerRemoveUserResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRemoveUserResponse | Initializes a new instance of the ConferenceApiHandlerRemoveUserResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetSystemModeResponse Properties

The ConferenceApiHandlerGetSystemModeResponse type exposes the following members.

Properties
 | Name | Description
Public property | Mode | The system mode.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonQualityConfiguration.Quality Property

Quality Property

Syntax
Json
{ Property:Quality }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyScheduleInfo.TimeZone Property

TimeZone Property

Syntax
Json
{ Property:TimeZone }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetControlModeRequest Constructor

ConferenceApiHandlerSetControlModeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetControlModeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivationInfo Constructor

Initializes a new instance of the ActivationInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetControlModeConfigurationResponse Properties

The ConferenceApiHandlerGetControlModeConfigurationResponse type exposes the following members.

Properties
 | Name | Description
Public property | Mode | The control mode.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPackageInfo Constructor

Initializes a new instance of the JsonPackageInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetLanguageGainLevelsResponse Properties

The ConferenceApiHandlerGetLanguageGainLevelsResponse type exposes the following members.

Properties
 | Name | Description
Public property | LanguageGainLevels | The gain levels for all audio available channels on the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNetworkIpAssignmentModeResponse Constructor

ConferenceApiHandlerSetNetworkIpAssignmentModeResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetNetworkIpAssignmentModeResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLoginStatus Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLoginStatus
Syntax
Json
{ JsonClass:JsonLoginStatus		LoggedIn:<type>,
 }

The JsonLoginStatus type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLoginStatus | Initializes a new instance of the JsonLoginStatus class
Top
Properties
 | Name | Description
Public property | LoggedIn |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetPermissionsResponse.Permissions Property

Permissions Property

Permissions list
Syntax
Json
{ Property:Permissions }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioModesList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageAudioModesList
Syntax
Json
{ JsonClass:JsonLanguageAudioModesList		LanguageAudioModes:<type>,
 }

The JsonLanguageAudioModesList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageAudioModesList | Initializes a new instance of the JsonLanguageAudioModesList class
Top
Properties
 | Name | Description
Public property | LanguageAudioModes |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoGet Properties

The JsonUserInfoGet type exposes the following members.

Properties
 | Name | Description
Public property | FirstName |
Public property | LastName |
Public property | Role |
Public property | User |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRegisterFirstUseStateResponse.FirstUseState Property

FirstUseState Property

Indicates whether first time use registration is active or not
Syntax
Json
{ Property:FirstUseState }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetLanguageLabelsRequest Properties

The ConferenceApiHandlerSetLanguageLabelsRequest type exposes the following members.

Properties
 | Name | Description
Public property | LanguageLabels | The list of language labels.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RegisterEventsRequest Properties

The ConferenceApiHandlerRegisterEventsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Events | List of events registered
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSoftwareInfo Properties

The JsonSoftwareInfo type exposes the following members.

Properties
 | Name | Description
Public property | MainVersion |
Public property | ProductVersion |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetStandbyStateResponse Class

ConferenceApiHandlerGetStandbyStateResponse Class

Response from GetStandbyState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetStandbyStateResponse
Syntax
Json
{ JsonClass:GetStandbyStateResponse		Standby:<type>,
 }

The ConferenceApiHandlerGetStandbyStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetStandbyStateResponse | Initializes a new instance of the ConferenceApiHandlerGetStandbyStateResponse class
Top
Properties
 | Name | Description
Public property | Standby | Indicates whether INT-TXO in standby or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegisterFirstUse Properties

The JsonRegisterFirstUse type exposes the following members.

Properties
 | Name | Description
Public property | Password |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageLabelInfo.Label Property

Label Property

The label of the language
Syntax
Json
{ Property:Label }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevel Properties

The JsonLanguageGainLevel type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId |
Public property | Level |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetLogsResponse Properties

The ConferenceApiHandlerGetLogsResponse type exposes the following members.

Properties
 | Name | Description
Public property | Logs | The returned list of logs
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLoginStatus.LoggedIn Property

LoggedIn Property

Syntax
Json
{ Property:LoggedIn }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetStandbyStateRequest Class

ConferenceApiHandlerGetStandbyStateRequest Class

Parameters to GetStandbyState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetStandbyStateRequest
Syntax
Json
{ JsonClass:GetStandbyStateRequest	 }

The ConferenceApiHandlerGetStandbyStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetStandbyStateRequest | Initializes a new instance of the ConferenceApiHandlerGetStandbyStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest.Password Property

Password Property

Password
Syntax
Json
{ Property:Password }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogLevelResponse Constructor

ConferenceApiHandlerGetLogLevelResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetLogLevelResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsResponse Constructor

ConferenceApiHandlerGetLogsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetLogsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterFirstUseRequest Constructor

ConferenceApiHandlerRegisterFirstUseRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterFirstUseRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageGainLevel Class

Describes the settings of the channel gain level
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguageGainLevel
Syntax
Json
{ JsonClass:LanguageGainLevel		LanguageId:<type>,
    Level:<type>,
 }

The LanguageGainLevel type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageGainLevel | Initializes a new instance of the LanguageGainLevel class
Top
Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | Level | Indicates the current audio gain setting
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageMutedStatesResponse Class

ConferenceApiHandlerSetLanguageMutedStatesResponse Class

Response from SetLanguagesMutedState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageMutedStatesResponse
Syntax
Json
{ JsonClass:SetLanguageMutedStatesResponse	 }

The ConferenceApiHandlerSetLanguageMutedStatesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageMutedStatesResponse | Initializes a new instance of the ConferenceApiHandlerSetLanguageMutedStatesResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonVersionInfo Constructor

Initializes a new instance of the JsonVersionInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RestoreConfigurationResponse Class

ConferenceApiHandlerRestoreConfigurationResponse Class

Response from RestoreConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRestoreConfigurationResponse
Syntax
Json
{ JsonClass:RestoreConfigurationResponse	 }

The ConferenceApiHandlerRestoreConfigurationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRestoreConfigurationResponse | Initializes a new instance of the ConferenceApiHandlerRestoreConfigurationResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNetworkInfoRequest Constructor

ConferenceApiHandlerGetNetworkInfoRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetNetworkInfoRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject Constructor

Initializes a new instance of the DisposableObject class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetOperationModeResponse.Mode Property

Mode Property

The operation mode.
Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.CapMacAddr Property

CapMacAddr Property

The MAC-address of the CAP processor of the INT-TXO
Syntax
Json
{ Property:CapMacAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryAudioLevel.DbLevel Property

DbLevel Property

Syntax
Json
{ Property:DbLevel }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LoginRequest Properties

The ConferenceApiHandlerLoginRequest type exposes the following members.

Properties
 | Name | Description
Public property | Password | Password
Public property | User | User name
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInputContactStateResponse Class

ConferenceApiHandlerGetInputContactStateResponse Class

Response from GetInputContactState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetInputContactStateResponse
Syntax
Json
{ JsonClass:GetInputContactStateResponse		Engaged:<type>,
 }

The ConferenceApiHandlerGetInputContactStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetInputContactStateResponse | Initializes a new instance of the ConferenceApiHandlerGetInputContactStateResponse class
Top
Properties
 | Name | Description
Public property | Engaged | Indicates whether input contact on the INT-TXO is engaged or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSourceTypeInfo.LanguageId Property

LanguageId Property

The ID of the language
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPermissions.Permissions Property

Permissions Property

Syntax
Json
{ Property:Permissions }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessage.Parameters Property

Parameters Property

Syntax
Json
{ Property:Parameters }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivateLicenseInfo.ActivationIds Property

ActivationIds Property

Syntax
Json
{ Property:ActivationIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSource.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfo Constructor

Initializes a new instance of the JsonLanguageMutedStateInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSourceTypeInfo.SourceType Property

SourceType Property

The audio source type for the language
Syntax
Json
{ Property:SourceType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest.User Property

User Property

User name
Syntax
Json
{ Property:User }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPermissions Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonPermissions
Syntax
Json
{ JsonClass:JsonPermissions		Permissions:<type>,
 }

The JsonPermissions type exposes the following members.

Constructors
 | Name | Description
Public method | JsonPermissions | Initializes a new instance of the JsonPermissions class
Top
Properties
 | Name | Description
Public property | Permissions |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLicenseInfo.LicenseInfo Property

LicenseInfo Property

Syntax
Json
{ Property:LicenseInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageInputsRequest.LanguageInputs Property

LanguageInputs Property

The list of languages with their input configuration
Syntax
Json
{ Property:LanguageInputs }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNetworkIpAssignmentModeRequest Constructor

ConferenceApiHandlerSetNetworkIpAssignmentModeRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetNetworkIpAssignmentModeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryGainLevelRequest Constructor

ConferenceApiHandlerGetAuxiliaryGainLevelRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryGainLevelRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetHostnameResponse Constructor

ConferenceApiHandlerSetHostnameResponse Constructor

Initializes a new instance of the ConferenceApiHandlerSetHostnameResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourceTypesInfoList Constructor

Initializes a new instance of the JsonLanguageSourceTypesInfoList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ChannelInfo.AudioSlot Property

AudioSlot Property

The number of the carrier's audio slot the channel is allocated to.
Syntax
Json
{ Property:AudioSlot }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryGainLevelResponse.Level Property

Level Property

The gain level of the auxiliary input
Syntax
Json
{ Property:Level }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfo Properties

The JsonLanguageMutedStateInfo type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId |
Public property | Muted |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveUserRequest Class

ConferenceApiHandlerRemoveUserRequest Class

Parameters to RemoveUser
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRemoveUserRequest
Syntax
Json
{ JsonClass:RemoveUserRequest		User:<type>,
 }

The ConferenceApiHandlerRemoveUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRemoveUserRequest | Initializes a new instance of the ConferenceApiHandlerRemoveUserRequest class
Top
Properties
 | Name | Description
Public property | User | The user to remove
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetStandbyStateRequest.Standby Property

Standby Property

Whether INT-TXO is in standby or not
Syntax
Json
{ Property:Standby }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegistrationEvents Constructor

Initializes a new instance of the JsonRegistrationEvents class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo Properties

The JsonLanguagesConfigurationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Channels |
Public property | Label |
Public property | LanguageId |
Public property | Mode |
Public property | SourceInput |
Public property | SourceType |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CustomerRegistrationInfo.Country Property

Country Property

The country of the customer
Syntax
Json
{ Property:Country }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageDistributionInfo Constructor

Initializes a new instance of the LanguageDistributionInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemModeRequest Class

ConferenceApiHandlerGetSystemModeRequest Class

Parameters to GetSystemMode
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetSystemModeRequest
Syntax
Json
{ JsonClass:GetSystemModeRequest	 }

The ConferenceApiHandlerGetSystemModeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetSystemModeRequest | Initializes a new instance of the ConferenceApiHandlerGetSystemModeRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddUserResponse Constructor

ConferenceApiHandlerAddUserResponse Constructor

Initializes a new instance of the ConferenceApiHandlerAddUserResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetCarriersStateResponse Class

ConferenceApiHandlerSetCarriersStateResponse Class

Response from SetCarriersState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetCarriersStateResponse
Syntax
Json
{ JsonClass:SetCarriersStateResponse	 }

The ConferenceApiHandlerSetCarriersStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetCarriersStateResponse | Initializes a new instance of the ConferenceApiHandlerSetCarriersStateResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfo.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSoftwareInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonSoftwareInfo
Syntax
Json
{ JsonClass:JsonSoftwareInfo		MainVersion:<type>,
    ProductVersion:<type>,
 }

The JsonSoftwareInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonSoftwareInfo | Initializes a new instance of the JsonSoftwareInfo class
Top
Properties
 | Name | Description
Public property | MainVersion |
Public property | ProductVersion |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RadiatorInfo Class

Describes the status of a radiator
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientRadiatorInfo
Syntax
Json
{ JsonClass:RadiatorInfo		HasError:<type>,
    IsPresent:<type>,
    RadiatorId:<type>,
 }

The RadiatorInfo type exposes the following members.

Constructors
 | Name | Description
Public method | RadiatorInfo | Initializes a new instance of the RadiatorInfo class
Top
Properties
 | Name | Description
Public property | HasError | Indicates whether the radiator is in error state
Public property | IsPresent | Indicates whether the radiator is connected to the transmitter
Public property | RadiatorId | The ID of the radiator
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCustomerInfo Properties

The JsonCustomerInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address |
Public property | City |
Public property | Country |
Public property | CustomerName |
Public property | LocationName |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetLanguageGainLevelsRequest Properties

The ConferenceApiHandlerSetLanguageGainLevelsRequest type exposes the following members.

Properties
 | Name | Description
Public property | LanguageGainLevels | The list of channels and the channel gain levels needs to be set to
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetUsersResponse Constructor

ConferenceApiHandlerGetUsersResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetUsersResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageGainLevel Properties

The LanguageGainLevel type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | Level | Indicates the current audio gain setting
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageLabelInfo
Syntax
Json
{ JsonClass:JsonLanguageLabelInfo		Label:<type>,
    LanguageId:<type>,
 }

The JsonLanguageLabelInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageLabelInfo | Initializes a new instance of the JsonLanguageLabelInfo class
Top
Properties
 | Name | Description
Public property | Label |
Public property | LanguageId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.MainMacAddr Property

MainMacAddr Property

The MAC-address of the main processor of the INT-TXO
Syntax
Json
{ Property:MainMacAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfo Properties

The JsonRadiatorInfo type exposes the following members.

Properties
 | Name | Description
Public property | HasError |
Public property | IsPresent |
Public property | RadiatorId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryActivation.Active Property

Active Property

Syntax
Json
{ Property:Active }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread.WorkItemQueue.Enqueue Method

Enqueue Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


JsonTcpIpSettings.SubnetMask Property

SubnetMask Property

Syntax
Json
{ Property:SubnetMask }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveUserRequest.User Property

User Property

The user to remove
Syntax
Json
{ Property:User }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetVersionInfoResponse Properties

The ConferenceApiHandlerGetVersionInfoResponse type exposes the following members.

Properties
 | Name | Description
Public property | VersionInfo | The various software versions on the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateLicensesRequest Properties

The ConferenceApiHandlerActivateLicensesRequest type exposes the following members.

Properties
 | Name | Description
Public property | ActivationIds | The list of activation ID's requested
Public property | Dictionary | The information of the customer activating the license(s)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InstalledLicense Class

Describes the license
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientInstalledLicense
Syntax
Json
{ JsonClass:InstalledLicense		ActivationDate:<type>,
    ExpirationDate:<type>,
    FeatureName:<type>,
    Quantity:<type>,
 }

The InstalledLicense type exposes the following members.

Constructors
 | Name | Description
Public method | InstalledLicense | Initializes a new instance of the InstalledLicense class
Top
Properties
 | Name | Description
Public property | ActivationDate | The activation date of the license
Public property | ExpirationDate | The expiratiom date of the license
Public property | FeatureName | The name of the licensed feature
Public property | Quantity | The number of licenses
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UnregisterEventsResponse Constructor

ConferenceApiHandlerUnregisterEventsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerUnregisterEventsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoGet.LastName Property

LastName Property

Syntax
Json
{ Property:LastName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateLicensesResponse Class

ConferenceApiHandlerActivateLicensesResponse Class

Response for activating licenses
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerActivateLicensesResponse
Syntax
Json
{ JsonClass:ActivateLicensesResponse		Package:<type>,
 }

The ConferenceApiHandlerActivateLicensesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerActivateLicensesResponse | Initializes a new instance of the ConferenceApiHandlerActivateLicensesResponse class
Top
Properties
 | Name | Description
Public property | Package | The Base64 encoded binary string containing the activation request file information.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageMutedStatesRequest Constructor

ConferenceApiHandlerSetLanguageMutedStatesRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetLanguageMutedStatesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetHostnameRequest.Hostname Property

Hostname Property

New hostname to set
Syntax
Json
{ Property:Hostname }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RemoveUserRequest Properties

The ConferenceApiHandlerRemoveUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | User | The user to remove
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetStandbyStateResponse Properties

The ConferenceApiHandlerGetStandbyStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | Standby | Indicates whether INT-TXO in standby or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo Constructor

Initializes a new instance of the NetworkInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer Class

Inheritance Hierarchy
SystemObject
System.ThreadingSynchronizationContext
TxoConferenceApi.OperationalSynchronizer
Syntax
Json
{ JsonClass:Synchronizer	 }

The Synchronizer type exposes the following members.

Constructors
 | Name | Description
 | Synchronizer |
Public method | Synchronizer | Initializes a new instance of the Synchronizer class
Public method | Synchronizer(String) | Initializes a new instance of the Synchronizer class
Top
Methods
 | Name | Description
Public method | CreateCopy | (Overrides SynchronizationContextCreateCopy.)
Public method | Dispose | Releases all resources used by the Synchronizer
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Synchronizer and optionally releases the managed resources
Public method | IsWaitNotificationRequired | Determines if wait notification is required. (Inherited from SynchronizationContext.)
Public method | OperationCompleted | When overridden in a derived class, responds to the notification that an operation has completed. (Inherited from SynchronizationContext.)
Public method | OperationStarted | When overridden in a derived class, responds to the notification that an operation has started. (Inherited from SynchronizationContext.)
Public method | Post | (Overrides SynchronizationContextPost(SendOrPostCallback, Object).)
Public method | Send | (Overrides SynchronizationContextSend(SendOrPostCallback, Object).)
Protected method | SetWaitNotificationRequired | Sets notification that wait notification is required and prepares the callback method so it can be called more reliably when a wait occurs. (Inherited from SynchronizationContext.)
Public method | Wait | Waits for any or all the elements in the specified array to receive a signal. (Inherited from SynchronizationContext.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RestoreConfigurationRequest Constructor

ConferenceApiHandlerRestoreConfigurationRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRestoreConfigurationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonChannelInfo
Syntax
Json
{ JsonClass:JsonChannelInfo		AudioSlot:<type>,
    CarrierId:<type>,
    ChannelId:<type>,
 }

The JsonChannelInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonChannelInfo | Initializes a new instance of the JsonChannelInfo class
Top
Properties
 | Name | Description
Public property | AudioSlot |
Public property | CarrierId |
Public property | ChannelId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioLevel.Channels Property

Channels Property

The list of allocated channels and the corresponding audio level in decibels.
Syntax
Json
{ Property:Channels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAudioChannelLevel.DbLevel Property

DbLevel Property

Syntax
Json
{ Property:DbLevel }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TxoConferenceApi.Common Namespace

Classes
 | Class | Description
Public class | DisposableObject |
Enumerations
 | Enumeration | Description
Public enumeration | AudioMode | The audio mode for all supported audio channels
Public enumeration | AudioQuality | The audio qualities for all supported audio channels
Public enumeration | AudioSourceType | The type of audio source
Public enumeration | ConferenceEvent | Events that the server can fire to the clients
Public enumeration | ControlMode | Defines the operational control mode
Public enumeration | EventLevel | The list of loglevels supported
Public enumeration | OperationMode | Defines the master or slave operation mode
Public enumeration | Permission | Defines user permissions
Public enumeration | Roles | Defines user roles
Public enumeration | SystemMode | Defines system mode
Public enumeration | TcpIpSetting | The network address assignent setting of a network


GetLanguageMutedStatesResponse Properties

The ConferenceApiHandlerGetLanguageMutedStatesResponse type exposes the following members.

Properties
 | Name | Description
Public property | LanguageMutedStates | The mute state for list of languages
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetControlModeConfigurationResponse Class

ConferenceApiHandlerGetControlModeConfigurationResponse Class

 Bosch Logo
Response from GetControlModeConfiguration
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetControlModeConfigurationResponse
Syntax
Json
{ JsonClass:GetControlModeConfigurationResponse		Mode:<type>,
 }

The ConferenceApiHandlerGetControlModeConfigurationResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetControlModeConfigurationResponse | Initializes a new instance of the ConferenceApiHandlerGetControlModeConfigurationResponse class
Top
Properties
 | Name | Description
Public property | Mode | The control mode.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageMutedStateInfo Class

Defines muted state of a language
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguageMutedStateInfo
Syntax
Json
{ JsonClass:LanguageMutedStateInfo		LanguageId:<type>,
    Muted:<type>,
 }

The LanguageMutedStateInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageMutedStateInfo | Initializes a new instance of the LanguageMutedStateInfo class
Top
Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | Muted | The muted state for the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVersionInfoResponse Class

ConferenceApiHandlerGetVersionInfoResponse Class

Response from GetVersionInfo
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetVersionInfoResponse
Syntax
Json
{ JsonClass:GetVersionInfoResponse		VersionInfo:<type>,
 }

The ConferenceApiHandlerGetVersionInfoResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVersionInfoResponse | Initializes a new instance of the ConferenceApiHandlerGetVersionInfoResponse class
Top
Properties
 | Name | Description
Public property | VersionInfo | The various software versions on the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


BackupConfigurationResponse Properties

The ConferenceApiHandlerBackupConfigurationResponse type exposes the following members.

Properties
 | Name | Description
Public property | Package | A binary blob
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserCredentials Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonUserCredentials
Syntax
Json
{ JsonClass:JsonUserCredentials		Password:<type>,
    Username:<type>,
 }

The JsonUserCredentials type exposes the following members.

Constructors
 | Name | Description
Public method | JsonUserCredentials | Initializes a new instance of the JsonUserCredentials class
Top
Properties
 | Name | Description
Public property | Password |
Public property | Username |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo Class

Describes the information of the network
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientNetworkInfo
Syntax
Json
{ JsonClass:NetworkInfo		CapIpAddr:<type>,
    CapMacAddr:<type>,
    DeviceName:<type>,
    Gateway:<type>,
    Hostname:<type>,
    IpAssignmentMode:<type>,
    MainIpAddr:<type>,
    MainMacAddr:<type>,
    Rstp:<type>,
    SerialNumber:<type>,
    SubnetMask:<type>,
 }

The NetworkInfo type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInfo | Initializes a new instance of the NetworkInfo class
Top
Properties
 | Name | Description
Public property | CapIpAddr | The IP-address of the CAP processor of the INT-TXO
Public property | CapMacAddr | The MAC-address of the CAP processor of the INT-TXO
Public property | DeviceName | The device name of the INT-TXO
Public property | Gateway | The default gateway of the INT-TXO
Public property | Hostname | The hostname of the INT-TXO
Public property | IpAssignmentMode | The network address assignent setting of a network
Public property | MainIpAddr | The IP-address of the main processor of the INT-TXO
Public property | MainMacAddr | The MAC-address of the main processor of the INT-TXO
Public property | Rstp | Indicates whether the RSTP protocol is enabled/disabled on the INT-TXO
Public property | SerialNumber | The serial number of the INT-TXO
Public property | SubnetMask | The Subnet Mask of the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfo Properties

The JsonLanguageLabelInfo type exposes the following members.

Properties
 | Name | Description
Public property | Label |
Public property | LanguageId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ChangeOwnPasswordResponse Class

ConferenceApiHandlerChangeOwnPasswordResponse Class

Response from changeOwnPassword
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerChangeOwnPasswordResponse
Syntax
Json
{ JsonClass:ChangeOwnPasswordResponse	 }

The ConferenceApiHandlerChangeOwnPasswordResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerChangeOwnPasswordResponse | Initializes a new instance of the ConferenceApiHandlerChangeOwnPasswordResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNetworkIpAssignmentModeResponse Class

ConferenceApiHandlerSetNetworkIpAssignmentModeResponse Class

Response from SetNetworkIpAssignmentMode
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetNetworkIpAssignmentModeResponse
Syntax
Json
{ JsonClass:SetNetworkIpAssignmentModeResponse	 }

The ConferenceApiHandlerSetNetworkIpAssignmentModeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetNetworkIpAssignmentModeResponse | Initializes a new instance of the ConferenceApiHandlerSetNetworkIpAssignmentModeResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InstalledLicense.Quantity Property

Quantity Property

The number of licenses
Syntax
Json
{ Property:Quantity }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryMutedState.Muted Property

Muted Property

Syntax
Json
{ Property:Muted }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateLicensesRequest Constructor

ConferenceApiHandlerActivateLicensesRequest Constructor

Initializes a new instance of the ConferenceApiHandlerActivateLicensesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageDistributionInfo.NumberOfReceivedLanguages Property

NumberOfReceivedLanguages Property

Syntax
Json
{ Property:NumberOfReceivedLanguages }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetStandbyStateResponse Class

ConferenceApiHandlerSetStandbyStateResponse Class

Response from SetStandbyState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetStandbyStateResponse
Syntax
Json
{ JsonClass:SetStandbyStateResponse	 }

The ConferenceApiHandlerSetStandbyStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetStandbyStateResponse | Initializes a new instance of the ConferenceApiHandlerSetStandbyStateResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageInputsRequest Constructor

ConferenceApiHandlerSetLanguageInputsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetLanguageInputsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ProcessLicensePackageRequest.Package Property

Package Property

The package to process.
Syntax
Json
{ Property:Package }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserCredentials Properties

The JsonUserCredentials type exposes the following members.

Properties
 | Name | Description
Public property | Password |
Public property | Username |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyScheduleInfo Constructor

Initializes a new instance of the JsonStandbyScheduleInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ApiAudioLevelsUpdateReceived Event

ApiAudioLevelsUpdateReceived Event

Syntax
Json
{ Event:ApiAudioLevelsUpdateReceived }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetDicentisConnectionStateResponse Properties

The ConferenceApiHandlerGetDicentisConnectionStateResponse type exposes the following members.

Properties
 | Name | Description
Public property | Connected | The state of the connection with the DICENTIS system
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsResponse Class

ConferenceApiHandlerRegisterEventsResponse Class

Response from RegisterEvents
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRegisterEventsResponse
Syntax
Json
{ JsonClass:RegisterEventsResponse	 }

The ConferenceApiHandlerRegisterEventsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterEventsResponse | Initializes a new instance of the ConferenceApiHandlerRegisterEventsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegisterFirstUseState Constructor

Initializes a new instance of the JsonRegisterFirstUseState class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNumberOfLanguagesLimitResponse.Limit Property

Limit Property

Indicates maximum number of languages to transmit
Syntax
Json
{ Property:Limit }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguagesConfigurationInfo.Mode Property

Mode Property

Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoGet Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonUserInfoGet
TxoConferenceApi.MessagesJsonUserInfoPut
Syntax
Json
{ JsonClass:JsonUserInfoGet		FirstName:<type>,
    LastName:<type>,
    Role:<type>,
    User:<type>,
 }

The JsonUserInfoGet type exposes the following members.

Constructors
 | Name | Description
Public method | JsonUserInfoGet | Initializes a new instance of the JsonUserInfoGet class
Top
Properties
 | Name | Description
Public property | FirstName |
Public property | LastName |
Public property | Role |
Public property | User |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageAudioLevelsList Properties

The JsonMessageAudioLevelsList type exposes the following members.

Properties
 | Name | Description
Public property | Auxiliary |
Public property | Languages |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonOperationMode Properties

The JsonOperationMode type exposes the following members.

Properties
 | Name | Description
Public property | Mode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TcpIpProperties.MainIpAddr Property

MainIpAddr Property

The IP-address of the main processor
Syntax
Json
{ Property:MainIpAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetSystemModeRequest Constructor

ConferenceApiHandlerGetSystemModeRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetSystemModeRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CustomerRegistrationInfo Properties

The CustomerRegistrationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Address | The address of the customer
Public property | City | The city of the customer
Public property | Country | The country of the customer
Public property | CustomerName | The name of the customer
Public property | LocationName | The location information of the customer
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuxiliaryAudioLevel Constructor

Initializes a new instance of the AuxiliaryAudioLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserCredentials Constructor

Initializes a new instance of the JsonUserCredentials class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItem Methods

The WorkItem type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Protected method | DoWork |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCount Constructor

Initializes a new instance of the JsonCount class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MessageAudioLevelsList Constructor

Initializes a new instance of the MessageAudioLevelsList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.DeviceName Property

DeviceName Property

Syntax
Json
{ Property:DeviceName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSource.SourceInput Property

SourceInput Property

The input source allocated to the language
Syntax
Json
{ Property:SourceInput }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TcpIpProperties Class

Defines the IP-settings of a network
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientTcpIpProperties
Syntax
Json
{ JsonClass:TcpIpProperties		CapIpAddr:<type>,
    Gateway:<type>,
    MainIpAddr:<type>,
    SubnetMask:<type>,
 }

The TcpIpProperties type exposes the following members.

Constructors
 | Name | Description
Public method | TcpIpProperties | Initializes a new instance of the TcpIpProperties class
Top
Properties
 | Name | Description
Public property | CapIpAddr | The IP-address of the CAP processor
Public property | Gateway | The default gateway
Public property | MainIpAddr | The IP-address of the main processor
Public property | SubnetMask | The Subnet mask
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPermissions Constructor

Initializes a new instance of the JsonPermissions class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioMode.LanguageId Property

LanguageId Property

The ID of the language
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetManualNetworkIpSettingsRequest Constructor

ConferenceApiHandlerSetManualNetworkIpSettingsRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetManualNetworkIpSettingsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfo.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo Properties

The LanguagesConfigurationInfo type exposes the following members.

Properties
 | Name | Description
Public property | Channels | The channels allocated to the language
Public property | Enabled | Indicates if the channel is enabled or not
Public property | Label | The label of the language
Public property | LanguageId | The ID of the language
Public property | Mode | Indicates the audio mode for the language
Public property | SourceInput | The source input for the language, applicable when SourceType is Dicentis
Public property | SourceType | Indicates the audio source type for the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonDicentisConnectionState Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonDicentisConnectionState
Syntax
Json
{ JsonClass:JsonDicentisConnectionState		Connected:<type>,
 }

The JsonDicentisConnectionState type exposes the following members.

Constructors
 | Name | Description
Public method | JsonDicentisConnectionState | Initializes a new instance of the JsonDicentisConnectionState class
Top
Properties
 | Name | Description
Public property | Connected |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoList.Users Property

Users Property

Syntax
Json
{ Property:Users }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkerThread Properties

The WorkerThread type exposes the following members.

Properties
 | Name | Description
Private property | EndLoop |
Public property | ManagedThreadId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetUsersResponse.Users Property

Users Property

The information for all users registered on the INT-TXO
Syntax
Json
{ Property:Users }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLogLevelRequest.LogLevel Property

LogLevel Property

Syntax
Json
{ Property:LogLevel }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


EventLevel Enumeration

The list of loglevels supported
Syntax
Json
EventLevel:{
Default
Trace
Info
Warning
Error}
Members
Member name | Value | Description
Default | 0 | The default loglevel
Trace | 1 | The loglevel for traces
Info | 2 | The loglevel for informationals
Warning | 3 | The loglevel for warnings
Error | 4 | The loglevel for errors
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject Properties

The DisposableObject type exposes the following members.

Properties
 | Name | Description
Protected property | Disposed |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonPhysicalNetworkInfo
Syntax
Json
{ JsonClass:JsonPhysicalNetworkInfo		CapIpAddr:<type>,
    CapMacAddr:<type>,
    DeviceName:<type>,
    Gateway:<type>,
    Hostname:<type>,
    IpAssignmentMode:<type>,
    MainIpAddr:<type>,
    MainMacAddr:<type>,
    Rstp:<type>,
    SerialNumber:<type>,
    SubnetMask:<type>,
 }

The JsonPhysicalNetworkInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonPhysicalNetworkInfo | Initializes a new instance of the JsonPhysicalNetworkInfo class
Top
Properties
 | Name | Description
Public property | CapIpAddr |
Public property | CapMacAddr |
Public property | DeviceName |
Public property | Gateway |
Public property | Hostname |
Public property | IpAssignmentMode |
Public property | MainIpAddr |
Public property | MainMacAddr |
Public property | Rstp |
Public property | SerialNumber |
Public property | SubnetMask |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateLicenseInfo Constructor

Initializes a new instance of the ActivateLicenseInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRegisterFirstUseStateResponse Class

ConferenceApiHandlerGetRegisterFirstUseStateResponse Class

Response from GetRegisterFirstUseState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetRegisterFirstUseStateResponse
Syntax
Json
{ JsonClass:GetRegisterFirstUseStateResponse		FirstUseState:<type>,
 }

The ConferenceApiHandlerGetRegisterFirstUseStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetRegisterFirstUseStateResponse | Initializes a new instance of the ConferenceApiHandlerGetRegisterFirstUseStateResponse class
Top
Properties
 | Name | Description
Public property | FirstUseState | Indicates whether first time use registration is active or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetNetworkIpAssignmentModeRequest Properties

The ConferenceApiHandlerSetNetworkIpAssignmentModeRequest type exposes the following members.

Properties
 | Name | Description
Public property | IpAssignmentMode | Indicates whether IP-addresses are assigned automatically (DHCP) or manual
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LogoutResponse Class

ConferenceApiHandlerLogoutResponse Class

Logout response
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerLogoutResponse
Syntax
Json
{ JsonClass:LogoutResponse	 }

The ConferenceApiHandlerLogoutResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLogoutResponse | Initializes a new instance of the ConferenceApiHandlerLogoutResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfo.Label Property

Label Property

Syntax
Json
{ Property:Label }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivateLicenseInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonActivateLicenseInfo
Syntax
Json
{ JsonClass:JsonActivateLicenseInfo		ActivationIds:<type>,
    Dictionary:<type>,
 }

The JsonActivateLicenseInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonActivateLicenseInfo | Initializes a new instance of the JsonActivateLicenseInfo class
Top
Properties
 | Name | Description
Public property | ActivationIds |
Public property | Dictionary |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDicentisConnectionStateRequest Class

ConferenceApiHandlerGetDicentisConnectionStateRequest Class

Parameters to GetDicentisConnectionState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetDicentisConnectionStateRequest
Syntax
Json
{ JsonClass:GetDicentisConnectionStateRequest	 }

The ConferenceApiHandlerGetDicentisConnectionStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetDicentisConnectionStateRequest | Initializes a new instance of the ConferenceApiHandlerGetDicentisConnectionStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChangeOwnPassword Properties

The JsonChangeOwnPassword type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPassword |
Public property | NewPassword |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourcesList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageSourcesList
Syntax
Json
{ JsonClass:JsonLanguageSourcesList		LanguageInputs:<type>,
 }

The JsonLanguageSourcesList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageSourcesList | Initializes a new instance of the JsonLanguageSourcesList class
Top
Properties
 | Name | Description
Public property | LanguageInputs |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer.Dispose Method

Dispose Method

Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Synchronizer
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Synchronizer and optionally releases the managed resources
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioMode Constructor

Initializes a new instance of the JsonLanguageAudioMode class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ChannelInfo.ChannelId Property

ChannelId Property

The ID of the channel.
Syntax
Json
{ Property:ChannelId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LogoutRequest Constructor

ConferenceApiHandlerLogoutRequest Constructor

Initializes a new instance of the ConferenceApiHandlerLogoutRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNumberOfLanguagesLimit Properties

The JsonNumberOfLanguagesLimit type exposes the following members.

Properties
 | Name | Description
Public property | Limit |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonQualityConfiguration Constructor

Initializes a new instance of the JsonQualityConfiguration class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VersionInfo Class

Describes the software versions
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientVersionInfo
Syntax
Json
{ JsonClass:VersionInfo		MainVersion:<type>,
    OmneoVersion:<type>,
    ProductVersion:<type>,
 }

The VersionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | VersionInfo | Initializes a new instance of the VersionInfo class
Top
Properties
 | Name | Description
Public property | MainVersion | The main software version of the INT-TXO
Public property | OmneoVersion | The OMNEO software version
Public property | ProductVersion | The DICENTIS software version
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSetHostname Properties

The JsonSetHostname type exposes the following members.

Properties
 | Name | Description
Public property | Hostname |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterAudioLevelsResponse Constructor

ConferenceApiHandlerRegisterAudioLevelsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterAudioLevelsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryMutedStateResponse Class

ConferenceApiHandlerGetAuxiliaryMutedStateResponse Class

Response from GetAuxiliaryMutedState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetAuxiliaryMutedStateResponse
Syntax
Json
{ JsonClass:GetAuxiliaryMutedStateResponse		Muted:<type>,
 }

The ConferenceApiHandlerGetAuxiliaryMutedStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetAuxiliaryMutedStateResponse | Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryMutedStateResponse class
Top
Properties
 | Name | Description
Public property | Muted | Indicates whether the analog auxiliary input is muted or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo.SourceType Property

SourceType Property

Indicates the audio source type for the language
Syntax
Json
{ Property:SourceType }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPackageInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonPackageInfo
Syntax
Json
{ JsonClass:JsonPackageInfo		Package:<type>,
 }

The JsonPackageInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonPackageInfo | Initializes a new instance of the JsonPackageInfo class
Top
Properties
 | Name | Description
Public property | Package |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RadiatorInfo Constructor

Initializes a new instance of the RadiatorInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo.LanguageId Property

LanguageId Property

The ID of the language
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageInputsResponse Class

ConferenceApiHandlerSetLanguageInputsResponse Class

Response from SetLanguageInputs
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageInputsResponse
Syntax
Json
{ JsonClass:SetLanguageInputsResponse	 }

The ConferenceApiHandlerSetLanguageInputsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageInputsResponse | Initializes a new instance of the ConferenceApiHandlerSetLanguageInputsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet Constructor

Default constructor
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfoList Constructor

Initializes a new instance of the JsonRadiatorInfoList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioMode Properties

The JsonLanguageAudioMode type exposes the following members.

Properties
 | Name | Description
Public property | LanguageId |
Public property | Mode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNumberOfLanguagesLimit.Limit Property

Limit Property

Syntax
Json
{ Property:Limit }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageSource Class

Defines the audio source input of a language
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguageSource
Syntax
Json
{ JsonClass:LanguageSource		LanguageId:<type>,
    SourceInput:<type>,
 }

The LanguageSource type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageSource | Initializes a new instance of the LanguageSource class
Top
Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | SourceInput | The input source allocated to the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ProcessLicensePackageRequest Class

ConferenceApiHandlerProcessLicensePackageRequest Class

Request for processing the license package
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerProcessLicensePackageRequest
Syntax
Json
{ JsonClass:ProcessLicensePackageRequest		Package:<type>,
 }

The ConferenceApiHandlerProcessLicensePackageRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerProcessLicensePackageRequest | Initializes a new instance of the ConferenceApiHandlerProcessLicensePackageRequest class
Top
Properties
 | Name | Description
Public property | Package | The package to process.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVersionInfoResponse.VersionInfo Property

VersionInfo Property

The various software versions on the INT-TXO
Syntax
Json
{ Property:VersionInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InstalledLicense Properties

The InstalledLicense type exposes the following members.

Properties
 | Name | Description
Public property | ActivationDate | The activation date of the license
Public property | ExpirationDate | The expiratiom date of the license
Public property | FeatureName | The name of the licensed feature
Public property | Quantity | The number of licenses
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkIpSettings Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonNetworkIpSettings
Syntax
Json
{ JsonClass:JsonNetworkIpSettings		Settings:<type>,
 }

The JsonNetworkIpSettings type exposes the following members.

Constructors
 | Name | Description
Public method | JsonNetworkIpSettings | Initializes a new instance of the JsonNetworkIpSettings class
Top
Properties
 | Name | Description
Public property | Settings |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetQualityConfigurationRequest Constructor

ConferenceApiHandlerSetQualityConfigurationRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetQualityConfigurationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsRequest Constructor

ConferenceApiHandlerRegisterEventsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterEventsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageLabelInfoList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageLabelInfoList
Syntax
Json
{ JsonClass:JsonLanguageLabelInfoList		LanguageLabels:<type>,
 }

The JsonLanguageLabelInfoList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageLabelInfoList | Initializes a new instance of the JsonLanguageLabelInfoList class
Top
Properties
 | Name | Description
Public property | LanguageLabels |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterAudioLevelsRequest Class

ConferenceApiHandlerRegisterAudioLevelsRequest Class

Parameters to RegisterAudioLevels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRegisterAudioLevelsRequest
Syntax
Json
{ JsonClass:RegisterAudioLevelsRequest	 }

The ConferenceApiHandlerRegisterAudioLevelsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterAudioLevelsRequest | Initializes a new instance of the ConferenceApiHandlerRegisterAudioLevelsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessage Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonMessage
Syntax
Json
{ JsonClass:JsonMessage		MessageId:<type>,
    Operation:<type>,
    Parameters:<type>,
 }

The JsonMessage type exposes the following members.

Constructors
 | Name | Description
Public method | JsonMessage | Initializes a new instance of the JsonMessage class
Top
Properties
 | Name | Description
Public property | MessageId |
Public property | Operation |
Public property | Parameters |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLicensesResponse Constructor

ConferenceApiHandlerGetLicensesResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetLicensesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryGainLevelResponse Class

ConferenceApiHandlerGetAuxiliaryGainLevelResponse Class

Response from getting auxiliary gain level
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetAuxiliaryGainLevelResponse
Syntax
Json
{ JsonClass:GetAuxiliaryGainLevelResponse		Level:<type>,
 }

The ConferenceApiHandlerGetAuxiliaryGainLevelResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetAuxiliaryGainLevelResponse | Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryGainLevelResponse class
Top
Properties
 | Name | Description
Public property | Level | The gain level of the auxiliary input
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInputContactState Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonInputContactState
Syntax
Json
{ JsonClass:JsonInputContactState		Engaged:<type>,
 }

The JsonInputContactState type exposes the following members.

Constructors
 | Name | Description
Public method | JsonInputContactState | Initializes a new instance of the JsonInputContactState class
Top
Properties
 | Name | Description
Public property | Engaged |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInputContactState Properties

The JsonInputContactState type exposes the following members.

Properties
 | Name | Description
Public property | Engaged |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonActivateLicenseInfo Constructor

Initializes a new instance of the JsonActivateLicenseInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioMode.Mode Property

Mode Property

Indicates the audio mode for the channel
Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


RegisterFirstUseRequest Properties

The ConferenceApiHandlerRegisterFirstUseRequest type exposes the following members.

Properties
 | Name | Description
Public property | Password | New password for Admin user upon first-time registration.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRegisterFirstUseStateRequest Class

ConferenceApiHandlerGetRegisterFirstUseStateRequest Class

Parameters to GetRegisterFirstUseState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetRegisterFirstUseStateRequest
Syntax
Json
{ JsonClass:GetRegisterFirstUseStateRequest	 }

The ConferenceApiHandlerGetRegisterFirstUseStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetRegisterFirstUseStateRequest | Initializes a new instance of the ConferenceApiHandlerGetRegisterFirstUseStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryGainLevelResponse Constructor

ConferenceApiHandlerGetAuxiliaryGainLevelResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryGainLevelResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelConfigurationInfoList Constructor

Initializes a new instance of the JsonChannelConfigurationInfoList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfoList Properties

The JsonCarrierInfoList type exposes the following members.

Properties
 | Name | Description
Public property | CarriersInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfoList.CarriersInfo Property

CarriersInfo Property

Syntax
Json
{ Property:CarriersInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler Methods

The ConferenceApiHandler type exposes the following members.

Methods
 | Name | Description
Public method | ActivateAuxiliary | Activates the analog auxiliary input
Public method | ActivateLicenses | Issues a request to activate license(s)
Public method | AddUser | Adds a user
Public method | BackupConfiguration | Gets the current Configuration file on device
Public method | ChangeOwnPassword | Change the password of the logged in user
Protected method | CleanupUnmanagedResources | (Inherited from DisposableObject.)
Public method | Dispose | (Inherited from DisposableObject.)
Public method | EnableTestTones | Enables testtones to all channels. Is not possible to enable testtones when 'slave' mode or 'auxiliary' mode is active
Protected method | Finalize | (Inherited from DisposableObject.)
Public method | GetAuxiliaryGainLevel | Gets the auxiliary gain level.
Public method | GetAuxiliaryMutedState | Gets the analog auxiliary active state
Public method | GetAuxiliaryState | Gets the analog auxiliary active state
Public method | GetCarriersState | Gets the enabled state of the carriers
Public method | GetControlModeConfiguration | Gets the currently configured Standalone or DICENTIS mode of the INT-TXO.
Public method | GetDateTime | Gets the local date and time as single string in iso-8601 format (yyyy-MM-ddTHH:mm:ss)
Public method | GetDicentisConnectionState | Gets the state of the connection with the DICENTIS system
Public method | GetEnableTestTones | Gets the enabled state of testtones to all channels
Public method | GetInputContactState | Gets the input contact state of the transmitter
Public method | GetLanguageDistributionInfo | Gets Language Distribution Info
Public method | GetLanguageGainLevels | Gets the channel gain levels.
Public method | GetLanguageMutedStates | Gets the muted state of the languages
Public method | GetLanguagesConfiguration | Gets the overall language, channel and carrier configuration for routing audio. Returns the current transmitted language configuration, including to which carrier the channels for the language are allocated. The sourceInput indicates which Dicentis language with languageId matching the sourceInput is being received and transmitted to the receiver. The sourceInput is ignored for Dante languages.
Public method | GetLatestLogs | This function gets the latest logs from the INT-TXO starting from the moment this function was last called
Public method | GetLicenses | Gets the installed licenses on the device
Public method | GetLoginStatus | Gets the login status
Public method | GetLogLevel | This function gets the loglevel set on the INT-TXO
Public method | GetLogs | This function gets all logs available on the INT-TXO
Public method | GetLogsTail | This function gets last count of logs from the eventlog on the INT-TXO
Public method | GetNetworkInfo | Gets the network information
Public method | GetNumberOfLanguagesLimit | Gets the configured maximum number of languages to transmit
Public method | GetOperationMode | Gets the master/slave operation mode
Public method | GetPermissions | Gets the permissions of the logged-in user
Public method | GetQualityConfiguration | Gets the overall channel quality configuration setting
Public method | GetRadiatorsState | Gets the radiators state connected to the INT-TXO
Public method | GetRegisterFirstUseState | Gets the state of registering for first use
Public method | GetStandbyState | Gets the standby state of the transmitter
Public method | GetSystemMode | Gets the current system mode the INT-TXO is in.
Public method | GetUsers | Gets the users
Public method | GetVersionInfo | Gets the version information
Public method | Login | Logs in the user
Public method | Logout | Logs the user out
Public method | ProcessLicensePackage | Issues a request to process a license response package
Public method | Reboot | Triggers an unconditional reboot of the transmitter
Public method | RegisterAudioLevels | This functions allows to register for audio level updates for the channels.
Public method | RegisterEvents | This function allows to register for events (e.g.: The number of active channels changed or permissions changed) of which the current data needs to be requested, whenever the event is triggered
Public method | RegisterFirstUse | Registers first use
Public method | RemoveUser | Removes a user
Public method | ResetToFactoryDefault | Resets the transmitter to its factory defaults
Public method | RestoreConfiguration | Restore configuration data retrieved with 'backupConfiguration'
Public method | SetAuxiliaryGainLevel | This function allows to set the gain level of the auxiliary input, valid values between -12dB and 12dB in steps of 0.5dB
Public method | SetAuxiliaryMutedState | This function allows to set the muted state of the auxiliary input
Public method | SetCarriersState | Sets the carriers state connected to the INT-TXO
Public method | SetControlMode | Sets the control mode of the INT-TXO. The control mode configuration setting is stored persistently in the INT-TXO's configuration. The operational state of the control mode will only change when the current state of the INT-TXO allows for it.
Public method | SetDateTime | Sets the current local date and time as single string in iso-8601 format (yyyy-MM-ddTHH:mm:ss)
Public method | SetHostname | Change the hostname of the INT-TXO
Public method | SetLanguageAudioModes | This functions sets the audio mode for the given list of languages.
Public method | SetLanguageGainLevels | This function allows to set the gain level of the given set of languages, valid values between -12dB and 12dB in steps of 0.5dB
Public method | SetLanguageInputs | This function sets the source input configuration for the given list languages. For a language definition with 'languageId', sets a Dicentis language languageId as 'sourceInput'. The Dicentis language configured as 'sourceInput' will then be receive and transmitted to the receiver. The default value of a sourceInput equals the languageId.The sourceInput is only valid/used for Dicentis languages.
Public method | SetLanguageLabels | This function sets thelabels for the given list of languages.
Public method | SetLanguageMutedStates | This function sets the muted state for the given list of languages.
Public method | SetLanguageSourceTypes | This function sets the source types for the given list of languages.
Public method | SetLogLevel | This function sets the loglevel on the INT-TXO
Public method | SetManualNetworkIpSettings | This functions allows to set the network settings
Public method | SetNetworkIpAssignmentMode | Indicates whether network address should assigned automatically (DHCP) or manual
Public method | SetNumberOfLanguagesLimit | Configures the maximum number of languages to transmit
Public method | SetQualityConfiguration | Sets the overall channel quality configuration
Public method | SetStandbyState | Gets the standby state of the transmitter: 'on' or 'off'
Public method | UnregisterAudioLevels | This functions allows to unregister from audio level updates.
Public method | UnregisterEvents | This functions allows to un register for the registered events
Public method | UpdateUser | Updates a user.
Protected method | ValidateStateNotDisposed | (Inherited from DisposableObject.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonOperationMode Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonOperationMode
Syntax
Json
{ JsonClass:JsonOperationMode		Mode:<type>,
 }

The JsonOperationMode type exposes the following members.

Constructors
 | Name | Description
Public method | JsonOperationMode | Initializes a new instance of the JsonOperationMode class
Top
Properties
 | Name | Description
Public property | Mode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkInfo.NetworkInfo Property

NetworkInfo Property

Syntax
Json
{ Property:NetworkInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfoList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonRadiatorInfoList
Syntax
Json
{ JsonClass:JsonRadiatorInfoList		RadiatorsInfo:<type>,
 }

The JsonRadiatorInfoList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonRadiatorInfoList | Initializes a new instance of the JsonRadiatorInfoList class
Top
Properties
 | Name | Description
Public property | RadiatorsInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDateTimeResponse.DateTime Property

DateTime Property

Contains the current date and time in iso-8601 format
Syntax
Json
{ Property:DateTime }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LoginRequest Class

ConferenceApiHandlerLoginRequest Class

Parameters to Login
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerLoginRequest
Syntax
Json
{ JsonClass:LoginRequest		Password:<type>,
    User:<type>,
 }

The ConferenceApiHandlerLoginRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLoginRequest | Initializes a new instance of the ConferenceApiHandlerLoginRequest class
Top
Properties
 | Name | Description
Public property | Password | Password
Public property | User | User name
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioMode Class

Defines the enabled state and audio mode of a language
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguageAudioMode
Syntax
Json
{ JsonClass:LanguageAudioMode		LanguageId:<type>,
    Mode:<type>,
 }

The LanguageAudioMode type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageAudioMode | Initializes a new instance of the LanguageAudioMode class
Top
Properties
 | Name | Description
Public property | LanguageId | The ID of the language
Public property | Mode | Indicates the audio mode for the channel
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLatestLogsResponse Constructor

ConferenceApiHandlerGetLatestLogsResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetLatestLogsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageAudioModesResponse Class

ConferenceApiHandlerSetLanguageAudioModesResponse Class

Response from SetLanguageAudioModes
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageAudioModesResponse
Syntax
Json
{ JsonClass:SetLanguageAudioModesResponse	 }

The ConferenceApiHandlerSetLanguageAudioModesResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageAudioModesResponse | Initializes a new instance of the ConferenceApiHandlerSetLanguageAudioModesResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryGainLevelResponse Constructor

ConferenceApiHandlerSetAuxiliaryGainLevelResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetAuxiliaryGainLevelResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryMutedStateRequest Constructor

ConferenceApiHandlerGetAuxiliaryMutedStateRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryMutedStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLogLevel Properties

The JsonLogLevel type exposes the following members.

Properties
 | Name | Description
Public property | LogLevel |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ChangeOwnPasswordRequest.CurrentPassword Property

CurrentPassword Property

The current password of the logged in user
Syntax
Json
{ Property:CurrentPassword }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetOperationModeRequest Class

ConferenceApiHandlerGetOperationModeRequest Class

Parameters to GetOperationMode
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetOperationModeRequest
Syntax
Json
{ JsonClass:GetOperationModeRequest	 }

The ConferenceApiHandlerGetOperationModeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetOperationModeRequest | Initializes a new instance of the ConferenceApiHandlerGetOperationModeRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsTailResponse Class

ConferenceApiHandlerGetLogsTailResponse Class

Response from SetLogsTail
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLogsTailResponse
Syntax
Json
{ JsonClass:GetLogsTailResponse		Logs:<type>,
 }

The ConferenceApiHandlerGetLogsTailResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLogsTailResponse | Initializes a new instance of the ConferenceApiHandlerGetLogsTailResponse class
Top
Properties
 | Name | Description
Public property | Logs | The logs returned from the tail
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevel.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


InstalledLicense.FeatureName Property

FeatureName Property

The name of the licensed feature
Syntax
Json
{ Property:FeatureName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLogLevelResponse Class

ConferenceApiHandlerSetLogLevelResponse Class

Response from SetLogLevel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLogLevelResponse
Syntax
Json
{ JsonClass:SetLogLevelResponse	 }

The ConferenceApiHandlerSetLogLevelResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLogLevelResponse | Initializes a new instance of the ConferenceApiHandlerSetLogLevelResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TxoConferenceApi.Messages Namespace

Classes
 | Class | Description
Public class | JsonActivateLicenseInfo |
Public class | JsonActivationInfo |
Public class | JsonAudioChannelLevel |
Public class | JsonAuxiliaryActivation |
Public class | JsonAuxiliaryAudioLevel |
Public class | JsonAuxiliaryGainLevel |
Public class | JsonAuxiliaryMutedState |
Public class | JsonAuxiliaryState |
Public class | JsonCarrierInfo |
Public class | JsonCarrierInfoList |
Public class | JsonChangeOwnPassword |
Public class | JsonChannelConfigurationInfoList |
Public class | JsonChannelInfo |
Public class | JsonControlMode |
Public class | JsonCount |
Public class | JsonCustomerInfo |
Public class | JsonDateTime |
Public class | JsonDicentisConnectionState |
Public class | JsonEmpty |
Public class | JsonInputContactState |
Public class | JsonInstalledLicense |
Public class | JsonInstalledLicenseInfo |
Public class | JsonLanguageAudioLevel |
Public class | JsonLanguageAudioMode |
Public class | JsonLanguageAudioModesList |
Public class | JsonLanguageDistributionInfo |
Public class | JsonLanguageGainLevel |
Public class | JsonLanguageGainLevelsList |
Public class | JsonLanguageLabelInfo |
Public class | JsonLanguageLabelInfoList |
Public class | JsonLanguageMutedStateInfo |
Public class | JsonLanguageMutedStateInfoList |
Public class | JsonLanguagesConfigurationInfo |
Public class | JsonLanguageSource |
Public class | JsonLanguageSourcesList |
Public class | JsonLanguageSourceTypeInfo |
Public class | JsonLanguageSourceTypesInfoList |
Public class | JsonLicenseInfo |
Public class | JsonLoginStatus |
Public class | JsonLogLevel |
Public class | JsonLogs |
Public class | JsonMessage |
Public class | JsonMessageAudioLevelsList |
Public class | JsonMessageEvents |
Public class | JsonMessageUpdate |
Public class | JsonNetworkInfo |
Public class | JsonNetworkIpSetting |
Public class | JsonNetworkIpSettings |
Public class | JsonNumberOfLanguagesLimit |
Public class | JsonOperationMode |
Public class | JsonPackageInfo |
Public class | JsonPermissions |
Public class | JsonPhysicalNetworkInfo |
Public class | JsonQualityConfiguration |
Public class | JsonRadiatorInfo |
Public class | JsonRadiatorInfoList |
Public class | JsonRegisterFirstUse |
Public class | JsonRegisterFirstUseState |
Public class | JsonRegistrationEvents |
Public class | JsonRemoveUser |
Public class | JsonSetHostname |
Public class | JsonSoftwareInfo |
Public class | JsonStandbySchedule |
Public class | JsonStandbyScheduleInfo |
Public class | JsonStandbyState |
Public class | JsonSystemMode |
Public class | JsonTcpIpSettings |
Public class | JsonTestTones |
Public class | JsonUserCredentials |
Public class | JsonUserInfoGet |
Public class | JsonUserInfoList |
Public class | JsonUserInfoPut |
Public class | JsonVersionInfo |


JsonChannelInfo Properties

The JsonChannelInfo type exposes the following members.

Properties
 | Name | Description
Public property | AudioSlot |
Public property | CarrierId |
Public property | ChannelId |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetCarriersStateRequest Class

ConferenceApiHandlerGetCarriersStateRequest Class

Parameters to GetCarriersState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetCarriersStateRequest
Syntax
Json
{ JsonClass:GetCarriersStateRequest	 }

The ConferenceApiHandlerGetCarriersStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetCarriersStateRequest | Initializes a new instance of the ConferenceApiHandlerGetCarriersStateRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTestTones Constructor

Initializes a new instance of the JsonTestTones class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNetworkInfoResponse.NetworkInfo Property

NetworkInfo Property

The network info of the INT-TXO
Syntax
Json
{ Property:NetworkInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNumberOfLanguagesLimitRequest Class

ConferenceApiHandlerGetNumberOfLanguagesLimitRequest Class

Parameters to getNumberOfLanguagesLimit
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetNumberOfLanguagesLimitRequest
Syntax
Json
{ JsonClass:GetNumberOfLanguagesLimitRequest	 }

The ConferenceApiHandlerGetNumberOfLanguagesLimitRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetNumberOfLanguagesLimitRequest | Initializes a new instance of the ConferenceApiHandlerGetNumberOfLanguagesLimitRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItem Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.OperationalWorkItem
Syntax
Json
{ JsonClass:WorkItem		AsyncWaitHandle:<type>,
 }

The WorkItem type exposes the following members.

Constructors
 | Name | Description
Protected method | WorkItem | Initializes a new instance of the WorkItem class
Top
Properties
 | Name | Description
Public property | AsyncWaitHandle |
Top
Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the WorkItem
Protected method | DoWork |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageUpdate Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonMessageUpdate
Syntax
Json
{ JsonClass:JsonMessageUpdate		Content:<type>,
    What:<type>,
 }

The JsonMessageUpdate type exposes the following members.

Constructors
 | Name | Description
Public method | JsonMessageUpdate | Initializes a new instance of the JsonMessageUpdate class
Top
Properties
 | Name | Description
Public property | Content |
Public property | What |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetEnableTestTonesRequest Class

ConferenceApiHandlerGetEnableTestTonesRequest Class

Parameters to GetEnableTestTones
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetEnableTestTonesRequest
Syntax
Json
{ JsonClass:GetEnableTestTonesRequest	 }

The ConferenceApiHandlerGetEnableTestTonesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetEnableTestTonesRequest | Initializes a new instance of the ConferenceApiHandlerGetEnableTestTonesRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RemoveUserRequest Constructor

ConferenceApiHandlerRemoveUserRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRemoveUserRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AudioChannelLevel Class

Contains the audio level of the identified channel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientAudioChannelLevel
Syntax
Json
{ JsonClass:AudioChannelLevel		ChannelId:<type>,
    DbLevel:<type>,
 }

The AudioChannelLevel type exposes the following members.

Constructors
 | Name | Description
Public method | AudioChannelLevel | Initializes a new instance of the AudioChannelLevel class
Top
Properties
 | Name | Description
Public property | ChannelId | The audio channel for which the audio level is applicable.
Public property | DbLevel | The level of the audio for the channel
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateLicensesResponse Constructor

ConferenceApiHandlerActivateLicensesResponse Constructor

Initializes a new instance of the ConferenceApiHandlerActivateLicensesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CustomerRegistrationInfo Class

Descibes the information of the customer requesting a license
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientCustomerRegistrationInfo
Syntax
Json
{ JsonClass:CustomerRegistrationInfo		Address:<type>,
    City:<type>,
    Country:<type>,
    CustomerName:<type>,
    LocationName:<type>,
 }

The CustomerRegistrationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CustomerRegistrationInfo | Initializes a new instance of the CustomerRegistrationInfo class
Top
Properties
 | Name | Description
Public property | Address | The address of the customer
Public property | City | The city of the customer
Public property | Country | The country of the customer
Public property | CustomerName | The name of the customer
Public property | LocationName | The location information of the customer
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDicentisConnectionStateResponse Class

ConferenceApiHandlerGetDicentisConnectionStateResponse Class

Response from GetDicentisConnectionState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetDicentisConnectionStateResponse
Syntax
Json
{ JsonClass:GetDicentisConnectionStateResponse		Connected:<type>,
 }

The ConferenceApiHandlerGetDicentisConnectionStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetDicentisConnectionStateResponse | Initializes a new instance of the ConferenceApiHandlerGetDicentisConnectionStateResponse class
Top
Properties
 | Name | Description
Public property | Connected | The state of the connection with the DICENTIS system
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet.Role Property

Role Property

The role of the user, which determines their permissions
Syntax
Json
{ Property:Role }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RebootResponse Constructor

ConferenceApiHandlerRebootResponse Constructor

Initializes a new instance of the ConferenceApiHandlerRebootResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfo Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageMutedStateInfo
Syntax
Json
{ JsonClass:JsonLanguageMutedStateInfo		LanguageId:<type>,
    Muted:<type>,
 }

The JsonLanguageMutedStateInfo type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageMutedStateInfo | Initializes a new instance of the JsonLanguageMutedStateInfo class
Top
Properties
 | Name | Description
Public property | LanguageId |
Public property | Muted |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryGainLevelRequest Class

ConferenceApiHandlerGetAuxiliaryGainLevelRequest Class

Request for getting the auxiliary gain levels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetAuxiliaryGainLevelRequest
Syntax
Json
{ JsonClass:GetAuxiliaryGainLevelRequest	 }

The ConferenceApiHandlerGetAuxiliaryGainLevelRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetAuxiliaryGainLevelRequest | Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryGainLevelRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MessageAudioLevelsList Class

Defines a message containing all audio levels from the INT-TXO
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientMessageAudioLevelsList
Syntax
Json
{ JsonClass:MessageAudioLevelsList		Auxiliary:<type>,
    Languages:<type>,
 }

The MessageAudioLevelsList type exposes the following members.

Constructors
 | Name | Description
Public method | MessageAudioLevelsList | Initializes a new instance of the MessageAudioLevelsList class
Top
Properties
 | Name | Description
Public property | Auxiliary | The audio level of the auxiliary input
Public property | Languages | For all languages, the audio levels per channel
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateLicenseInfo.Dictionary Property

Dictionary Property

The dictionary containing the customer information
Syntax
Json
{ Property:Dictionary }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ResetToFactoryDefaultRequest Class

ConferenceApiHandlerResetToFactoryDefaultRequest Class

Parameters to ResetToFactoryDefault
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerResetToFactoryDefaultRequest
Syntax
Json
{ JsonClass:ResetToFactoryDefaultRequest	 }

The ConferenceApiHandlerResetToFactoryDefaultRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerResetToFactoryDefaultRequest | Initializes a new instance of the ConferenceApiHandlerResetToFactoryDefaultRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageGainLevelsResponse Constructor

ConferenceApiHandlerGetLanguageGainLevelsResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetLanguageGainLevelsResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageDistributionInfo Class

Describes the language distribution info
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguageDistributionInfo
Syntax
Json
{ JsonClass:LanguageDistributionInfo		NumberOfActiveLanguages:<type>,
    NumberOfReceivedLanguages:<type>,
 }

The LanguageDistributionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageDistributionInfo | Initializes a new instance of the LanguageDistributionInfo class
Top
Properties
 | Name | Description
Public property | NumberOfActiveLanguages | The number of active channels that visible on the receivers
Public property | NumberOfReceivedLanguages | The number of languages that INT-TXO received
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryStateRequest Constructor

ConferenceApiHandlerGetAuxiliaryStateRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioLevel.LanguageId Property

LanguageId Property

Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItemQueue Properties

The WorkerThreadWorkItemQueue type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the QueueT. (Inherited from QueueWorkItem .)
Public property | HasItems |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetRadiatorsStateResponse Constructor

ConferenceApiHandlerGetRadiatorsStateResponse Constructor

Initializes a new instance of the ConferenceApiHandlerGetRadiatorsStateResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRadiatorInfo.HasError Property

HasError Property

Syntax
Json
{ Property:HasError }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.CapIpAddr Property

CapIpAddr Property

The IP-address of the CAP processor of the INT-TXO
Syntax
Json
{ Property:CapIpAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryState Constructor

Initializes a new instance of the JsonAuxiliaryState class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageGainLevel.Level Property

Level Property

Indicates the current audio gain setting
Syntax
Json
{ Property:Level }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetControlModeConfigurationResponse.Mode Property

Mode Property

The control mode.
Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsRequest Class

ConferenceApiHandlerRegisterEventsRequest Class

Parameters to RegisterEvents
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerRegisterEventsRequest
Syntax
Json
{ JsonClass:RegisterEventsRequest		Events:<type>,
 }

The ConferenceApiHandlerRegisterEventsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerRegisterEventsRequest | Initializes a new instance of the ConferenceApiHandlerRegisterEventsRequest class
Top
Properties
 | Name | Description
Public property | Events | List of events registered
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageLabelsRequest Constructor

ConferenceApiHandlerSetLanguageLabelsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetLanguageLabelsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateUserRequest Class

ConferenceApiHandlerUpdateUserRequest Class

Parameters to updateUser. Obtains fields directly from UserInfoPut.
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientUserInfoGet
TxoConferenceApi.ClientUserInfoPut
TxoConferenceApi.ClientConferenceApiHandlerUpdateUserRequest
Syntax
Json
{ JsonClass:UpdateUserRequest		FirstName:<type>,
    LastName:<type>,
    Role:<type>,
    User:<type>,
    Password:<type>,
 }

The ConferenceApiHandlerUpdateUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerUpdateUserRequest | Construct an instance of UpdateUserRequest from an instance of UserInfoPut
Top
Properties
 | Name | Description
Public property | FirstName | The first name of the user (Inherited from UserInfoGet.)
Public property | LastName | The last name of the user (Inherited from UserInfoGet.)
Public property | Password | The password of the user (Inherited from UserInfoPut.)
Public property | Role | The role of the user, which determines their permissions (Inherited from UserInfoGet.)
Public property | User | The ID of the user (i.e. their user name) (Inherited from UserInfoGet.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioMode Constructor

Initializes a new instance of the LanguageAudioMode class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LicenseInfo Properties

The LicenseInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivationInfo | The information on the licenses installed on the transmitter.
Public property | CustomerInfo | The customer registration information.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageGainLevelsRequest Class

ConferenceApiHandlerGetLanguageGainLevelsRequest Class

Request for getting channel gain levels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLanguageGainLevelsRequest
Syntax
Json
{ JsonClass:GetLanguageGainLevelsRequest	 }

The ConferenceApiHandlerGetLanguageGainLevelsRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLanguageGainLevelsRequest | Initializes a new instance of the ConferenceApiHandlerGetLanguageGainLevelsRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageAudioModesRequest Constructor

ConferenceApiHandlerSetLanguageAudioModesRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetLanguageAudioModesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TcpIpProperties Properties

The TcpIpProperties type exposes the following members.

Properties
 | Name | Description
Public property | CapIpAddr | The IP-address of the CAP processor
Public property | Gateway | The default gateway
Public property | MainIpAddr | The IP-address of the main processor
Public property | SubnetMask | The Subnet mask
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetAuxiliaryGainLevelResponse Properties

The ConferenceApiHandlerGetAuxiliaryGainLevelResponse type exposes the following members.

Properties
 | Name | Description
Public property | Level | The gain level of the auxiliary input
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLoginStatusRequest Class

ConferenceApiHandlerGetLoginStatusRequest Class

Parameters to GetLoginStatus
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLoginStatusRequest
Syntax
Json
{ JsonClass:GetLoginStatusRequest	 }

The ConferenceApiHandlerGetLoginStatusRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLoginStatusRequest | Initializes a new instance of the ConferenceApiHandlerGetLoginStatusRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ProcessLicensePackageResponse Properties

The ConferenceApiHandlerProcessLicensePackageResponse type exposes the following members.

Properties
 | Name | Description
Public property | Package | The Base64 encoded binary string containing the possible return file information.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


WorkItem.Dispose Method

Dispose Method

Releases all resources used by the WorkItem
Syntax
Json
Request
Response

Implements

IDisposableDispose
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioModesList.LanguageAudioModes Property

LanguageAudioModes Property

Syntax
Json
{ Property:LanguageAudioModes }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ChannelInfo Class

Describes the info for a channel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientChannelInfo
Syntax
Json
{ JsonClass:ChannelInfo		AudioSlot:<type>,
    CarrierId:<type>,
    ChannelId:<type>,
 }

The ChannelInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelInfo | Initializes a new instance of the ChannelInfo class
Top
Properties
 | Name | Description
Public property | AudioSlot | The number of the carrier's audio slot the channel is allocated to.
Public property | CarrierId | The carrier the channel is allocated to.
Public property | ChannelId | The ID of the channel.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageGainLevelsRequest Constructor

ConferenceApiHandlerSetLanguageGainLevelsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerSetLanguageGainLevelsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoPut Class

Describes the user information that can be sent to the TXO
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientUserInfoGet
TxoConferenceApi.ClientUserInfoPut
TxoConferenceApi.ClientConferenceApiHandlerAddUserRequest
TxoConferenceApi.ClientConferenceApiHandlerUpdateUserRequest
Syntax
Json
{ JsonClass:UserInfoPut		FirstName:<type>,
    LastName:<type>,
    Role:<type>,
    User:<type>,
    Password:<type>,
 }

The UserInfoPut type exposes the following members.

Constructors
 | Name | Description
Public method | UserInfoPut | Copy constructor
Top
Properties
 | Name | Description
Public property | FirstName | The first name of the user (Inherited from UserInfoGet.)
Public property | LastName | The last name of the user (Inherited from UserInfoGet.)
Public property | Password | The password of the user
Public property | Role | The role of the user, which determines their permissions (Inherited from UserInfoGet.)
Public property | User | The ID of the user (i.e. their user name) (Inherited from UserInfoGet.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSoftwareInfo.ProductVersion Property

ProductVersion Property

Syntax
Json
{ Property:ProductVersion }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo.Channels Property

Channels Property

The channels allocated to the language
Syntax
Json
{ Property:Channels }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ChangeOwnPasswordRequest.NewPassword Property

NewPassword Property

The new password for the logged in user
Syntax
Json
{ Property:NewPassword }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTestTones.Enable Property

Enable Property

Syntax
Json
{ Property:Enable }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNumberOfLanguagesLimitRequest Constructor

ConferenceApiHandlerGetNumberOfLanguagesLimitRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetNumberOfLanguagesLimitRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateLicenseInfo Class

Describes the license(s) to be activated
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientActivateLicenseInfo
Syntax
Json
{ JsonClass:ActivateLicenseInfo		ActivationIds:<type>,
    Dictionary:<type>,
 }

The ActivateLicenseInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ActivateLicenseInfo | Initializes a new instance of the ActivateLicenseInfo class
Top
Properties
 | Name | Description
Public property | ActivationIds | The activation ID's to be requested
Public property | Dictionary | The dictionary containing the customer information
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfoList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonCarrierInfoList
Syntax
Json
{ JsonClass:JsonCarrierInfoList		CarriersInfo:<type>,
 }

The JsonCarrierInfoList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonCarrierInfoList | Initializes a new instance of the JsonCarrierInfoList class
Top
Properties
 | Name | Description
Public property | CarriersInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonSoftwareInfo.MainVersion Property

MainVersion Property

Syntax
Json
{ Property:MainVersion }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRegisterFirstUse Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonRegisterFirstUse
Syntax
Json
{ JsonClass:JsonRegisterFirstUse		Password:<type>,
 }

The JsonRegisterFirstUse type exposes the following members.

Constructors
 | Name | Description
Public method | JsonRegisterFirstUse | Initializes a new instance of the JsonRegisterFirstUse class
Top
Properties
 | Name | Description
Public property | Password |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UserInfoGet.LastName Property

LastName Property

The last name of the user
Syntax
Json
{ Property:LastName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetManualNetworkIpSettingsRequest.Settings Property

Settings Property

The network settings to be changed to
Syntax
Json
{ Property:Settings }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChangeOwnPassword.NewPassword Property

NewPassword Property

Syntax
Json
{ Property:NewPassword }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageSourceTypesResponse Constructor

ConferenceApiHandlerSetLanguageSourceTypesResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetLanguageSourceTypesResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetNetworkInfoResponse Properties

The ConferenceApiHandlerGetNetworkInfoResponse type exposes the following members.

Properties
 | Name | Description
Public property | NetworkInfo | The network info of the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfo.Muted Property

Muted Property

Syntax
Json
{ Property:Muted }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCarrierInfoList Constructor

Initializes a new instance of the JsonCarrierInfoList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryMutedStateRequest Constructor

ConferenceApiHandlerSetAuxiliaryMutedStateRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetAuxiliaryMutedStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


EnableTestTonesRequest Properties

The ConferenceApiHandlerEnableTestTonesRequest type exposes the following members.

Properties
 | Name | Description
Public property | Enable | Indicates whether the test tones to all channels are enabled
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRemoveUser Constructor

Initializes a new instance of the JsonRemoveUser class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageGainLevelsList Properties

The JsonLanguageGainLevelsList type exposes the following members.

Properties
 | Name | Description
Public property | LanguageGainLevels |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageLabelInfo Properties

The LanguageLabelInfo type exposes the following members.

Properties
 | Name | Description
Public property | Label | The label of the language
Public property | LanguageId | The ID of the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioMode.Mode Property

Mode Property

Syntax
Json
{ Property:Mode }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.BackupConfigurationResponse Constructor

ConferenceApiHandlerBackupConfigurationResponse Constructor

Initializes a new instance of the ConferenceApiHandlerBackupConfigurationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.ActivateLicensesRequest.ActivationIds Property

ActivationIds Property

The list of activation ID's requested
Syntax
Json
{ Property:ActivationIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageAudioLevel Class

Contains the audio levels of the channels allocated to the language
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguageAudioLevel
Syntax
Json
{ JsonClass:LanguageAudioLevel		Channels:<type>,
    LanguageId:<type>,
 }

The LanguageAudioLevel type exposes the following members.

Constructors
 | Name | Description
Public method | LanguageAudioLevel | Initializes a new instance of the LanguageAudioLevel class
Top
Properties
 | Name | Description
Public property | Channels | The list of allocated channels and the corresponding audio level in decibels.
Public property | LanguageId | The language for which the audio levels are applicable.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer.Post Method

Post Method

Syntax
Json
  See Also
Reference
Bosch Security Systems
(c) Bosch Security System B.V., 2024


GetLanguageDistributionInfoResponse Properties

The ConferenceApiHandlerGetLanguageDistributionInfoResponse type exposes the following members.

Properties
 | Name | Description
Public property | LanguageDistributionInfo | The language distribution info
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateLicenseInfo Properties

The ActivateLicenseInfo type exposes the following members.

Properties
 | Name | Description
Public property | ActivationIds | The activation ID's to be requested
Public property | Dictionary | The dictionary containing the customer information
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetQualityConfigurationResponse Constructor

ConferenceApiHandlerGetQualityConfigurationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetQualityConfigurationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


NetworkInfo.Hostname Property

Hostname Property

The hostname of the INT-TXO
Syntax
Json
{ Property:Hostname }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonVersionInfo Fields

The JsonVersionInfo type exposes the following members.

Fields
 | Name | Description
Public field | VersionInfo |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonRemoveUser.User Property

User Property

Syntax
Json
{ Property:User }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonCustomerInfo.City Property

City Property

Syntax
Json
{ Property:City }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo.CapIpAddr Property

CapIpAddr Property

Syntax
Json
{ Property:CapIpAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetQualityConfigurationResponse Properties

The ConferenceApiHandlerGetQualityConfigurationResponse type exposes the following members.

Properties
 | Name | Description
Public property | Quality | Indicates the overall channel quality configuration setting.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsTailRequest Class

ConferenceApiHandlerGetLogsTailRequest Class

Parameters to GetLogsTail
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLogsTailRequest
Syntax
Json
{ JsonClass:GetLogsTailRequest		Count:<type>,
 }

The ConferenceApiHandlerGetLogsTailRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLogsTailRequest | Initializes a new instance of the ConferenceApiHandlerGetLogsTailRequest class
Top
Properties
 | Name | Description
Public property | Count | The number of logs to retrieve from the tail
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSource Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageSource
Syntax
Json
{ JsonClass:JsonLanguageSource		LanguageId:<type>,
    SourceInput:<type>,
 }

The JsonLanguageSource type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageSource | Initializes a new instance of the JsonLanguageSource class
Top
Properties
 | Name | Description
Public property | LanguageId |
Public property | SourceInput |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTcpIpSettings.CapIpAddr Property

CapIpAddr Property

Syntax
Json
{ Property:CapIpAddr }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonControlMode Properties

The JsonControlMode type exposes the following members.

Properties
 | Name | Description
Public property | Mode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UpdateUserRequest Properties

The ConferenceApiHandlerUpdateUserRequest type exposes the following members.

Properties
 | Name | Description
Public property | FirstName | The first name of the user (Inherited from UserInfoGet.)
Public property | LastName | The last name of the user (Inherited from UserInfoGet.)
Public property | Password | The password of the user (Inherited from UserInfoPut.)
Public property | Role | The role of the user, which determines their permissions (Inherited from UserInfoGet.)
Public property | User | The ID of the user (i.e. their user name) (Inherited from UserInfoGet.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


VersionInfo Constructor

Initializes a new instance of the VersionInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPermissions Properties

The JsonPermissions type exposes the following members.

Properties
 | Name | Description
Public property | Permissions |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonPhysicalNetworkInfo Properties

The JsonPhysicalNetworkInfo type exposes the following members.

Properties
 | Name | Description
Public property | CapIpAddr |
Public property | CapMacAddr |
Public property | DeviceName |
Public property | Gateway |
Public property | Hostname |
Public property | IpAssignmentMode |
Public property | MainIpAddr |
Public property | MainMacAddr |
Public property | Rstp |
Public property | SerialNumber |
Public property | SubnetMask |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LicenseInfo.ActivationInfo Property

ActivationInfo Property

The information on the licenses installed on the transmitter.
Syntax
Json
{ Property:ActivationInfo }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageDistributionInfo.NumberOfActiveLanguages Property

NumberOfActiveLanguages Property

Syntax
Json
{ Property:NumberOfActiveLanguages }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ActivateLicenseInfo.ActivationIds Property

ActivationIds Property

The activation ID's to be requested
Syntax
Json
{ Property:ActivationIds }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


UnregisterEventsRequest Properties

The ConferenceApiHandlerUnregisterEventsRequest type exposes the following members.

Properties
 | Name | Description
Public property | Events | List of unregistered events
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetInputContactStateResponse.Engaged Property

Engaged Property

Indicates whether input contact on the INT-TXO is engaged or not
Syntax
Json
{ Property:Engaged }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelInfo.AudioSlot Property

AudioSlot Property

Syntax
Json
{ Property:AudioSlot }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogsTailRequest Constructor

ConferenceApiHandlerGetLogsTailRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetLogsTailRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CustomerRegistrationInfo.CustomerName Property

CustomerName Property

The name of the customer
Syntax
Json
{ Property:CustomerName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLogLevel Constructor

Initializes a new instance of the JsonLogLevel class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageEvents Properties

The JsonMessageEvents type exposes the following members.

Properties
 | Name | Description
Public property | Events |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.AddUserRequest Class

ConferenceApiHandlerAddUserRequest Class

Parameters to addUser. Obtains fields directly from UserInfoPut.
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientUserInfoGet
TxoConferenceApi.ClientUserInfoPut
TxoConferenceApi.ClientConferenceApiHandlerAddUserRequest
Syntax
Json
{ JsonClass:AddUserRequest		FirstName:<type>,
    LastName:<type>,
    Role:<type>,
    User:<type>,
    Password:<type>,
 }

The ConferenceApiHandlerAddUserRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerAddUserRequest | Construct an instance of AddUserRequest from an instance of UserInfoPut
Top
Properties
 | Name | Description
Public property | FirstName | The first name of the user (Inherited from UserInfoGet.)
Public property | LastName | The last name of the user (Inherited from UserInfoGet.)
Public property | Password | The password of the user (Inherited from UserInfoPut.)
Public property | Role | The role of the user, which determines their permissions (Inherited from UserInfoGet.)
Public property | User | The ID of the user (i.e. their user name) (Inherited from UserInfoGet.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LoginResponse Properties

The ConferenceApiHandlerLoginResponse type exposes the following members.

Properties
 | Name | Description
Public property | LoggedIn | Loggeg in status
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTestTones Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonTestTones
Syntax
Json
{ JsonClass:JsonTestTones		Enable:<type>,
 }

The JsonTestTones type exposes the following members.

Constructors
 | Name | Description
Public method | JsonTestTones | Initializes a new instance of the JsonTestTones class
Top
Properties
 | Name | Description
Public property | Enable |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


TcpIpProperties.Gateway Property

Gateway Property

The default gateway
Syntax
Json
{ Property:Gateway }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLanguageGainLevelsResponse Class

ConferenceApiHandlerGetLanguageGainLevelsResponse Class

Response from getting channel gain levels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetLanguageGainLevelsResponse
Syntax
Json
{ JsonClass:GetLanguageGainLevelsResponse		LanguageGainLevels:<type>,
 }

The ConferenceApiHandlerGetLanguageGainLevelsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetLanguageGainLevelsResponse | Initializes a new instance of the ConferenceApiHandlerGetLanguageGainLevelsResponse class
Top
Properties
 | Name | Description
Public property | LanguageGainLevels | The gain levels for all audio available channels on the INT-TXO
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelInfo.CarrierId Property

CarrierId Property

Syntax
Json
{ Property:CarrierId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageSourcesList.LanguageInputs Property

LanguageInputs Property

Syntax
Json
{ Property:LanguageInputs }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetStandbyStateResponse.Standby Property

Standby Property

Indicates whether INT-TXO in standby or not
Syntax
Json
{ Property:Standby }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.UpdateUserResponse Constructor

ConferenceApiHandlerUpdateUserResponse Constructor

Initializes a new instance of the ConferenceApiHandlerUpdateUserResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


GetEnableTestTonesResponse Properties

The ConferenceApiHandlerGetEnableTestTonesResponse type exposes the following members.

Properties
 | Name | Description
Public property | Enable | Indicates whether all testtones to all channels is enabled
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInputContactState.Engaged Property

Engaged Property

Syntax
Json
{ Property:Engaged }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SystemMode Enumeration

Defines system mode
Syntax
Json
SystemMode:{
Dicentis
Standalone
Auxiliary
Test
Slave}
Members
Member name | Value | Description
Dicentis | 0 | Dicentis mode is active
Standalone | 1 | Standalone mode is active
Auxiliary | 2 | Auxiliary mode is active
Test | 3 | Test mode is active
Slave | 4 | Slave mode is active mode
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyScheduleInfo.Enabled Property

Enabled Property

Syntax
Json
{ Property:Enabled }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLatestLogsResponse.Logs Property

Logs Property

The list of logs returned
Syntax
Json
{ Property:Logs }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetLogLevelRequest Constructor

ConferenceApiHandlerGetLogLevelRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetLogLevelRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageMutedStateInfoList Constructor

Initializes a new instance of the JsonLanguageMutedStateInfoList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonTcpIpSettings Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonTcpIpSettings
Syntax
Json
{ JsonClass:JsonTcpIpSettings		CapIpAddr:<type>,
    Gateway:<type>,
    MainIpAddr:<type>,
    SubnetMask:<type>,
 }

The JsonTcpIpSettings type exposes the following members.

Constructors
 | Name | Description
Public method | JsonTcpIpSettings | Initializes a new instance of the JsonTcpIpSettings class
Top
Properties
 | Name | Description
Public property | CapIpAddr |
Public property | Gateway |
Public property | MainIpAddr |
Public property | SubnetMask |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetDateTimeResponse Class

ConferenceApiHandlerSetDateTimeResponse Class

Response from SetDateTime
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetDateTimeResponse
Syntax
Json
{ JsonClass:SetDateTimeResponse	 }

The ConferenceApiHandlerSetDateTimeResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetDateTimeResponse | Initializes a new instance of the ConferenceApiHandlerSetDateTimeResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


Synchronizer Constructor (String)

Initializes a new instance of the Synchronizer class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonStandbyState.Standby Property

Standby Property

Syntax
Json
{ Property:Standby }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoPut Constructor

Initializes a new instance of the JsonUserInfoPut class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetNumberOfLanguagesLimitResponse Class

ConferenceApiHandlerGetNumberOfLanguagesLimitResponse Class

Response from getNumberOfLanguagesLimit
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetNumberOfLanguagesLimitResponse
Syntax
Json
{ JsonClass:GetNumberOfLanguagesLimitResponse		Limit:<type>,
 }

The ConferenceApiHandlerGetNumberOfLanguagesLimitResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetNumberOfLanguagesLimitResponse | Initializes a new instance of the ConferenceApiHandlerGetNumberOfLanguagesLimitResponse class
Top
Properties
 | Name | Description
Public property | Limit | Indicates maximum number of languages to transmit
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonQualityConfiguration Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonQualityConfiguration
Syntax
Json
{ JsonClass:JsonQualityConfiguration		Quality:<type>,
 }

The JsonQualityConfiguration type exposes the following members.

Constructors
 | Name | Description
Public method | JsonQualityConfiguration | Initializes a new instance of the JsonQualityConfiguration class
Top
Properties
 | Name | Description
Public property | Quality |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.BackupConfigurationRequest Constructor

ConferenceApiHandlerBackupConfigurationRequest Constructor

Initializes a new instance of the ConferenceApiHandlerBackupConfigurationRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageMutedStateInfo Constructor

Initializes a new instance of the LanguageMutedStateInfo class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVersionInfoRequest Constructor

ConferenceApiHandlerGetVersionInfoRequest Constructor

Initializes a new instance of the ConferenceApiHandlerGetVersionInfoRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetQualityConfigurationResponse Constructor

ConferenceApiHandlerSetQualityConfigurationResponse Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerSetQualityConfigurationResponse class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageDistributionInfo.NumberOfReceivedLanguages Property

NumberOfReceivedLanguages Property

The number of languages that INT-TXO received
Syntax
Json
{ Property:NumberOfReceivedLanguages }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryGainLevelRequest Class

ConferenceApiHandlerSetAuxiliaryGainLevelRequest Class

Parameters to SetAuxiliaryGainLevel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetAuxiliaryGainLevelRequest
Syntax
Json
{ JsonClass:SetAuxiliaryGainLevelRequest		Level:<type>,
 }

The ConferenceApiHandlerSetAuxiliaryGainLevelRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetAuxiliaryGainLevelRequest | Initializes a new instance of the ConferenceApiHandlerSetAuxiliaryGainLevelRequest class
Top
Properties
 | Name | Description
Public property | Level | The gain level of the auxiliary input
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonChannelInfo.ChannelId Property

ChannelId Property

Syntax
Json
{ Property:ChannelId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler Properties

The ConferenceApiHandler type exposes the following members.

Properties
 | Name | Description
Protected property | Disposed | (Inherited from DisposableObject.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.LogoutRequest Class

ConferenceApiHandlerLogoutRequest Class

Logout request
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerLogoutRequest
Syntax
Json
{ JsonClass:LogoutRequest	 }

The ConferenceApiHandlerLogoutRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerLogoutRequest | Initializes a new instance of the ConferenceApiHandlerLogoutRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioModesList Constructor

Initializes a new instance of the JsonLanguageAudioModesList class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessage.MessageId Property

MessageId Property

Syntax
Json
{ Property:MessageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetAuxiliaryStateResponse Class

ConferenceApiHandlerGetAuxiliaryStateResponse Class

Response from GetAuxiliaryState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetAuxiliaryStateResponse
Syntax
Json
{ JsonClass:GetAuxiliaryStateResponse		Active:<type>,
 }

The ConferenceApiHandlerGetAuxiliaryStateResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetAuxiliaryStateResponse | Initializes a new instance of the ConferenceApiHandlerGetAuxiliaryStateResponse class
Top
Properties
 | Name | Description
Public property | Active | Indicates whether the analog auxiliary input is active or not
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


AuxiliaryAudioLevel Class

Contains the audio level of the auxiliary input
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientAuxiliaryAudioLevel
Syntax
Json
{ JsonClass:AuxiliaryAudioLevel		DbLevel:<type>,
 }

The AuxiliaryAudioLevel type exposes the following members.

Constructors
 | Name | Description
Public method | AuxiliaryAudioLevel | Initializes a new instance of the AuxiliaryAudioLevel class
Top
Properties
 | Name | Description
Public property | DbLevel | The level of the audio for the zuxiliary input
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetNumberOfLanguagesLimitResponse Class

ConferenceApiHandlerSetNumberOfLanguagesLimitResponse Class

Response from SetNumberOfLanguagesLimit
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetNumberOfLanguagesLimitResponse
Syntax
Json
{ JsonClass:SetNumberOfLanguagesLimitResponse	 }

The ConferenceApiHandlerSetNumberOfLanguagesLimitResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetNumberOfLanguagesLimitResponse | Initializes a new instance of the ConferenceApiHandlerSetNumberOfLanguagesLimitResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ChangeOwnPasswordRequest Properties

The ConferenceApiHandlerChangeOwnPasswordRequest type exposes the following members.

Properties
 | Name | Description
Public property | CurrentPassword | The current password of the logged in user
Public property | NewPassword | The new password for the logged in user
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryMutedState Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonAuxiliaryMutedState
Syntax
Json
{ JsonClass:JsonAuxiliaryMutedState		Muted:<type>,
 }

The JsonAuxiliaryMutedState type exposes the following members.

Constructors
 | Name | Description
Public method | JsonAuxiliaryMutedState | Initializes a new instance of the JsonAuxiliaryMutedState class
Top
Properties
 | Name | Description
Public property | Muted |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryMutedStateRequest Class

ConferenceApiHandlerSetAuxiliaryMutedStateRequest Class

Parameters to SetAuxiliaryMutedState
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetAuxiliaryMutedStateRequest
Syntax
Json
{ JsonClass:SetAuxiliaryMutedStateRequest		Muted:<type>,
 }

The ConferenceApiHandlerSetAuxiliaryMutedStateRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetAuxiliaryMutedStateRequest | Initializes a new instance of the ConferenceApiHandlerSetAuxiliaryMutedStateRequest class
Top
Properties
 | Name | Description
Public property | Muted | The muted state of the auxiliary input
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonAuxiliaryGainLevel Properties

The JsonAuxiliaryGainLevel type exposes the following members.

Properties
 | Name | Description
Public property | Level |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RestoreConfigurationRequest.Package Property

Package Property

A binary blob
Syntax
Json
{ Property:Package }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetAuxiliaryGainLevelResponse Class

ConferenceApiHandlerSetAuxiliaryGainLevelResponse Class

Response from SetAuxiliaryGainLevel
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetAuxiliaryGainLevelResponse
Syntax
Json
{ JsonClass:SetAuxiliaryGainLevelResponse	 }

The ConferenceApiHandlerSetAuxiliaryGainLevelResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetAuxiliaryGainLevelResponse | Initializes a new instance of the ConferenceApiHandlerSetAuxiliaryGainLevelResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageAudioModesRequest Class

ConferenceApiHandlerSetLanguageAudioModesRequest Class

Parameters to SetLanguageAudioModes
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageAudioModesRequest
Syntax
Json
{ JsonClass:SetLanguageAudioModesRequest		LanguageAudioModes:<type>,
 }

The ConferenceApiHandlerSetLanguageAudioModesRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageAudioModesRequest | Initializes a new instance of the ConferenceApiHandlerSetLanguageAudioModesRequest class
Top
Properties
 | Name | Description
Public property | LanguageAudioModes | The list of languages with their audio modes configuration
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonQualityConfiguration Properties

The JsonQualityConfiguration type exposes the following members.

Properties
 | Name | Description
Public property | Quality |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.EnableTestTonesRequest Constructor

ConferenceApiHandlerEnableTestTonesRequest Constructor

Initializes a new instance of the ConferenceApiHandlerEnableTestTonesRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceEvent Enumeration

Events that the server can fire to the clients
Syntax
Json
ConferenceEvent:{
LoginStateChanged
PermissionsChanged
StandbyStateChanged
OperationModeChanged
EnableTestTonesChanged
LicensesChanged
RegisterFirstUseStateChanged
LanguageDistributionInfoChanged
NetworkInfoChanged
RadiatorStateChanged
CarrierStateChanged
VersionInfoChanged
UserInfoChanged
AuxiliaryActiveStateChanged
SystemModeChanged
ControlModeConfigurationChanged
QualityConfigurationChanged
LanguagesConfigurationChanged
LanguageGainLevelsChanged
AuxiliaryGainLevelChanged
DicentisConnectionStateChanged
InputContactStateChanged
LanguageMutedStatesChanged
AuxiliaryMutedStateChanged
NumberOfLanguagesLimitChanged
DateTimeChanged
LogLevelChanged}
Members
Member name | Value | Description
LoginStateChanged | 0 | Indicates that the login state has changed
PermissionsChanged | 1 | Indicates the permissions of the logged in user have changed
StandbyStateChanged | 2 | Indicates the INT-TXO was set into standby or taken out of standby
OperationModeChanged | 3 | Indicates the master/slave operation mode of the INT-TXO has changed
EnableTestTonesChanged | 4 | Indicates the test tones were (de)activated
LicensesChanged | 5 | Indicates a change in the license set has occurred
RegisterFirstUseStateChanged | 6 | Indicates that first-time use registration has started/stopped
LanguageDistributionInfoChanged | 7 | Indicates that the generic language distribution settings have changed (e.g. number of active/received languages)
NetworkInfoChanged | 8 | Indicates that the network specific configuration info has changed
RadiatorStateChanged | 9 | Indicate the state of the radiator(s) has changed
CarrierStateChanged | 10 | Indicates that the configuration of one or more carriers has changed event
VersionInfoChanged | 11 | Indicates that any of the product or main versions has changed
UserInfoChanged | 12 | Indicates that a user was added, removed or updated on the INT-TXO
AuxiliaryActiveStateChanged | 13 | Indicates that an analog auxiliary was (de)activated
SystemModeChanged | 14 | Indicates the current system mode of the INT-TXO has changed
ControlModeConfigurationChanged | 15 | Indicates that the control mode configuration setting on the INT-TXO has changed
QualityConfigurationChanged | 16 | Indicates the general quality configuration has changed for the INT-TXO channels
LanguagesConfigurationChanged | 17 | Indicates that the configuration settings of one or more languages has changed.
LanguageGainLevelsChanged | 18 | Indicates that the gain level and/or muted state of a channel has changed.
AuxiliaryGainLevelChanged | 19 | Indicates that the gain level and/or muted state of the auxiliary input has changed.
DicentisConnectionStateChanged | 20 | Indicates whether the state of the connection to the DICENTIS-system has changed.
InputContactStateChanged | 21 | Indicates whether the state of the input contact at the back of the INT-TXO has changed.
LanguageMutedStatesChanged | 22 | Indicates whether the muted state of the language definition has changed.
AuxiliaryMutedStateChanged | 23 | Indicate that the muted state of the auxiliary has changed
NumberOfLanguagesLimitChanged | 24 | Indicates that the maximum number of languages to transmit changed
DateTimeChanged | 25 | Indicates that the date and time are set
LogLevelChanged | 26 | Indicate that the loglevel of the INT-TXO has changed
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


SetLanguageSourceTypesRequest Properties

The ConferenceApiHandlerSetLanguageSourceTypesRequest type exposes the following members.

Properties
 | Name | Description
Public property | LanguageSourceTypes | The list of language source types
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetLanguageGainLevelsResponse Class

ConferenceApiHandlerSetLanguageGainLevelsResponse Class

Response from SetChannelGainLevels
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetLanguageGainLevelsResponse
Syntax
Json
{ JsonClass:SetLanguageGainLevelsResponse	 }

The ConferenceApiHandlerSetLanguageGainLevelsResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetLanguageGainLevelsResponse | Initializes a new instance of the ConferenceApiHandlerSetLanguageGainLevelsResponse class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonNetworkIpSettings.Settings Property

Settings Property

Syntax
Json
{ Property:Settings }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterAudioLevelsRequest Constructor

ConferenceApiHandlerRegisterAudioLevelsRequest Constructor

Initializes a new instance of the ConferenceApiHandlerRegisterAudioLevelsRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


DisposableObject.Finalize Method

Finalize Method

Syntax
Json
Request
Response
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ChannelInfo Properties

The ChannelInfo type exposes the following members.

Properties
 | Name | Description
Public property | AudioSlot | The number of the carrier's audio slot the channel is allocated to.
Public property | CarrierId | The carrier the channel is allocated to.
Public property | ChannelId | The ID of the channel.
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguageGainLevel.LanguageId Property

LanguageId Property

The ID of the language
Syntax
Json
{ Property:LanguageId }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


LanguagesConfigurationInfo Class

Describes the configuration of a language, including allocated channels and carrier.
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientLanguagesConfigurationInfo
Syntax
Json
{ JsonClass:LanguagesConfigurationInfo		Channels:<type>,
    Enabled:<type>,
    Label:<type>,
    LanguageId:<type>,
    Mode:<type>,
    SourceInput:<type>,
    SourceType:<type>,
 }

The LanguagesConfigurationInfo type exposes the following members.

Constructors
 | Name | Description
Public method | LanguagesConfigurationInfo | Initializes a new instance of the LanguagesConfigurationInfo class
Top
Properties
 | Name | Description
Public property | Channels | The channels allocated to the language
Public property | Enabled | Indicates if the channel is enabled or not
Public property | Label | The label of the language
Public property | LanguageId | The ID of the language
Public property | Mode | Indicates the audio mode for the language
Public property | SourceInput | The source input for the language, applicable when SourceType is Dicentis
Public property | SourceType | Indicates the audio source type for the language
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


CustomerRegistrationInfo.LocationName Property

LocationName Property

The location information of the customer
Syntax
Json
{ Property:LocationName }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonUserInfoPut Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonUserInfoGet
TxoConferenceApi.MessagesJsonUserInfoPut
Syntax
Json
{ JsonClass:JsonUserInfoPut		FirstName:<type>,
    LastName:<type>,
    Role:<type>,
    User:<type>,
    Password:<type>,
 }

The JsonUserInfoPut type exposes the following members.

Constructors
 | Name | Description
Public method | JsonUserInfoPut | Initializes a new instance of the JsonUserInfoPut class
Top
Properties
 | Name | Description
Public property | FirstName | (Inherited from JsonUserInfoGet.)
Public property | LastName | (Inherited from JsonUserInfoGet.)
Public property | Password |
Public property | Role | (Inherited from JsonUserInfoGet.)
Public property | User | (Inherited from JsonUserInfoGet.)
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLogs Constructor

Initializes a new instance of the JsonLogs class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.RegisterEventsRequest.Events Property

Events Property

List of events registered
Syntax
Json
{ Property:Events }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetVersionInfoRequest Class

ConferenceApiHandlerGetVersionInfoRequest Class

Parameters to GetVersionInfo
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerGetVersionInfoRequest
Syntax
Json
{ JsonClass:GetVersionInfoRequest	 }

The ConferenceApiHandlerGetVersionInfoRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerGetVersionInfoRequest | Initializes a new instance of the ConferenceApiHandlerGetVersionInfoRequest class
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonLanguageAudioMode Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonLanguageAudioMode
Syntax
Json
{ JsonClass:JsonLanguageAudioMode		LanguageId:<type>,
    Mode:<type>,
 }

The JsonLanguageAudioMode type exposes the following members.

Constructors
 | Name | Description
Public method | JsonLanguageAudioMode | Initializes a new instance of the JsonLanguageAudioMode class
Top
Properties
 | Name | Description
Public property | LanguageId |
Public property | Mode |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.SetDateTimeRequest Class

ConferenceApiHandlerSetDateTimeRequest Class

Parameters to SetDateTime
Inheritance Hierarchy
SystemObject
TxoConferenceApi.ClientConferenceApiHandlerSetDateTimeRequest
Syntax
Json
{ JsonClass:SetDateTimeRequest		DateTime:<type>,
 }

The ConferenceApiHandlerSetDateTimeRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ConferenceApiHandlerSetDateTimeRequest | Initializes a new instance of the ConferenceApiHandlerSetDateTimeRequest class
Top
Properties
 | Name | Description
Public property | DateTime | Indicates what local date and time to set in iso-8601 format
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


ConferenceApiHandler.GetDicentisConnectionStateRequest Constructor

ConferenceApiHandlerGetDicentisConnectionStateRequest Constructor

Bosch Logo
Initializes a new instance of the ConferenceApiHandlerGetDicentisConnectionStateRequest class
Syntax
Json
{ Constructor:.ctor }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonInstalledLicense.ActivationDate Property

ActivationDate Property

Syntax
Json
{ Property:ActivationDate }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


JsonMessageAudioLevelsList Class

Inheritance Hierarchy
SystemObject
TxoConferenceApi.MessagesJsonMessageAudioLevelsList
Syntax
Json
{ JsonClass:JsonMessageAudioLevelsList		Auxiliary:<type>,
    Languages:<type>,
 }

The JsonMessageAudioLevelsList type exposes the following members.

Constructors
 | Name | Description
Public method | JsonMessageAudioLevelsList | Initializes a new instance of the JsonMessageAudioLevelsList class
Top
Properties
 | Name | Description
Public property | Auxiliary |
Public property | Languages |
Top
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024


MessageAudioLevelsList.Auxiliary Property

Auxiliary Property

The audio level of the auxiliary input
Syntax
Json
{ Property:Auxiliary }
See Also

Reference

Bosch Security Systems

(c) Bosch Security System B.V., 2024